Page 9 of 11 FirstFirst ... 7891011 LastLast
Results 81 to 90 of 108
  1. #81
    Join Date
    Dec 2007
    Posts
    37
    Plugin Contributions
    0

    red flag Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Hi I guess the answer to my previous question is no

    So

    IS there a version of this that will work with v1.3.9

  2. #82
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by Amethyst_fairy View Post
    I installed and it shows up in sideboxes in admin but does not show up on store side boxes at all. I have installed and reinstalled. Should be on R side of site at bottom under onesocial.
    Did you make the changes required to our store's includes/templates/YOUR_TEMPLATE/common/html_header.php file??
    Do you have the right blog location defined in "Configuration > WordPress for Zen Cart (wp4zen) > WordPress Blog Path"?

    Quote Originally Posted by Amethyst_fairy View Post
    Also how do you tell if wordpress is installed on same sql that maybe the issue.
    You use the same DB settings in both the WP wp-config.php and ZC configure.php files. If you have the blog in a different database, you will need to move the blog tables to the same DB as the store DB.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  3. #83
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by jld View Post
    Hi I guess the answer to my previous question is no
    The answer to your previous question is addressed in the module description (which is also on the 1st page of this support thread)
    Basic Features (Free)


    • Blog Archive. Sidebox which displays a list of posts grouped by year and month. Admin configuration comes with various options.
    • Blog Categories. Sidebox displays the blog posts by category.Admin configuration comes with various options.
    • Blog Pages. A configurable sidebox to list blog pages and sub-pages. Admin configuration comes with various options.
    Could you add additional WordPress sideboxes to display inside a Zen Cart sidebox?? It's very possible dependng on the content, but you may need a developer to create these sideboxes for you.

    You could also use the Blank Sidebox contribution, and if your forum plugin supports any shortcodes that can be used inside a WordPress widget, you could use the PHP code for that shortcode inside the Blank Sidebox. For example:
    Code:
    <?php
    /**
     * blank sidebox - allows a blank sidebox to be added to your site
     *
     * @package templateSystem
     * @copyright 2007 Kuroi Web Design
      * @copyright Portions Copyright 2003-2007 Zen Cart Development Team
     * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
     * @version $Id: blank_sidebox.php 2007-05-26 kuroi $
     */
      $content = '';
      $content .= '<div id="' . str_replace('_', '-', $box_id . 'Content') . '" class="sideBoxContent">';
    
      // Replace the text and HTML tags between the apostophes on lines 19 and 20.
      // Use as many or as few lines using this model as you need for your custom content.
      // If you have a multilingual site define your text in the languages/YOUR_LANGUAGE/extra_definitions/blank_sidebox_defines.php and include it as shown in line 19.
      // If your site is monolingual, you can put the text right here as shown on line 20 (and nobody will know!)
      //$content .= '<p>' . TEXT_BLANK_SIDEBOX . '</p>';
      $content .= do_shortcode('[YOUR-SHORTCODE_HERE]');
    
      $content .= '</div>';
    ?>
    Quote Originally Posted by jld View Post
    IS there a version of this that will work with v1.3.9
    The version available in the downloads now will work with ZC v1.3.9.
    Last edited by DivaVocals; 13 Mar 2016 at 11:50 PM.
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  4. #84
    Join Date
    Feb 2008
    Posts
    529
    Plugin Contributions
    0

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    zc 1.5.5 test site on WAMP with Responsive Sheffield Blue (testing ok).
    Installed latest Wordpress on root, same address, configs etc with wp_ prefix set in zencart db. Tested - Wordpress loads correctly and no issues noted in front end or back end.

    Installed WP4zen: store side is fine and opens tests finel. Admin side opens and functions including config WP4zen. But when I go to tools/layout controller to set up the side boxes I get a blank page. It doesn't hang the site - I can backout of the page, but can't access the layout page.

    The logs generate no errors on accessing the storefront, a few errors on accessing the admin (which I also get without this mod re WAMP no ssl, version notice), and zillions when I try to open the layout controller. (I thought I saved the error message but turns out I just saved a blank folder. The errors did, however, refer over and over to the layout control, more columns called for than anticipated etc.) I've removed the mod to work on other aspects but can reinstall to replicate the error logs if helpful).

    There were some layout controller issues with 1.5.5 and the responsive templates that were resolved. So I'm wondering if there is some similar issue with this mod and zc 1.5.5, or if anything I've described jumps out at anyone as meaning x.

    When installing the mod I did change the my_ template and admin folder names, and I did merge the common/html_header file.

  5. #85
    Join Date
    Feb 2008
    Posts
    529
    Plugin Contributions
    0

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Re post#84 - I found the error message from the log:

    [26-Mar-2016 19:27:26 UTC] Request URI: /xxxxxxxxx/layout_controller.php, IP address: ::1
    #1 trigger_error() called at [C:\wamp\www\includes\functions\plugin_support.php:68]
    #2 plugin_version_check_for_updates() called at [C:\wamp\www\xxxxxxxx\includes\init_includes\init_responsive_sheffield_blue.php:8 9]
    #3 require(C:\wamp\www\xxxxxxx\includes\init_includes\init_responsive_sheffield_blu e.php) called at [C:\wamp\www\includes\autoload_func.php:48]
    #4 require(C:\wamp\www\includes\autoload_func.php) called at [C:\wamp\www\xxxxxxxxxx\includes\application_top.php:171]
    #5 require(C:\wamp\www\xxxxxxx\includes\application_top.php) called at [C:\wamp\www\xxxxxxx\layout_controller.php:10]
    [26-Mar-2016 19:27:26 UTC] PHP Notice: CURL error checking plugin versions: 60:SSL certificate problem: self signed certificate in certificate chain
    Trying file_get_contents() instead. in C:\wamp\www\includes\functions\plugin_support.php on line 68

    [26


    -Mar-2016 19:27:26 UTC] PHP Stack trace:

    [26-Mar-2016 19:27:26 UTC] PHP 1. {main}() C:\wamp\www\xxxxxxxxx\layout_controller.php:0

    [26-Mar-2016 19:27:26 UTC] PHP 2. require() C:\wamp\www\xxxxxxxxx\layout_controller.php:10

    [26-Mar-2016 19:27:26 UTC] PHP 3. require() C:\wamp\www\xxxxxxxxx\includes\application_top.php:171

    [26-Mar-2016 19:27:26 UTC] PHP 4. require() C:\wamp\www\includes\autoload_func.php:48

    [26-Mar-2016 19:27:26 UTC] PHP 5. plugin_version_check_for_updates() C:\wamp\www\xxxxxxxx\includes\init_includes\init_responsive_sheffield_blue.php:8 9

    [26-Mar-2016 19:27:26 UTC] PHP 6. trigger_error() C:\wamp\www\includes\functions\plugin_support.php:68

    [26-Mar-2016 19:27:26 UTC] Request URI: /xxxxxxxx/layout_controller.php, IP address: ::1
    #1 trigger_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:167]
    #2 queryFactory->show_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:139]
    #3 queryFactory->set_error() called at [C:\wamp\www\includes\classes\db\mysql\query_factory.php:266]
    #4 queryFactory->Execute() called at [C:\wamp\www\xxxxxxxx\layout_controller.php:66]


    [26-Mar-2016 19:27:26 UTC] PHP Fatal error: 1136:Column count doesn't match value count at row 1 :: insert into zen_layout_boxes
    (layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
    values ('responsive_sheffield_blue', 'wp_archives_sidebox.php', 0, 0, 0, 0, 0, 0, 0, 0) ==> (as called by) C:\wamp\www\xxxxxxx\layout_controller.php on line 66 <== in C:\wamp\www\includes\classes\db\mysql\query_factory.php on line 167

    [26-Mar-2016 19:27:26 UTC] PHP Stack trace:

    [26-Mar-2016 19:27:26 UTC] PHP 1. {main}() C:\wamp\www\xxxxxx\layout_controller.php:0

    [26-Mar-2016 19:27:26 UTC] PHP 2. queryFactory->Execute() C:\wamp\www\xxxxxx\layout_controller.php:66

    [26-Mar-2016 19:27:26 UTC] PHP 3. queryFactory->set_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:266

    [26-Mar-2016 19:27:26 UTC] PHP 4. queryFactory->show_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:139

    [26-Mar-2016 19:27:26 UTC] PHP 5. trigger_error() C:\wamp\www\includes\classes\db\mysql\query_factory.php:167
    The top group of statements are what I get routinely from my WAMP test version of live site and as far as I can tell in test mode aren't stopping me from doing anything. The bottlom statements are what come when I hit config/layout controller in the admin panel, resulting in a blank page.

  6. #86
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,633
    Plugin Contributions
    78

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.

  7. #87
    Join Date
    Feb 2008
    Posts
    529
    Plugin Contributions
    0

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by lat9 View Post
    Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.
    I had already applied the changes from @rbarbour post and some tips from Dr Byte, but I'll go back over them and see if I missed something or did something wrong.

  8. #88
    Join Date
    Feb 2008
    Posts
    529
    Plugin Contributions
    0

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by lat9 View Post
    Your errors have nothing to do with wp4zen, they have to do with some changes required for existing responsive templates (like Responsive Sheffield Blue) to operate within Zen Cart v1.5.5. There was a posting by @rbarbour within the past couple of days that outlined the changes required.
    My set site with no Wordpress or WP4Zen includes the barbour changes. The admin layout controller works properly.
    2nd copy of test site with Wordpress added to above, the admin layout controller works properly.(Wordpress functions when called up by localhost/wordpress)
    3rd copy of test site - above set that includes Wordpress plus addition of WP4Zen, admin panel loads, but layout controller generates the error.
    The only merge between 2nd and 3rd is the single block of code for WP4Zen in common/html_header.

    In the Sheffield Responsive common/html_header I merged only the two section of code as in the barbour posting as for test copy 1 and 2. For test copy 3 I added the section of code for WP4Zen.

    There were a lot of other differences in the zc 1.5.5 html_header - adding the two sections suggested by Barbour did make the Sheffield template function - but I wonder if some of the other part of the newer code need changing to accommodate WP4Zen. I also tried using the entire zc 1.5.5 default file with only the WP4Zen bit merged in that also didn't work and also didn't work with my test 1 or 2 site.

    Should I be asking this in a diff forum?

  9. #89
    Join Date
    Feb 2008
    Posts
    529
    Plugin Contributions
    0

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by soxophoneplayer View Post
    ...admin panel loads, but layout controller generates the error....
    Think I have this sorted. I don't know why the zc 1.5.5 layout controller works with Sheffield Blue Responsive template but not WP4Zen. But,

    in the 1.5.5 admin/layout controller, line #66, I eliminated two zero's so it now looks like this:

    PHP Code:
    // (BOF - EDIT) ZCA Responsive Components for 1.5.5

          
    $db->Execute("insert into " TABLE_LAYOUT_BOXES "
                      (layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
                      values ('" 
    zen_db_input($template_dir) . "', '" zen_db_input($file) . "', 0, 0, 0, 0, 0, 0)");

    // (EOF - EDIT) ZCA Responsive Components for 1.5.5 
    The layout contoller is now working for me with both the Sheffiled Blue and the WP4Zen installed. If its not already clear I really don't know what I'm doing but this seems to work touch wood.

  10. #90
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: WordPress® for Zen Cart® (wp4zen) [Support Thread]

    Quote Originally Posted by soxophoneplayer View Post
    Think I have this sorted. I don't know why the zc 1.5.5 layout controller works with Sheffield Blue Responsive template but not WP4Zen. But,

    in the 1.5.5 admin/layout controller, line #66, I eliminated two zero's so it now looks like this:

    PHP Code:
    // (BOF - EDIT) ZCA Responsive Components for 1.5.5

          
    $db->Execute("insert into " TABLE_LAYOUT_BOXES "
                      (layout_template, layout_box_name, layout_box_status, layout_box_location, layout_box_sort_order, layout_box_sort_order_single, layout_box_status_single, show_box_min_width)
                      values ('" 
    zen_db_input($template_dir) . "', '" zen_db_input($file) . "', 0, 0, 0, 0, 0, 0)");

    // (EOF - EDIT) ZCA Responsive Components for 1.5.5 
    The layout contoller is now working for me with both the Sheffiled Blue and the WP4Zen installed. If its not already clear I really don't know what I'm doing but this seems to work touch wood.
    As lat9 pointed out, the issue isn't this module but a problem with your template. The error you were getting and the fix you made confirms this:
    Code:
    [26-Mar-2016 19:27:26 UTC] PHP Fatal error:  1136:Column count doesn't  match value count at row 1 :: insert into zen_layout_boxes
                      (layout_template, layout_box_name, layout_box_status,  layout_box_location, layout_box_sort_order,  layout_box_sort_order_single, layout_box_status_single,  show_box_min_width)
                      values ('responsive_sheffield_blue',  'wp_archives_sidebox.php', 0, 0, 0, 0, 0, 0, 0, 0) ==> (as called by)  C:\wamp\www\xxxxxxx\layout_controller.php on line 66 <== in  C:\wamp\www\includes\classes\db\mysql\query_factory.php on line 167
    See the values I highlighted in red. this is the issue and apparently was corrected by the fix you made. There were NO columns in the layout controller SQL for these additional values. (hence the column count error)
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

 

 
Page 9 of 11 FirstFirst ... 7891011 LastLast

Similar Threads

  1. v154 Support Thread: AddToAny for Zen Cart (The Universal Sharing Platform)
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 8
    Last Post: 8 Apr 2019, 02:39 PM
  2. v155 Responsive Classic (built in to Zen Cart v1.5.5) [Support Thread]
    By picaflor-azul in forum Addon Templates
    Replies: 0
    Last Post: 17 Mar 2016, 12:30 AM
  3. Wordpress On ZC [Support Thread]
    By hira in forum All Other Contributions/Addons
    Replies: 1858
    Last Post: 17 Jan 2014, 01:24 AM
  4. Replies: 68
    Last Post: 29 Jul 2013, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR