Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45
  1. #21
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    My, my! That was fast ... v1.0.2 is now available for download!

  2. #22
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,030
    Plugin Contributions
    32

    Default Re: myDEBUG Backtrace [Support Thread]

    Quote Originally Posted by lat9 View Post
    My, my! That was fast ... v1.0.2 is now available for download!
    That's 'cause you got JUICE.. (pays to be behind the velvet rope!!)
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  3. #23
    Join Date
    Mar 2009
    Location
    Italy
    Posts
    156
    Plugin Contributions
    0

    Default Re: myDEBUG Backtrace [Support Thread]

    Hi,

    i got a strange report:
    HTML Code:
    [25-May-2015 14:59:07] PHP Warning:  debug_print_backtrace() expects exactly 0 parameters, 1 given in /var/www/vhosts/.../httpdocs/includes/extra_configures/enable_error_logging.php on line 20
    It should report something different instead of that, right?

    In every debug file is the same regerdless the error reported after.

    I checked the plugin file and it should be installed correctly... What am i missing?

  4. #24
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    @izar74: You're running on a PHP version less than 5.3.6, right?

  5. #25
    Join Date
    Mar 2009
    Location
    Italy
    Posts
    156
    Plugin Contributions
    0

    Default Re: myDEBUG Backtrace [Support Thread]

    Quote Originally Posted by lat9 View Post
    @izar74: You're running on a PHP version less than 5.3.6, right?
    ops, forgot to add the server configuration...

    Yes, the server is actually using PHP: 5.3.3, is that the problem?

  6. #26
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    Well... it's the reason! The parameter was introduced in PHP 5.3.6.

    You can edit the /includes/extra_configures/enable_error_logging.php file and its admin counterpart, changing the line that reads:
    Code:
      debug_print_backtrace (DEBUG_BACKTRACE_IGNORE_ARGS);
    to
    Code:
      debug_print_backtrace ();

  7. #27
    Join Date
    Mar 2009
    Location
    Italy
    Posts
    156
    Plugin Contributions
    0

    Default Re: myDEBUG Backtrace [Support Thread]

    Quote Originally Posted by lat9 View Post
    Well... it's the reason! The parameter was introduced in PHP 5.3.6.

    You can edit the /includes/extra_configures/enable_error_logging.php file and its admin counterpart, changing the line that reads:
    Code:
      debug_print_backtrace (DEBUG_BACKTRACE_IGNORE_ARGS);
    to
    Code:
      debug_print_backtrace ();

    Thanks a lot :-)

  8. #28
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    I've submitted v1.0.3. This version calls the debug_print_backtrace function with arguments dependent on the PHP version ... so no more PHP warnings for PHP versions less than 5.3.6 (which are no longer supported, anyway).

    If you're currently using the plugin on a later version of PHP, there is no need to update.

  9. #29
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    v1.0.3 is now available for download: https://www.zen-cart.com/downloads.php?do=file&id=1879

  10. #30
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,205
    Plugin Contributions
    72

    Default Re: myDEBUG Backtrace [Support Thread]

    I just submitted v1.1.0 for review. The information logged now contains the REQUEST_URI (actual page and parameters) and REMOTE_ADDR (the IP address) values active when the debug-log occurred.

    There have been times when an issue occurs only on a specific page's access and/or when a specific IP address is accessing (like a script kiddie forcing out-of-memory conditions), so that additional information will help in figuring out what's going on when a debug-log occurs.

 

 
Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Hebrew Support - new release [Support Thread]
    By eranariel in forum Addon Language Packs
    Replies: 12
    Last Post: 9 Oct 2019, 09:32 PM
  2. Wordpress On ZC [Support Thread]
    By hira in forum All Other Contributions/Addons
    Replies: 1858
    Last Post: 17 Jan 2014, 01:24 AM
  3. Replies: 4
    Last Post: 19 Jan 2013, 05:47 AM
  4. SnapShot [support thread]
    By skipwater in forum All Other Contributions/Addons
    Replies: 32
    Last Post: 26 Oct 2012, 08:38 PM
  5. PurpleShades Support Thread
    By kobra in forum Addon Templates
    Replies: 122
    Last Post: 18 May 2011, 07:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR