Results 1 to 10 of 10
  1. #1
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    5,620
    Plugin Contributions
    211

    Default Known Bugs (and fixes) with v1.5.3

    A summary of fixes to issues found with v1.5.3
    That Software Guy, Plugin Moderator. Store: Zen Cart Modifications
    Contributions: Quantity Discounts, Better Together, SMS on Sale, Gift Wrap at Checkout, and more.

  2. #2
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    5,620
    Plugin Contributions
    211

    Default Fresh admin install fails with too many redirects

    If you've deleted the /cache folder from your site, then admin page fails with too many redirects
    See http://www.zen-cart.com/showthread.p...81#post1251681 for resolution.
    That Software Guy, Plugin Moderator. Store: Zen Cart Modifications
    Contributions: Quantity Discounts, Better Together, SMS on Sale, Gift Wrap at Checkout, and more.

  3. #3
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default password authentication problem in zc_install--specific to v1.5.3 dated July 4, 2014

    zc_install database upgrade -- password authentication problem when entering admin password

    FIX:
    1. unzip this zc_install-includes-functions-general.php.zip file
    2. upload the general.php file to: /zc_install/includes/functions/general.php

    3. Apply the additional fix in posts #8 , #9 below.


    (OR BETTER YET, USE v1.5.4 instead!!!!!)
    Attached Files Attached Files
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: hotfix 1

    FYI - Both of the above fixes are rolled into a new zip, which is available in the usual location on SourceForge. See the download link on the home page at www.zen-cart.com
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: password authentication problem in zc_install--specific to v1.5.3 dated July 4, 2

    Problem: PayPal Express Checkout error 10486

    Fix: This isn't unique to v1.5.3. It's a change PayPal made awhile back, which has never existed in ZC prior to v1.5.4

    http://www.zen-cart.com/showthread.p...48#post1254048
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #6
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: CURL error with linkpoint_api module

    Symptom: Linkpoint_api payment module triggers CURL error "60 - SSL certificate problem", as well as "Illegal String Offset" errors in debug logs.

    Solution: Small code change, posted here: http://www.zen-cart.com/showthread.p...71#post1256771
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Authorize.net SIM module error 99

    Symptom: Authorize.net SIM module reporting error 99

    Fix: http://www.zen-cart.com/showthread.p..._currency_code
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  8. #8
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: password not accepted during zc_install database upgrade

    Symptom:
    Error:
    PHP Warning: require_once(/home/user/public_html/site/../includes/classes/vendors/password_compat-master/lib/password.php): failed to open stream: No such file or directory in /......./includes/classes/class.zcPassword.php on line 52
    SOLUTION:
    Edit /zc_install/includes/functions/general.php
    After the opening <?php line, add the following:
    Code:
      define('DIR_FS_CATALOG', zen_read_config_value('DIR_FS_CATALOG', FALSE));
      define('DIR_WS_CLASSES', 'includes/classes/');
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  9. #9
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: password not accepted during zc_install database upgrade

    Another change which appears to help address the admin-password-rejected-during-database-upgrade issue is:

    Edit /includes/classes/class.zcPassword.php
    Around line 49 you have this:
    Code:
        if (version_compare($phpVersion, '5.3.7', '<')) {
          require_once (DIR_FS_CATALOG . DIR_WS_FUNCTIONS . 'password_compat.php');
        } elseif (version_compare($phpVersion, '5.5.0', '<')) {
          require_once (DIR_FS_CATALOG . DIR_WS_CLASSES . 'vendors/password_compat-master/lib/password.php');
        }
    Change it to this:
    Code:
        if (version_compare($phpVersion, '5.3.7', '<')) {
          require_once (realpath(dirname(__FILE__)) . '/../functions/password_compat.php');
        } elseif (version_compare($phpVersion, '5.5.0', '<')) {
          require_once (realpath(dirname(__FILE__)) . '/vendors/password_compat-master/lib/password.php');
        }
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  10. #10
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.3

    THIS MAY OR MAY NOT AFFECT various v1.5.0 implementations. We're posting it here "in case". Implementing this fix is safe either way.

    Symptom: Admin Login "broken" in v1.5.0 - v1.5.5a with Google Chrome error: "Aw, snap"



    Google Chrome 54.0.2840.59 is now forcefully disallowing the use of javascript function declarations of 'animate'. This interferes with the "spinner" that appears during admin login since v1.5.0


    The fix is simple:
    1. Open /admin/login.php in a code-safe text editor, such as Sublime Text:
    2. Find and replace "animate(" with "waiting_spinner(". There will be 3 occurrences.
    3. Save
    That's it. Login should now work again.


    For a visual example of the changes, see: https://github.com/zencart/zencart/pull/1321/files
    (exact position and line numbers may differ between Zen Cart versions)


    Ref: https://www.zen-cart.com/showthread....log-into-admin
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. v155 Known Bugs (and fixes) with v1.5.5 , a, b, c, d, e
    By DrByte in forum Bug Reports
    Replies: 17
    Last Post: 16 Aug 2017, 03:25 AM
  2. v151 Known Bugs (and fixes) with v1.5.1
    By DrByte in forum Upgrading to 1.5.x
    Replies: 4
    Last Post: 18 Oct 2016, 06:17 PM
  3. v150 Known Bugs (and fixes) with v1.5.0
    By DrByte in forum Upgrading to 1.5.x
    Replies: 5
    Last Post: 18 Oct 2016, 06:17 PM
  4. v155 Known Bugs (and fixes) with v1.5.5 , a, b, c, d, e
    By DrByte in forum Bug Reports
    Replies: 0
    Last Post: 20 Mar 2016, 03:46 AM
  5. Known Bugs (and fixes) with v1.3.8 / v1.3.8a
    By DrByte in forum Upgrading from 1.3.x to 1.3.9
    Replies: 41
    Last Post: 17 Feb 2010, 01:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR