Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2005
    Location
    Chicago, IL USA
    Posts
    1,371
    Plugin Contributions
    27

    Default SSL warning in Chrome

    So I noticed on SSL pages on one of my sites, Chrome would show the X through the https in the address bar. No such issue in FF or IE.

    After digging around, it turns out Chrome does not like the form action for the advanced search in the header,

    action="http://www.mysite.com/index.php?main_page=advanced_search_result

    The fix I employed was editing
    /includes/templates/MY_TEMPLATE/templates/tpl_search_header.php

    I change line 14 from:
    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get');

    to:
    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'SSL', false), 'get');

    Feel free to chime in if there is a better way to go about this, but wanted to share in case others saw this same error or never noticed it in the first place.

  2. #2
    Join Date
    Jul 2012
    Posts
    14,216
    Plugin Contributions
    17

    Default Re: SSL warning in Chrome

    Quote Originally Posted by jeking View Post
    So I noticed on SSL pages on one of my sites, Chrome would show the X through the https in the address bar. No such issue in FF or IE.

    After digging around, it turns out Chrome does not like the form action for the advanced search in the header,

    action="http://www.mysite.com/index.php?main_page=advanced_search_result

    The fix I employed was editing
    /includes/templates/MY_TEMPLATE/templates/tpl_search_header.php

    I change line 14 from:
    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'NONSSL', false), 'get');

    to:
    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', 'SSL', false), 'get');

    Feel free to chime in if there is a better way to go about this, but wanted to share in case others saw this same error or never noticed it in the first place.
    What if instead of either 'SSL' or 'NONSSL' instead the variable $request_type was used?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  3. #3
    Join Date
    Oct 2005
    Location
    Chicago, IL USA
    Posts
    1,371
    Plugin Contributions
    27

    Default Re: SSL warning in Chrome

    That's a better approach than I had. Thanks for the suggestion.

  4. #4
    Join Date
    Jul 2012
    Posts
    14,216
    Plugin Contributions
    17

    Default Re: SSL warning in Chrome

    Quote Originally Posted by jeking View Post
    That's a better approach than I had. Thanks for the suggestion.
    Glad it worked out!
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Nov 2013
    Posts
    26
    Plugin Contributions
    0

    Default Re: SSL warning in Chrome

    Quote Originally Posted by mc12345678 View Post
    Glad it worked out!
    I'm having the same issue. Can you explain how the line of code should be written with the variable "$request_type" used? Thanks.

  6. #6
    Join Date
    Oct 2005
    Location
    Chicago, IL USA
    Posts
    1,371
    Plugin Contributions
    27

    Default Re: SSL warning in Chrome

    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', $request_type, false), 'get');

    If that doesn't do it, there may be something else causing the warning. If so, post your url.

  7. #7
    Join Date
    Nov 2013
    Posts
    26
    Plugin Contributions
    0

    Default Re: SSL warning in Chrome

    Quote Originally Posted by jeking View Post
    $content .= zen_draw_form('quick_find_header', zen_href_link(FILENAME_ADVANCED_SEARCH_RESULT, '', $request_type, false), 'get');

    If that doesn't do it, there may be something else causing the warning. If so, post your url.
    Thanks,

 

 

Similar Threads

  1. v139a search box now appearing as non SSL causing warning from Chrome
    By wootoot1234 in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 22 Feb 2015, 05:59 PM
  2. v151 SSL problem in Google Chrome
    By doooomed in forum General Questions
    Replies: 15
    Last Post: 5 Oct 2014, 12:31 PM
  3. v139a Enabling SSL causes Errors in Firefox and Chrome
    By DowntoEarthDesign in forum General Questions
    Replies: 2
    Last Post: 26 Aug 2012, 02:05 PM
  4. SSL warning in Chrome
    By alexsmith2709 in forum General Questions
    Replies: 13
    Last Post: 11 Nov 2011, 04:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR