Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2012
    Posts
    8
    Plugin Contributions
    0

    Default Receipt page not working in COWOA, CEON and Authorize.net SIM

    I'm having a problem with the receipt page not showing after cc transactions are submitted by using the authorize.net SIM payment module. Before I go into detail my client adamantly does not want cc information entered in her website. Thus, the AIM module is not an option.

    Once the authorize.net payment form is submitted, a completely blank page appears in the url: https://secure.authorize.net/gateway/transact.dll . The payment form and submission works. However, I have read and reread the SIM module set up. All Relay/Receipt/Silent URL fields are blank in the authorize.net account. the id fields are correct. Here is the log for the transaction once its been posted,
    [x_login] => *******
    [x_amount] => xxx
    [x_version] => 3.1
    [x_method] => CC
    [x_type] => AUTH_ONLY
    [x_cust_ID] => 5728
    [x_email_customer] => TRUE
    [x_company] =>
    [x_first_name] => xxx
    [x_last_name] => xxx
    [x_address] => xxx
    [x_city] => xxx
    [x_state] => xxx
    [x_zip] => xxx
    [x_country] => xxx
    [x_phone] => xxx
    [x_fax] =>
    [x_email] => xxx
    [x_ship_to_company] =>
    [x_ship_to_first_name] => xxx
    [x_ship_to_last_name] => xxx
    [x_ship_to_address] => xxx
    [x_ship_to_city] => xxx
    [x_ship_to_state] => xxx
    [x_ship_to_zip] => xxx
    [x_ship_to_country] => xxx
    [x_Customer_IP] => xxx
    [x_relay_response] => TRUE
    [x_relay_URL] =>
    https://www.antique-hardware.com/ind...action=confirm
    [x_invoice_num] =>
    [x_duplicate_window] => 120
    [x_allow_partial_Auth] => FALSE
    [x_description] => Website Purchase from Antique Hardware & More
    [x_fp_sequence] => 556
    [x_fp_timestamp] => 1394029456
    [x_fp_hash] => xxx
    [x_show_form] => PAYMENT_FORM
    [x_receipt_link_method] => POST
    [x_receipt_link_text] => Click here to complete your order.
    [x_receipt_link_url] =>
    https://www.antique-hardware.com/ind...eckout_process
    [zenid] => xxx
    [url] => https://secure.authorize.net/gateway/transact.dll
    )

    Email receipts from authorize.net work fine for each transaction.
    Has anyone else had a similar problem? Is it possible to comment lines in the code such as relay lines and receipt lines to use the authorize.net receipt form? If so, which specific lines? Help please!

  2. #2
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Receipt page not working in Authorize.net SIM

    Quote Originally Posted by Amyne View Post
    I'm having a problem with the receipt page not showing after cc transactions are submitted by using the authorize.net SIM payment module.
    1. What exactly do you mean by "receipt page"? Please be very specific.
    2. Do you get order-confirmation emails sent to you?
    3. When did this problem suddenly start happening?
    4. What plugins/addons have you installed?
    5.
    What version of PHP and MySQL is your server using?
    6.
    In what ways is your site customized or different from a brand new uncustomized install?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jun 2012
    Posts
    8
    Plugin Contributions
    0

    Default Re: Receipt page not working in Authorize.net SIM

    Quote Originally Posted by DrByte View Post
    1. What exactly do you mean by "receipt page"? Please be very specific.
    2. Do you get order-confirmation emails sent to you?
    3. When did this problem suddenly start happening?
    4. What plugins/addons have you installed?
    5.
    What version of PHP and MySQL is your server using?
    6.
    In what ways is your site customized or different from a brand new uncustomized install?
    Dr. Byte, Thanks for replying.
    1. By receipt page, I mean being directed back to the store site.
    2. Yes, the receipt emails are received.
    3. Immediately upon installing the module.
    4. Addons include CEON URI SEO, COWOA, Image Handler, QBI for quickbooks, Ultimate cross sell. Classic template.
    5. PHP = 5.4.24 ; SQL = 5.5
    6. Besides what was been changed for the addons, this site's core files should not have other modifications.

    In addition, would it be possible that file permissions and being on Sitelock Trueshield cause this?

  4. #4
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Receipt page not working in Authorize.net SIM

    Quote Originally Posted by Amyne View Post
    In addition, would it be possible that file permissions and being on Sitelock Trueshield cause this?
    No idea. You'd need to talk to whomever supports those.

    Quote Originally Posted by Amyne View Post
    4. Addons include CEON URI SEO, COWOA
    Those are probably where your problem is.

    It could well be that the URL-rewriting is interfering with normal operation.
    And the completely different checkout that COWOA gives might also be causing it.

    Perhaps someone else who uses those can chime in to offer you help with them.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jun 2012
    Posts
    8
    Plugin Contributions
    0

    Default Re: Receipt page not working in Authorize.net SIM

    Thank for your input. I hope to test these possibilities when I upgrade the site.

    Does anyone else have comments?

  6. #6
    Join Date
    Dec 2010
    Location
    U.S. State of Texas
    Posts
    76
    Plugin Contributions
    0

    Default Re: Receipt page not working in Authorize.net SIM

    I have searched several threads and found that others have had the very same issue I am about to describe but I have not seen a resolution, other than switching to AIM. Let me preface by saying that the site owner does not want to utilize AIM at this time due to not wanting cards submitted (even with SSL) on his site. So I am left with trying to figure this one out.

    Zen Cart Version: 1.5.0
    website url: allthingsdelivered-dfw.com
    php 5.3
    mySQL 5.5
    SSL - Not yet installed, pending.
    Host Company: Hostgator

    When submitting credit card information on authorize.net's site, if a credit card is declined I am being directed to https://secure.authorize.net/gateway/transact.dll. I can read through on the unformatted page that the card was declined and I confirmed with authorize.net that the transaction is processing on their end. However it appears as though the css is not being applied to the page. I have followed the set-up instructions by going to: http://www.zen-cart.com/content.php?...payment-module. All url's have been removed from response/receipt, relay response, and silent post url. To be sure, I called authorize.net and verified with them that they are seeing blank url's. Time zone is correct on the server and I am not receiving any errors upon checkout (just unformatted w/out .css) and the error log is not displaying anything other than the card was declined in the cache folder. The site is in production mode and offsite. Oh yea, when the card is approved, no issue. This is the first SIM I am setting up as most of the other sites are using first data or AIM. I hope I included enough information to receive some feedback. If I missed a thread that resolves this issue, please pass on as I couldnt' find one. If I can't get this resolved, I will do my best to talking the site owner into going AIM. Thanks again.

  7. #7
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Receipt page not working in Authorize.net SIM

    Just my three cents, but it sounds a LOT like the issue is centered with the SIM payment module.. Otherwise MANY MORE folks using COWOA and Ceon URI would have the SAME issue.. Speaking from personal experience of having clients using AIM, PayPal Express, PayPal Payments Pro, and PayPal Payflow with both of these modules (including a client who moved from AIM to PayPal Payflow), I can say that I've not had ANY issues with payments/transactions completing..

    I would take a look at the SIM module, or perhaps talk your client into considering PayPal Express if they are that INSISTENT on payments NOT being entered on their sites..
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  8. #8
    Join Date
    Dec 2010
    Location
    U.S. State of Texas
    Posts
    76
    Plugin Contributions
    0

    Default Re: Receipt page not working in Authorize.net SIM

    Thanks for your feedback. I will talk to the customer again, was just hoping that there is something I am missing or a bug that I was not aware of to resolve.

  9. #9
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    10,023
    Plugin Contributions
    32

    Default Re: Receipt page not working in Authorize.net SIM

    Quote Originally Posted by creyesx6 View Post
    Thanks for your feedback. I will talk to the customer again, was just hoping that there is something I am missing or a bug that I was not aware of to resolve.
    Yep.. not sure what your client's hesitation is, but SSL certs are easy to get these days and AFFORDABLE.. there's no reason to NOT accept credit cards on their site direct..
    My Site - Zen Cart & WordPress integration specialist
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  10. #10
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Receipt page not working in Authorize.net SIM

    Quote Originally Posted by creyesx6 View Post
    I have searched several threads and found that others have had the very same issue I am about to describe but I have not seen a resolution, other than switching to AIM. Let me preface by saying that the site owner does not want to utilize AIM at this time due to not wanting cards submitted (even with SSL) on his site. So I am left with trying to figure this one out.

    Zen Cart Version: 1.5.0
    website url: allthingsdelivered-dfw.com
    php 5.3
    mySQL 5.5
    SSL - Not yet installed, pending.
    Host Company: Hostgator

    When submitting credit card information on authorize.net's site, if a credit card is declined I am being directed to https://secure.authorize.net/gateway/transact.dll. I can read through on the unformatted page that the card was declined and I confirmed with authorize.net that the transaction is processing on their end. However it appears as though the css is not being applied to the page. I have followed the set-up instructions by going to: http://www.zen-cart.com/content.php?...payment-module. All url's have been removed from response/receipt, relay response, and silent post url. To be sure, I called authorize.net and verified with them that they are seeing blank url's. Time zone is correct on the server and I am not receiving any errors upon checkout (just unformatted w/out .css) and the error log is not displaying anything other than the card was declined in the cache folder. The site is in production mode and offsite. Oh yea, when the card is approved, no issue. This is the first SIM I am setting up as most of the other sites are using first data or AIM. I hope I included enough information to receive some feedback. If I missed a thread that resolves this issue, please pass on as I couldnt' find one. If I can't get this resolved, I will do my best to talking the site owner into going AIM. Thanks again.
    What are the settings for HTTP_SERVER and HTTPS_SERVER in your /includes/configure.php file? If you don't have SSL available on the site yet, I suggest making your HTTPS_SERVER be the same as whatever is in your HTTP_SERVER setting.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. v150 Difference Between Authorize.net (SIM) and Authorize.net (AIM)
    By joem83 in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 30 Aug 2012, 10:48 PM
  2. Authorize.Net SIM NOT WORKING
    By rspencer1762 in forum Built-in Shipping and Payment Modules
    Replies: 5
    Last Post: 11 Dec 2010, 11:03 PM
  3. USPS module not working properly and Authorize.net SIM giving error
    By aikisho in forum Built-in Shipping and Payment Modules
    Replies: 3
    Last Post: 3 Jul 2010, 12:44 AM
  4. Authorize.Net SIM Module not working right for us
    By chaoscube in forum Built-in Shipping and Payment Modules
    Replies: 2
    Last Post: 12 Sep 2008, 09:53 PM
  5. pls help: Authorize.net SIM Response/Receipt URL and integrating vertual terminal
    By greenhat in forum Built-in Shipping and Payment Modules
    Replies: 6
    Last Post: 30 Aug 2008, 08:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR