Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Aug 2010
    Posts
    53
    Plugin Contributions
    0

    red flag Poodle Help Fix - it's not working!!!

    Hi,

    The fix that Dr.Byte is not working for me. The file authorizenet_aim.php has already been comment out

    // curl_setopt($ch, CURLOPT_SSLVERSION, 3);

    and the orders don't go through authorize.net.

    Please help me. What should I do?

    Thanks

  2. #2
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Poodle Help Fix - it's not working!!!

    Hi,

    Try replacing /includes/modules/payment/authorizenet_aim.php with the one in the zip I've attached here. It should be compatible with ZC v1.3.9a thru v1.5.3. (And may be fine on 138 as well).
    Attached Files Attached Files
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Dec 2007
    Posts
    1
    Plugin Contributions
    0

    Default Re: Poodle Help Fix - it's not working!!!

    DrByte your authorizet.net_aim.php file is significantly different from the one with ZC v1.3.9b.

    For me, using just the modification:
    // curl_setopt($ch, CURLOPT_SSLVERSION, 3);

    Worked for my site.

  4. #4
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Poodle Help Fix - it's not working!!!

    It also includes a handful of tweaks and updates to the AIM standards.

    But really, if you're still using 1.3.9, you really ought to be scheduling an upgrade really soon.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Nov 2014
    Location
    arizona
    Posts
    3
    Plugin Contributions
    0

    Default Re: Poodle Help Fix - it's not working!!!

    I have tried to use your zip file, but it does not work with 1.3.9d. Do you know what i have to change in the PHP file to make it work?

  6. #6
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Poodle Help Fix - it's not working!!!

    Quote Originally Posted by korylazar View Post
    I have tried to use your zip file, but it does not work with 1.3.9d. Do you know what i have to change in the PHP file to make it work?
    What's the error message?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Nov 2014
    Location
    arizona
    Posts
    3
    Plugin Contributions
    0

    Default Re: Poodle Help Fix - it's not working!!!

    it is still coming up with a communication error.

  8. #8
    Join Date
    Nov 2014
    Location
    arizona
    Posts
    3
    Plugin Contributions
    0

    Default Re: Poodle Help Fix - it's not working!!!

    Quote Originally Posted by korylazar View Post
    it is still coming up with a communication error.
    Communications Error - Please notify webmaster. - Your credit card could not be authorized for this reason. Please correct the information and try again or contact us for further assistance.

  9. #9
    Join Date
    Jan 2004
    Posts
    65,255
    Blog Entries
    7
    Plugin Contributions
    226

    Default Re: Poodle Help Fix - it's not working!!!

    In v1.3.9 the debug logs were typically put into the /cache/ folder on your server. You'll need to use FTP to look at that folder, and then look for the most recent AIM_xxxxxxx.log files.
    Inside the files will be the actual communications log for the attempted transactions, including the details which explain what's failing.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  10. #10
    Join Date
    Nov 2014
    Location
    Texas
    Posts
    1
    Plugin Contributions
    0

    Default Re: Poodle Help Fix - it's not working!!!

    Quote Originally Posted by DrByte View Post
    Hi,

    Try replacing /includes/modules/payment/authorizenet_aim.php with the one in the zip I've attached here. It should be compatible with ZC v1.3.9a thru v1.5.3. (And may be fine on 138 as well).
    Made an account just to say thank you for posting this! Thanks DrByte!! The zip file worked flawlessly on v1.5.3

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. PayPal Express Checkout Error after POODLE fix
    By Three Sisters in forum PayPal Express Checkout support
    Replies: 8
    Last Post: 22 Apr 2015, 12:07 AM
  2. v139h error (7) couldn't connect to host with paypal after Poodle fix
    By p1drobert in forum PayPal Express Checkout support
    Replies: 6
    Last Post: 10 Feb 2015, 01:43 AM
  3. v139h Completing POODLE fix for PayPal but no UPS counts
    By hara in forum PayPal Express Checkout support
    Replies: 4
    Last Post: 27 Jan 2015, 07:09 PM
  4. v139h Completing POODLE fix for PayPal
    By avamcd in forum PayPal Express Checkout support
    Replies: 2
    Last Post: 17 Nov 2014, 08:06 PM
  5. v151 Authorize.net not working after Nov 4 2014. SSL? Poodle
    By cyberfolli in forum Built-in Shipping and Payment Modules
    Replies: 6
    Last Post: 7 Nov 2014, 06:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR