Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2009
    Posts
    14
    Plugin Contributions
    0

    Default poodlefix paypal and older v1.38a zencart builds

    Hello folks

    I received an email from paypal today with the news about SSL3 etc.

    On following the very good advice given by DrByte in how to "comment out" the curlopt lines I cannot find these lines of code at all???

    I am using v1.38a zencart with the paypal module but I have been through the paypal_curl.php and paypaldp.php from the hosted files and no where is there a mention of curlopt_sslversion etc??

    Were these lines only included with later versions of zencart??

    Any help or advice would be most welcome.

    I am thinking of taking the plunge of updating to the latest version of zencart but there have been SO many changes to templates, modules etc over the years I would not have a clue where to start :)

    Thanks in advance.

  2. #2
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,010
    Plugin Contributions
    25

    Default Re: poodlefix paypal and older v1.38a zencart builds

    If you have not updated your site since v1.3.8a, it could probably do with a facelift anyway. The best route for you would be to install a new v1.5.3 copy of Zen Cart and import the database from your existing version, then "upgrade" the db using the Zen Cart installer zc_install. This process is covered in the tutorials linked at the top of this page.

    You can choose which mods to install based on how useful they really are to you - this is a good opportunity to trim out mods that you can do without.

    You do all this without touching your existing site, then when all is ready, you switch over to the new site (an oversimplification, but that's the gist of it.)
    http://www.zen-cart.com/entry.php?3-...d-of-upgrading

  3. #3
    Join Date
    Jan 2009
    Posts
    14
    Plugin Contributions
    0

    Default Re: poodlefix paypal and older v1.38a zencart builds

    Thanks for that - you make it sound VERY easy and something I should have done a while ago LOL. I am just trying to figure out if the older version of zencart will be effected by the paypal SSL change on Dec 3rd as there is no option listed in the 2 paypal module php files that I can find??
    I cannot find a line in the php files anywhere as "curlopt_sslversion" - very odd!

  4. #4
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: poodlefix paypal and older v1.38a zencart builds

    The only sslversion 3 setting in original ZC v1.3.8a files is in the class.linkpoint_api.php file. Not in paypal files.

    HOWEVER there were serious security vulnerabilities in v1.3.8a and thus it is highly recommended that you upgrade your site.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Jan 2009
    Posts
    14
    Plugin Contributions
    0

    Default Re: poodlefix paypal and older v1.38a zencart builds

    Many thanks Dr Byte for the input.

    Am I correct in thinking the older ZC without the sslversion in the paypal files setting may still work then after Dec 3rd?

    I am now going to go ahead with an "upgrade" and as gjh42 said above it would be a good time to remove old modules etc and clean the site up.

    Thank you both for the advice - much appreciated.

  6. #6
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: poodlefix paypal and older v1.38a zencart builds

    Quote Originally Posted by Josh4u View Post
    Many thanks Dr Byte for the input.

    Am I correct in thinking the older ZC without the sslversion in the paypal files setting may still work then after Dec 3rd?
    Yes. That will give you some time to work on your upgrade.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    May 2011
    Posts
    7
    Plugin Contributions
    0

    Default Re: poodlefix paypal and older v1.38a zencart builds

    Quote Originally Posted by Josh4u View Post
    Many thanks Dr Byte for the input.

    Am I correct in thinking the older ZC without the sslversion in the paypal files setting may still work then after Dec 3rd?

    I am now going to go ahead with an "upgrade" and as gjh42 said above it would be a good time to remove old modules etc and clean the site up.

    Thank you both for the advice - much appreciated.
    I have same issue as you, mine if i put in sandbox mode it gives me timeout error? I don't think it's gonna work. Have you tried yours in sandbox mode?

  8. #8
    Join Date
    Jan 2009
    Posts
    14
    Plugin Contributions
    0

    Default Re: poodlefix paypal and older v1.38a zencart builds

    To be honest I took the advice from Dr Byte and upgraded to the latest version.

    Not that difficult to be honest and not nearly as bad as I thought it would.

    i have attached the screengrab that I took of a posting on this forum about how to easily upgrade.

    Make sure that you back up the database and the existing files FIRST.

    I followed the instructions on the screengrab and had my store up again in less than 2 hours - that also included the setting up of the new shipping and payment modules along with other "addon" modules which I had used previously (reward module, html editor etc).

    The site does now appear to work better and after also changing the paypal config files to cope with the PayPal SSL rules from Dec 3rd it is all working a treat!

    Good luck but if the worst comes to the worst you have the exising files and sql database backup that you can always go back to :o)
    Name:  ZenCart update instructions.jpg
Views: 44
Size:  80.7 KB

 

 

Similar Threads

  1. Using latest PayPal Express Checkout with older version of ZenCart
    By jeffmic in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 22 Sep 2010, 11:09 PM
  2. Quick Updates 2.0 for zencart 1.38a
    By myworld20091 in forum All Other Contributions/Addons
    Replies: 3
    Last Post: 28 Nov 2008, 12:15 PM
  3. Replies: 2
    Last Post: 1 Oct 2007, 08:00 PM
  4. Older ZenCart version
    By JayCali in forum General Questions
    Replies: 1
    Last Post: 28 Feb 2007, 07:52 AM
  5. Need to integrate into older version of ZenCart...
    By aml12 in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 15 Jan 2007, 04:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR