Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Join Date
    Oct 2011
    Posts
    41
    Plugin Contributions
    0

    Default Payment modules missing in Admin

    This is for a 1.39 migration to 1.54.
    The products/groups are displaying properly, so at least that part of the database migration worked.
    When I look at payment methods in Admin, only Authorize.net shows up, and no part of that bar responds to a click (so no activation or editing).

    The includes/payment folder has the authorizenet subfolder and the authorizenet/authorizenet_aim/authorizenet_echeck files (as a well as what appears to be all of the other payment modules).
    This is being set up on a local Ubuntu 14.04 server.
    Any troubleshooting steps would be much appreciated.

  2. #2
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,825
    Plugin Contributions
    9

    Default Re: Payment modules missing in Admin

    This appears when selecting/trying to select authorizenet (AIM)
    Code:
    ALERT: For security reasons, Installation of this module is disabled until your Admin is configured for SSL.
    So as you are on a local setup - do you have a ssl certificate installed
    Zen-Venom Get Bitten

  3. #3
    Join Date
    Jul 2012
    Posts
    15,096
    Plugin Contributions
    17

    Default Re: Payment modules missing in Admin

    If as stated that admin side is only showing one payment method and even that is only partially shown, then suggest reviewing logs folder as seeing a partially blank window.

    http://www.zen-cart.com/content.php?124-blank-page
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  4. #4
    Join Date
    Oct 2011
    Posts
    41
    Plugin Contributions
    0

    Default Re: Payment modules missing in Admin

    I do have one installed, but I notice that when I enter an https://shoppingcart address as a customer would, the https:// stays in the browser window. When I do that on an admin screen, it rewrites the url address to only show the url (no https://). So I'll see if I can sort that. This is the first time I've tried to bring up ZenCart on my very own server, so I'm still doing the whole server configuration thing by cookbook, rather than experience. The SSL may not be correctly set. Thanks!

  5. #5
    Join Date
    Oct 2011
    Posts
    41
    Plugin Contributions
    0

    Default Re: Payment modules missing in Admin

    No evidence of files not loading in the logs.
    In terms of the mechanics of displaying the payment modules, what file is looking at that payment module folder? Or -since I migrated a 1.39 database as part of this - is that list of modules in the database? If I can get a high-level picture of this, I can do some step-by-step troubleshooting.
    Thanks very much. I appreciate any time spent replying to these questions.

  6. #6
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,471
    Plugin Contributions
    6

    Default Re: Payment modules missing in Admin

    Check the directory:
    /includes/modules/payment

    and ensure that there are no renamed files nor any backup files in the directory ...

    Then check that all of the files are the code files for each one ...

    Next, check the directory:
    /includes/languages/english/modules/payment

    and ensure that there is a matching language file for each of the files in:
    /includes/modules/payment

    and ensure that each file is, in fact, the language file containing the define statements and that you have not accidentally loaded a Payment modules code file into the language file ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  7. #7
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,186
    Plugin Contributions
    7

    Default Re: Payment modules missing in Admin

    Step#1 Follow Ajeh's instructions/advice in post#6.

    If the problem persists...

    Quote Originally Posted by David R View Post
    When I look at payment methods in Admin, only Authorize.net shows up, and no part of that bar responds to a click (so no activation or editing).
    There would generally be three "Authorize.net" modules that should appear, the SIM, the AIM, and the eCheck.

    Would I be right in assuming that only the 1st of these three are showing? or are all three showing?

    The reason I ask is because if it is a problem not related to any of Ajeh's suggestions, the actual cause is more often than not in the code for the module that gets loaded immediately AFTER the one that appears on screen.

    For example, if you can see the SIM module, and nothing else, the problem most likely has something to do with the AIM module. If you can see both the SIM and the AIM modules, the problem is most likely related to the echeck module, if you can see all three, then the COD module (if installed) is the most likely suspect.

    If you get really stuck, try deleting the files for all of the modules (from both the languages and modules/payment folders) and re-adding them one at a time, ensuring that you do so in pairs - that is to say, each module has two (essential) files the module itself, and its language file, which need to be added/removed as a unit.

    Alternatively you could try removing the files pair by pair until the problem goes away. The last pair removed will be the one that is causing the problem.

    In my experience, the most common cause of the symptom you describe is due to a backup of one of the files residing in the same folder. Such backup are ok as long as they *don't* end with a .php extension.

    eg:
    authorizenet.bak will be fine.
    authorizenet_bak.php will cause the symptoms you describe.

    Cheers
    RodG
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

  8. #8
    Join Date
    Jul 2012
    Posts
    15,096
    Plugin Contributions
    17

    Default Re: Payment modules missing in Admin

    And all of that should be evidenced in the logs directory (assuming the path is setup correctly in the admin/includes/configure.php to capture an error log. The absence of any logs suggests an error in that file which could be possible depending on how the file in the directory was "generated" seeing as this was an upgrade.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  9. #9
    Join Date
    Oct 2011
    Posts
    41
    Plugin Contributions
    0

    Default Re: Payment modules missing in Admin

    I really appreciate the responses. This is what makes ZenCart so worthwhile to me. Sorry for the delayed update.
    There are no backup files in the folders. The languages files match the program files, and are actually language and program files, respectively :-) (that was wonderful).
    There's nothing relevant to this in the logs folder, and I checked the path specification in the configure file.
    I also tried switching languages (4 set up) and templates (back to Zen green), but those changes had no effect.
    It is just the SIM method loading. So the next step will be to pull all the files, as suggested, and add them back in.
    If that doesn't produce any results, I'll consider starting over to see if I can spot the issue as I rebuild it.
    I'm thinking it might be smart to test the payment, discount and shipping modules *before* I change the template, add the languages, reload the old MySQL data, etc...
    Thank you for the list of action items. It's a huge help. I'll report back either way.

  10. #10
    Join Date
    Jan 2004
    Posts
    65,399
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Payment modules missing in Admin

    Quote Originally Posted by David R View Post
    I'm thinking it might be smart to test the payment, discount and shipping modules *before* I change the template, add the languages, reload the old MySQL data, etc...
    Ya, that's a helpful step I try to remember to do too, as it rules out things, or points out where/when a problem starts (or didn't start).

    What payment modules are you normally using? You could delete the files for modules and corresponding lang files for whichever ones you don't use, if that'll help you debug things. You can put them back later if you want.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. payment modules missing in admin area
    By nemy in forum Addon Payment Modules
    Replies: 9
    Last Post: 6 Jan 2016, 09:15 PM
  2. Protx Module Missing in Payment Modules List in my admin
    By edzpgt in forum Addon Payment Modules
    Replies: 15
    Last Post: 24 Jul 2009, 07:37 PM
  3. Payment modules missing in my admin
    By scottrof in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 11 Oct 2007, 05:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR