Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,825
    Plugin Contributions
    9

    Default Re: configuration problem -

    You can create a file name it "phpinfo.php" with the following
    Code:
    <?
    php phpinfo();
    ?>
    FTP it to the root(public_html) of your account and navigate to it http://your_domain/phpinfo.php
    No need to get into your ZenCart admin
    Then going back to the installer and launching to http://www.stitchnframeonline.com/ze...v1.5.4/myadmin to no avail...
    When you state "launching" - exactly what are you doing???
    Are you re-running zc_install - you should be
    Zen-Venom Get Bitten

  2. #12
    Join Date
    Jun 2009
    Location
    Des Moines, Iowa USA
    Posts
    585
    Plugin Contributions
    0

    Default Re: configuration problem -

    Oh TY guys for all the patience!!!

    First - I am a newbie( well not technically but ...) The only way I THOUGHT to check on the PHP version was to go to cpanel and check the version the server is using.. the indicated version was checked.. I will have to call bluehost and check on the procedure....

    Second.. You are right RodG it is very tempting to reuse the old file (but if anyone else is listening) DONT CUT CORNERS! I have learned that a long time ago - however with my overworked stressed life I will sometimes overread some things. not this last time. Now when I did a install wirh zc_install... i deleted the confiure files from both folders and uploaded via fizella the 1.5.4 dist-configre.php did not rename it (assumed the install would do that) and just renamed the admin files to launch from the install screen...



    When you state "launching" - exactly what are you doing???
    Are you re-running zc_install - you should be
    Thinking that maybe i did not code the address correctly in the address line, I navigated to the admin from the last page of the zc installer that is "go to admin"

    With this - I will go reread everything Kobra; RodG and everyone else has advised and get back with a yea or nea and an explanation of what has occurred - TIA SO much...

  3. #13
    Join Date
    Jun 2009
    Location
    Des Moines, Iowa USA
    Posts
    585
    Plugin Contributions
    0

    Default Re: configuration problem -

    You can create a file name it "phpinfo.php" with the following
    Code:

    <?
    php phpinfo();
    ?>

    FTP it to the root(public_html) of your account and navigate to it http://your_domain/phpinfo.php
    No need to get into your ZenCart admin
    Worked great!!

    Oohh! It says on my php config in the cpanel that the version PHP 5.4 is not compatible with ZC1.3.9 and ZC1.5.1 --which is what my two websites are right now. if I upgrade the PHP version I guess I will assume that both websites will go down?!

  4. #14
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    7,500
    Plugin Contributions
    8

    Default Re: configuration problem -

    You can make minor adjustments to the existing that will allow them to "work" with 5.4 while you finish the update.
    https://www.zen-cart.com/showthread....HP-5-3-5-4-5-5
    Did you read the posting tips?!?
    Responsive Color Changes for 155-156c demo here.
    Zen Cart PCI Compatible Hosting

  5. #15
    Join Date
    Jun 2009
    Location
    Des Moines, Iowa USA
    Posts
    585
    Plugin Contributions
    0

    Default Re: configuration problem -

    Hi everyone - small update - just go off the phone with bluehost and the tech said that I as definitely using 5.4PHP. He said that the .htaccess in the root was the default and that everything went over to that version. I did check the phpinfo and it said it was on 5.2 Rod said I was on 5.2 bluehost said 5.4... soooo Bluehost did a search for 5.2 thru all my files and found nothing that would override this... This is so totally weird!! Here is the .htaccess:

    # Use PHP54 as default
    AddHandler application/x-httpd-php54s .phpOptions All -Indexes
    # For security reasons, Option all cannot be overridden.
    #Options All -Indexes
    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

    # disable directory browsing

    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

    # enable directory browsing
    # For security reasons, Option all cannot be overridden.
    # Options All +Indexes
    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch +Indexes

  6. #16
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,186
    Plugin Contributions
    7

    Default Re: configuration problem -

    Quote Originally Posted by stitchnkitty View Post
    Hi everyone - small update - just go off the phone with bluehost and the tech said that I as definitely using 5.4PHP. He said that the .htaccess in the root was the default and that everything went over to that version. I did check the phpinfo and it said it was on 5.2 Rod said I was on 5.2 bluehost said 5.4...
    Just to be pedantic, it wasn't I that said you were using 5.2, it was the ZenCart install script (and I can assure you that THAT would be much more reliable than anything I say/said).

    Quote Originally Posted by stitchnkitty View Post
    soooo Bluehost did a search for 5.2 thru all my files and found nothing that would override this... This is so totally weird!! Here is the .htaccess:

    # Use PHP54 as default
    AddHandler application/x-httpd-php54s .phpOptions All -Indexes
    # For security reasons, Option all cannot be overridden.
    #Options All -Indexes
    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

    # disable directory browsing

    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch -Indexes

    # enable directory browsing
    # For security reasons, Option all cannot be overridden.
    # Options All +Indexes
    Options ExecCGI Includes IncludesNOEXEC SymLinksIfOwnerMatch +Indexes
    Although I can't say with 100% certainty, but if this is *exactly* how the .htaccess reads then it isn't going to work as expected. It looks like a few of the lines have been joined.

    eg:
    AddHandler application/x-httpd-php54s .phpOptions All -Indexes

    Should be:
    AddHandler application/x-httpd-php54s .php
    Options All -Indexes

    The joining of the ".phpOptions" means there'll not be a match on the ".php" files so the php54s handler will never be invoked, which means the default .PHP handler will be used instead, and based on the phpinfo output (and the ZenCart installer) the default handler is (apparently) php5.2.


    Cheers
    RodG
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

  7. #17
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    6,186
    Plugin Contributions
    7

    Default Re: configuration problem -

    Update:

    If after fixing the joined lines in the .htaccess file you find you still have the same problem I suggest you place a copy of the .htaccess file into the /zen-cart-v1.5.4/ folder.

    OR, probably a better option.... According to BlueHost
    -------------------------------------------------------------------------
    All our servers support (i.e. are capable of running) PHP 5.2 and PHP 5.4. The default version is 5.4.x but you can follow the directions below to use PHP 5.2.X instead. However we are working on phasing out PHP 5.2.x from our servers as it is no longer supported by its developers.
    -------------------------------------------------------------------------

    If I/we assume that this statement is still correct, then you can probably just delete the .htaccess file (in the root folder) completely. No need to place a copy in the /zen-cart-v1.5.4/ folder either.

    A word of caution though, if your *current* store is an older version that isn't compatible with V5.4 this could cause it to break. In fact you MAY even break the original store when you fix the .htaccess file in the root directory (as this will/should cause *that* store to be use whatever is defined in the file.

    To help clarify...

    If the zencart installation in http://www.stitchnframeonline.com/ requires php5.2 and the installation in
    http://www.stitchnframeonline.com/zen-cart-v1.5.4/ requires php5.4

    AND the server default PHP is V5.4

    You will need
    AddHandler application/x-httpd-php52 .php in the http://www.stitchnframeonline.com/.htaccess file
    and you won't need the http://www.stitchnframeonline.com/zen-cart-v1.5.4/.htaccess file at all

    If the server default is php5.2

    You will need
    AddHandler application/x-httpd-php54 .php in the http://www.stitchnframeonline.com/zen-cart-v1.5.4/.htaccess file
    and you won't need the http://www.stitchnframeonline.com/.htaccess file at all

    Although not possible, if the server didn't have a default PHP version, you will need
    AddHandler application/x-httpd-php54 .php in the http://www.stitchnframeonline.com/zen-cart-v1.5.4/.htaccess file, and
    AddHandler application/x-httpd-php52 .php in the http://www.stitchnframeonline.com/.htaccess file

    IMPORTANT#1: If the server is using the Suhosin patch you will need to add an 's' after the version number (as per your current .htaccess file which has AddHandler application/x-httpd-php54s

    IMPORTANT#2: It *appears* that the 's' is only a requirement for php52 with Suhosin. The 's' in the php54 is (apparently) unique to BlueHost, and is used to signify 'single host' and/or 'all sub folders', and this being the case I can't say for sure what the results will be if you don't have the 's' after the '54' - You may need to experiment a little here.
    I suggest you place the phpinfo() script in both folders (the root of the existing store, and the root of the new/updated store and point your browser to each one individually to verify that the 'correct' version is given for each store.

    Cheers
    RodG
    Ozpost - The Ultimate Shipping module for Australian Merchants. Click these links for its Homepage, or Download from Zen-Cart.com.

  8. #18
    Join Date
    Jun 2009
    Location
    Des Moines, Iowa USA
    Posts
    585
    Plugin Contributions
    0

    Default Re: configuration problem -

    RodG you are a genius!!! And the way you explain things is so totally understandable!!!!

    I did insert the phpinfo.ini into the zen-cart-v1.5.4 folder-- and checked the version it was 5.2
    Then inserted the corrected .htaccess into that same folder and checked the PHP version.. and yes it did indeed change to 5.4 ..

    And then the admin came up... Now I am wondering if running the zc_install on 5.2 and then changing it to 5.4 would effect the functionality of the website? I am thinking not,otherwise after every upgrade everyone would have to reinstall, but need you expert confirmation on this...
    With the limited messing at this time, I found that the template access was denied(This would be in the Template Selection section, templates install, preview, Access denied).
    I am thinking this a totally different issue....

    I will, in the next couple of days, check to see if the conversion to 5.4 in my root will indeed "break" the sites.

    TIA sooo much!!!!!

  9. #19
    Join Date
    Jul 2012
    Posts
    15,096
    Plugin Contributions
    17

    Default Re: configuration problem -

    Running the install under PHP 5.2 and then upping to 5.4 will have no effect on the upgrade previously performed. If files were changed to support the upgrade, they should be restored to original, but the PHP shift does not affect the install.

    Suggest a new thread for the lack of permission, but that issue is separate and recommend checking ability of accessing other options as part of bounding the issue.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  10. #20
    Join Date
    Jun 2009
    Location
    Des Moines, Iowa USA
    Posts
    585
    Plugin Contributions
    0

    Default Re: configuration problem -

    Great TY -

    Lack of permissions I think was due to multiple reinstalls and of course the support override files are no longer there. Need to upload. If there are further issues I will indeed start a new thread!!

    Yea!!!! TY

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. configuration.php problem?
    By carter in forum Templates, Stylesheets, Page Layout
    Replies: 4
    Last Post: 15 Apr 2009, 12:55 PM
  2. configuration problem
    By stregoi in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 10 Apr 2007, 09:42 PM
  3. File Configuration problem
    By virago in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 15 Aug 2006, 09:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR