Page 12 of 12 FirstFirst ... 2101112
Results 111 to 116 of 116
  1. #111
    Join Date
    Sep 2008
    Location
    Cleethorpes
    Posts
    1,219
    Plugin Contributions
    6

    red flag Re: WorldPay Module version 3.0 - Support thread

    Quote Originally Posted by niccol View Post
    Nick

    Once again, I would encourage you to look at other options than WorldPay

    You'd have to say which version of the module you were using to get a proper solution. But for whatever reason the version number is not being set in the class.

    You should look for a line near the top that says something like:

    Code:
    $this->moduleVersion = '3.0';
    If that is there then you need to work out why it is not being carried as far as;

    Code:
    $db->Execute("INSERT INTO " . TABLE_CONFIGURATION . " (configuration_key, configuration_value,  configuration_group_id, date_added) VALUES ('MODULE_PAYMENT_WORLDPAY_VERSION', '".$this->moduleVersion."', '6', now())");
    If you can't work it out then you could just replace , '".$this->moduleVersion."', with ,'3',
    Hi Nick, nice to hear from you again by the way. Hows lockdown for you?

    The problem I have is that Worldpay is required by the client. I have it working on another site so I don't know what is different.

    I ended up putting the table in manually. But still it doesn't work, however I will try your ideas as it might be the installer needs to run and it can't if the table is already there. I'll give it a go anyway
    Nick Smith - Venture Design and Print
    https://venturedesignandprint.co.uk

  2. #112
    Join Date
    Sep 2008
    Location
    Cleethorpes
    Posts
    1,219
    Plugin Contributions
    6

    red flag Re: WorldPay Module version 3.0 - Support thread

    Quote Originally Posted by Nick1973 View Post
    Hi Nick, nice to hear from you again by the way. Hows lockdown for you?

    The problem I have is that Worldpay is required by the client. I have it working on another site so I don't know what is different.

    I ended up putting the table in manually. But still it doesn't work, however I will try your ideas as it might be the installer needs to run and it can't if the table is already there. I'll give it a go anyway
    Well I have it sort of loaded, but I don't see all the options for entering WorldPay details correctly.

    Name:  Screenshot 2020-04-20 at 17.02.02.jpg
Views: 63
Size:  35.1 KB
    Nick Smith - Venture Design and Print
    https://venturedesignandprint.co.uk

  3. #113
    Join Date
    Sep 2008
    Location
    Cleethorpes
    Posts
    1,219
    Plugin Contributions
    6

    Default Re: WorldPay Module version 3.0 - Support thread

    Quote Originally Posted by Nick1973 View Post
    Hi Nick, nice to hear from you again by the way. Hows lockdown for you?

    The problem I have is that Worldpay is required by the client. I have it working on another site so I don't know what is different.

    I ended up putting the table in manually. But still it doesn't work, however I will try your ideas as it might be the installer needs to run and it can't if the table is already there. I'll give it a go anyway
    Hi Nick, it looks like we actually went through all this once before and I managed to get a working version of the module. I forgot all about it to be fair. The site that it's working on is marthill.co.uk, and they don't have any issues at present. So I've downloaded all the files in order of the module, I'm not sure if this will fix the issues, but I can give it a try.
    Nick Smith - Venture Design and Print
    https://venturedesignandprint.co.uk

  4. #114
    Join Date
    Nov 2020
    Posts
    162
    Plugin Contributions
    1

    Default Re: WorldPay Module version 3.0 - Support thread

    Does this work on 1.57b? reading the thread it seems like i may have troubles? just gone live today with them and thought before i go installing it is there an updated version since this release, perhaps named different?

  5. #115
    Join Date
    Apr 2013
    Location
    eglisau switzerland
    Posts
    559
    Plugin Contributions
    0

    Default Re: WorldPay Module version 3.0 - Support thread

    Does this plugin support the EU required Strong Customer Authentication (SCA)?

    Thanks for any info.

  6. #116
    Join Date
    Jun 2013
    Location
    United Kingdom
    Posts
    38
    Plugin Contributions
    4

    Default Re: WorldPay Module version 3.0 - Support thread

    For anyone having callback issues (most notably 301), I believe I have identified the cause.

    With Configuration > Sessions > Prevent Spider Sessions set to True, Zen Cart identifies the WorldPay callback as a spider (due to the WorldPay user agent of WJHRO\/1.0 (WorldPay Java HTTP Request Object) (java matches against /includes/spiders.txt).

    This can be avoided by setting Configuration > Sessions > Prevent Spider Sessions set to False, or changing:

    PHP Code:
    } elseif (SESSION_BLOCK_SPIDERS == 'True' ) { 
    to

    PHP Code:
    } elseif (SESSION_BLOCK_SPIDERS == 'True' && $_GET['main_page'] != 'wp_callback' ) { 
    Which is line 84 in /includes/init_includes/init_sessions.php (copy file to /includes/init_includes/overrides/init_sessions.php first, or modify the existing file in the /includes/init_includes/overrides/ directory if it already exists).

 

 
Page 12 of 12 FirstFirst ... 2101112

Similar Threads

  1. MultiSite Module Support Thread
    By Gerome in forum All Other Contributions/Addons
    Replies: 2215
    Last Post: 21 Sep 2022, 05:43 AM
  2. WorldPay Module version 2.0 - Support thread
    By philip_clarke in forum Addon Payment Modules
    Replies: 729
    Last Post: 4 Nov 2017, 08:23 AM
  3. v151 Codetrio Sphinx Search Version 1.0 Support Thread
    By imranulh in forum All Other Contributions/Addons
    Replies: 5
    Last Post: 16 Jul 2014, 01:24 AM
  4. Simple SEO URL (OLD version) [support thread]
    By yellow1912 in forum All Other Contributions/Addons
    Replies: 5053
    Last Post: 30 Jun 2014, 02:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR