Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    Default Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    So I've just installed Wamp (2.5) and I want to get a copy of an already existing ZenCart site to work in the wamp server so that changes can be tested there first before being rolled out live.

    My ZenCart (1.5.0) versions are:
    PHP: 5.3.5
    MySQL: 5.1.54
    Apache Server (don't know what version from Tool -> Server Info)
    Database Patch Level 1.5.0

    I've tried a few sources of instruction on how to get it working, and even seem to have successfully installed zencart in a separate directory on wamp (www/zencart/). But when trying to visit the site from Wamp (www/MySite/index.php/) I get the ZenCart message about either not having installed zencart, or having incorrect paths for configure.php files. I tried to make some changes to paths in configure.php according to the guides that I'd found but none of the changes were successful.

    Mostly I'm interested in a step by step guide to go from fresh install of Wamp to a running copy of my site in the test environment - if possible. Otherwise point-and-shoot troubleshooting would still be helpful.

    I tried to provide clarifying information and explanation of the issue I'm having but if anything more is needed I can provide it so as to best describe what is/is not working.

  2. #2
    Join Date
    Aug 2009
    Location
    Longs, SC
    Posts
    626
    Plugin Contributions
    2

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Quote Originally Posted by RobertH View Post
    I've tried a few sources of instruction on how to get it working, and even seem to have successfully installed zencart in a separate directory on wamp (www/zencart/). But when trying to visit the site from Wamp (www/MySite/index.php/) I get the ZenCart message about either not having installed zencart, or having incorrect paths for configure.php files. I tried to make some changes to paths in configure.php according to the guides that I'd found but none of the changes were successful.
    When you say you successfully installed zencart what do you mean? Did you create a database, copy the zencart files to the directory, and run the install? Did you copy the files from your existing site and try to edit the config files? Did you create a database in the wamp environment and import your existing database? It would help if you give more info on what steps you executed.

  3. #3

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Quote Originally Posted by badarac View Post
    When you say you successfully installed zencart what do you mean? Did you create a database, copy the zencart files to the directory, and run the install? Did you copy the files from your existing site and try to edit the config files? Did you create a database in the wamp environment and import your existing database? It would help if you give more info on what steps you executed.
    Well I ran the zencart installation through wamp, but it seems like it's installed in its own directory inside wamp (www/zencart/) I don't know if it will be accessible to other projects outside the directory - is why I wrote "seem to".

    I did create a database in Wamp's PhpmyAdmin during the installation process, but I haven't imported the existing database - not entirely sure how to go about that.

    The files for the existing site are in a directory in wamp/www/ as well which is why it seems to me like the zencart install was separated from the files of the existing site - this is where I was looking for the most help. I saw guides on how to install zencart into wamp by itself, but not necessarily how to install it when there's an existing site. I don't know how the site files and the zencart install files need to be integrated within wamp.

    I tried a few scattered things I found that seemed like they might have been related to my problem. I haven't really been able to keep track of all of them which is why I tried to express my willingness to start from scratch. A new wamp install and an existing ZC site.

    Does this clarify at all?

  4. #4
    Join Date
    Aug 2009
    Location
    Longs, SC
    Posts
    626
    Plugin Contributions
    2

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Let me try and give you a high level step by step for a couple scenarios.
    New install:
    In wamp select phpmyadmin and create a new database. If you left the program defaults alone the database userid will be root and the database password will be blank. You'll need those for the install.

    Download the zencart zip file and extract it to a directory you create in wamp/www. Start wamp and when it starts click on the wamp icon, then select localhost(the same place you accessed phpmyadmin to create the database).

    Select the directory where you extracted the zencart code. The installation of zencart should start.

    Go through the zencart install specifying the database name, userid, and password when asked.

    Rename the admin directory and install directory. You should now be able to select the directory from localhost in wamp and have it open in the browser. Access the admin by adding /whateveryourenamedtheadmindirectory.
    Existing site:
    Create a directory in wamp/www and copy your existing site files to it.

    From the cpanel on your live site go to phpmyadmin(or whatever tool they provide to manage your database). Select your live database and export it. If you are going to import it to an existing zencart database (like the one from the prior scenario) then be sure to include the drop tables option.

    Select phpmyadin in wamp and go to the database you created. Import the database using the export from the live site.

    Edit the config files that you copied to the local directory with the local info. I've found that the simplest way to get the config files right is to do a new install of zencart to get the config files built, then replace all the files from the fresh local install with the ones from your live site except the config files. That ensures that the config files reflect the correct urls, directories, and database info.

    If you've done everything correctly you should be able to launch the live site from the localhost directory.

  5. #5
    Join Date
    Jul 2012
    Posts
    16,177
    Plugin Contributions
    17

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Also be sure that in your local site that the DB_PREFIX is the same as in your live site... (if the define in the live site's includes/configure.php for DB_PREFIX is like: define('DB_PREFIX', ''); then there is no prefix to be concerned about).

    Otherwise, as part of the process to import the data to your local site as badarac suggests, the DB_PREFIX in both includes/configure.php and YOUR_SECRET_ADMIN/includes/configure.php of your local site should be changed to what the live site uses in order to work with the imported data.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  6. #6

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Alright I've taken the steps you laid out badarac, as well as checked and matched the DB_PREFIX lines in the local site's configure.php files like mc said.

    When navigating to the directory in localhost now instead of getting the ZenCart page - saying it needed to be installed, or the paths fixed - I get a simple line of text saying "WARNING: An Error occurred, please refresh the page and try again."

    When I tried it before changing the DB_PREFIX lines, the page was simply white. After changing those prefix lines to match how they are on the live site, now the page loads that error in a single line of text.

  7. #7
    Join Date
    Jul 2012
    Posts
    16,177
    Plugin Contributions
    17

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Blank, partial blank or message like received: http://www.zen-cart.com/content.php?124-blank-page
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  8. #8

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Quote Originally Posted by mc12345678 View Post
    Blank, partial blank or message like received: http://www.zen-cart.com/content.php?124-blank-page
    It's a completely blank page with one line of type: "WARNING: An Error occurred, please refresh the page and try again."

  9. #9
    Join Date
    Jul 2012
    Posts
    16,177
    Plugin Contributions
    17

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Quote Originally Posted by RobertH View Post
    It's a completely blank page with one line of type: "WARNING: An Error occurred, please refresh the page and try again."
    Understood. That's why the link was provided as it is to a FAQ about how to move forward from that issue... Please revew the content of the link, post information in the logs if you wish. Do not divulge your SECRET_ADMN_DRECTORY even if it is a test enviironment on a local computer, it's a good practice.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  10. #10

    Default Re: Setting up a Test Site Environment via Wamp (with an existing ZenCart site)

    Well I started over (again) with a fresh WAMP install and following https://www.zen-cart.com/content.php...fferent-server instructions. I ended up in the same spot - with a blank screen and the "WARNING: An Error occurred, please refresh the page and try again."

    My most recent error logs in /cache/ are:

    Admin:
    Code:
    [13-Aug-2015 17:00:13 Europe/Paris] PHP Fatal error:  Call to undefined function money_format() in C:\wamp\www\localsite\SECRET_ADMIN_NAME\index.php on line 149
    
    [13-Aug-2015 17:00:13 Europe/Paris] PHP Stack trace:
    
    [13-Aug-2015 17:00:13 Europe/Paris] PHP   1. {main}() C:\wamp\www\localsite\SECRET_ADMIN_NAME\index.php:0

    Non-Admin
    Code:
    [13-Aug-2015 16:58:21 Europe/Paris] PHP Fatal error:  1054:Unknown column 'p.products_carrot' in 'field list' :: select p.products_tax_class_id, p.products_carrot, p.products_price from nhd_products p where p.products_id = '0'  in C:\wamp\www\localsite\includes\classes\db\mysql\query_factory.php on line 101
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP Stack trace:
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   1. {main}() C:\wamp\www\localsite\index.php:0
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   2. require() C:\wamp\www\localsite\index.php:26
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   3. require() C:\wamp\www\localsite\includes\application_top.php:149
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   4. require() C:\wamp\www\localsite\includes\autoload_func.php:48
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   5. include() C:\wamp\www\localsite\includes\init_includes\init_templates.php:83
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   6. include() C:\wamp\www\localsite\includes\modules\extra_definitions.php:73
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   7. queryFactory->Execute() C:\wamp\www\localsite\includes\languages\english\extra_definitions\free_gifts.php:24
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   8. queryFactory->set_error() C:\wamp\www\localsite\includes\classes\db\mysql\query_factory.php:208
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP   9. queryFactory->show_error() C:\wamp\www\localsite\includes\classes\db\mysql\query_factory.php:86
    
    [13-Aug-2015 16:58:21 Europe/Paris] PHP  10. trigger_error() C:\wamp\www\localsite\includes\classes\db\mysql\query_factory.php:101

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. v151 Trouble setting up a test environment (WAMP and XAMPP)
    By nikerymis in forum Installing on a Windows Server
    Replies: 8
    Last Post: 16 Oct 2014, 01:17 AM
  2. v150 replacing existing site with a test ZC located on same server
    By dagadesign in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 29 Jan 2012, 04:25 AM
  3. Issues with test site and Wamp
    By mw4kids in forum Templates, Stylesheets, Page Layout
    Replies: 6
    Last Post: 30 Mar 2009, 02:31 PM
  4. Replacing existing site with ZenCart site
    By countrycupboard in forum General Questions
    Replies: 1
    Last Post: 22 Mar 2008, 04:36 PM
  5. Setting up a test environment
    By RonG in forum General Questions
    Replies: 5
    Last Post: 28 Feb 2008, 04:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR