Page 1 of 3 123 LastLast
Results 1 to 10 of 30
  1. #1
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    help question Need Advice on Upgrading from v139h to v154

    Hi,

    It has been a really long time since I last posted here. I'm on a very old version of Zencart v139h which was working fine for me until lately got into trouble with some hack attempt which I have fixed.

    But now I am looking into finally doing the upgrade to a more secure version.

    My hosting is GoDaddy and the php version I currently have is 5.0 on v139h.

    I'd like advise on how best to approach the upgrade since I would have to upgrade the php first.

    Will it function OK if I go ahead and upgrade it to php 5.3 while I work on the upgrade version in a separate folder? That is my first concern.

    If that works then I can start working on the upgrade. Unfortunately Godaddy does not have 5.4 so I can only upgrade to v1.53 at best.

    This was my first site so I was a little gungho in adding a lot of modules which I regret now and would like to start anew by just stripping it to only the essentials.

    I'd like to carry over just products, product descriptions, bare essentials. Customers will have to register all over again on the new site. Or maybe I can carry over customer info but not product purchase?

    Can I carry over database (restore it), go into the database, remove all non essential tables and just leave the product information then do the upgrade using the new zencart files? That way I do not have to mess with comparing files from old to new. It will be a new site except the product portion will be pre populated.

    That is my theory for now but I know a lot of you out there are more techy than I am and may see the holes where I can't. So need your advice if this is a good game plan or if there is a better way to go about it. Remember, my goal is to get to a new version, and try and get only the essential product info carried over.

    Thank you for your help in advance.

  2. #2
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,443
    Plugin Contributions
    9

    Default Re: Need Advice on Upgrading from v139h to v154

    Quote Originally Posted by sunflowertami View Post
    Hi,

    It has been a really long time since I last posted here. I'm on a very old version of Zencart v139h which was working fine for me until lately got into trouble with some hack attempt which I have fixed.

    But now I am looking into finally doing the upgrade to a more secure version.

    My hosting is GoDaddy and the php version I currently have is 5.0 on v139h.
    Unfortunately that seems to be your major problem - any other host I know has a php version selector in their cPanel...

    Quote Originally Posted by sunflowertami View Post
    I'd like advise on how best to approach the upgrade since I would have to upgrade the php first.

    Will it function OK if I go ahead and upgrade it to php 5.3 while I work on the upgrade version in a separate folder? That is my first concern.

    If that works then I can start working on the upgrade. Unfortunately Godaddy does not have 5.4 so I can only upgrade to v1.53 at best.
    I prefer to do upgrades on a local clone of my site, make sure that all works ok before I make the changes on the live site.

    Quote Originally Posted by sunflowertami View Post
    This was my first site so I was a little gungho in adding a lot of modules which I regret now and would like to start anew by just stripping it to only the essentials.

    I'd like to carry over just products, product descriptions, bare essentials. Customers will have to register all over again on the new site. Or maybe I can carry over customer info but not product purchase?

    Can I carry over database (restore it), go into the database, remove all non essential tables and just leave the product information then do the upgrade using the new zencart files? That way I do not have to mess with comparing files from old to new. It will be a new site except the product portion will be pre populated.

    That is my theory for now but I know a lot of you out there are more techy than I am and may see the holes where I can't. So need your advice if this is a good game plan or if there is a better way to go about it. Remember, my goal is to get to a new version, and try and get only the essential product info carried over.

    Thank you for your help in advance.
    You can start afresh without loosing any customer data, I have done this numerous times for clients. Every time old and outdated / unused plugins were stripped and only the absolute necessary plugins were installed, provided they are compatible with the latest version of ZC.

    Cheers / Frank

  3. #3
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,828
    Plugin Contributions
    9

    Default Re: Need Advice on Upgrading from v139h to v154

    I suggest that you align yourself with a better host first
    Zen-Venom Get Bitten

  4. #4
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    Default Re: Need Advice on Upgrading from v139h to v154

    Kobra,

    I hear you. GoDaddy has not been my first choice. I actually have another site on BLue Host and prefer to keep both so that if one goes down the other is still up. FYI GoDaddy has improved through the years, their uptime is now far better than Blue Host.

    So working with what I have, any suggestions?

  5. #5
    Join Date
    Jul 2012
    Posts
    14,385
    Plugin Contributions
    17

    Default Re: Need Advice on Upgrading from v139h to v154

    The following is a good reference offering at least an overview of how to do the process. After the rebuild and functional operation, I would then suggest the "stripping" of the database tables with the frequent use of database backups in case more than desired is removed.

    http://www.zen-cart.com/entry.php?3-...d-of-upgrading
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  6. #6
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,443
    Plugin Contributions
    9

    Default Re: Need Advice on Upgrading from v139h to v154

    Quote Originally Posted by sunflowertami View Post
    ....

    So working with what I have, any suggestions?
    You won't have any joy running a ZC 1.5.4 site with PHP 5.0 - and that is a given. I'd move the site to any (any...) other host first, a host that can give you the choice of your desired PHP version.

  7. #7
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    Default Re: Need Advice on Upgrading from v139h to v154

    Hi Frank,

    Moving it is not an option I have right now.

    I was going to just upgrade to 1.5.3 or 1.5.0 and upgrade php to 5.3.

    Should I upgrade php first, then do work on the new zen site or work on the new zen site then upgrade to php 5.3?

    Would 1.39h survive the php upgrade if I do the former first.

  8. #8
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,443
    Plugin Contributions
    9

    Default Re: Need Advice on Upgrading from v139h to v154

    Quote Originally Posted by sunflowertami View Post
    Hi Frank,

    Moving it is not an option I have right now.

    I was going to just upgrade to 1.5.3 or 1.5.0 and upgrade php to 5.3.

    Should I upgrade php first, then do work on the new zen site or work on the new zen site then upgrade to php 5.3?

    Would 1.39h survive the php upgrade if I do the former first.
    Well, I remember running a 1.3.9h site on PHP 5.4, it did work somehow. So, how about you upgrade to PHP 5.3 first and then get your store to a higher ZC 1.5.x version? BTW, the upgrade from 1.5.3 to 1.5.4 is a cake walk..... you can always do that later.

    Personally I would clone the site to my local (LAMP) server, do the full hog of upgrading and then copy the result to a server other than GoDaddy and make it live.

    But that's just me...

  9. #9
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    Default Re: Need Advice on Upgrading from v139h to v154

    Hi Frank,

    Unfortunately I have a windows os on my pc and my site is running on Linux. So I believe it maybe better to test the environment it will be working in.

  10. #10
    Join Date
    Jul 2012
    Posts
    14,385
    Plugin Contributions
    17

    Default Re: Need Advice on Upgrading from v139h to v154

    Quote Originally Posted by sunflowertami View Post
    Hi Frank,

    Unfortunately I have a windows os on my pc and my site is running on Linux. So I believe it maybe better to test the environment it will be working in.
    Once a page of any type can be presented properly, essentially it doesn't matter what os you're using... More important would be what php version is being used.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. v154 Upgrading from v154 to v155a problem with database upgrade
    By rsrwus in forum Upgrading to 1.5.x
    Replies: 2
    Last Post: 13 May 2016, 02:28 AM
  2. V137 to V154 Lost Chinese Input in Admin CP after upgrading
    By haostaff in forum Upgrading to 1.5.x
    Replies: 4
    Last Post: 22 May 2015, 11:51 AM
  3. Urgent! Need a little advice from the Zen Gurus
    By rwoody in forum General Questions
    Replies: 6
    Last Post: 15 Dec 2008, 12:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR