Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Yes, the production site 1.3.9h is up and running on a separate server.

    Thanks, will do that next.

  2. #12
    Join Date
    Jun 2008
    Posts
    255
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Update on php.

    I am on BlueHost and my cpanel says php 5.4.24.

    However from the way zencart is acting when I installed v1.54, I was told this is because I am running php 5.2.

    So I made the necessary changes and contacted support for BlueHost and complained about it.

    Just got an email back saying that I WAS running php 5.2 even if my cpanel is stating 5.4. Huh! So anyway they changed it to php 5.4 and I have since changed all the coding back and admin is running ok.

    So when in doubt, contact your server support.

  3. #13
    Join Date
    Jul 2012
    Posts
    14,386
    Plugin Contributions
    17

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Quote Originally Posted by sunflowertami View Post
    Yes, the production site 1.3.9h is up and running on a separate server.

    Thanks, will do that next.
    I am not sayng that you need to do this now, but understand that you should be treating this current attempt as a trial run and not your official upgrade. As long as your "old" store is open, it is collecting data. That data should be incorporated into the "new" live store... The only way to do that is to temporarily put the store in maintenance mode (when sure that the files are as desired) and associate the old database data with the new store, update the data then put the store in operation under the new data/files...

    But... As I said, not saying need to do that now... Take good notes about what you're doing and be able to reproduce it successfully a second time (or third) so that the actual upgrade of the live site goes as smoothly as possible.

    Also need to look into what it takes for your site to use PHP 5.4 or higher, but don't swap between the two until ready to commiit to iit (new store).
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  4. #14
    Join Date
    Jul 2012
    Posts
    14,386
    Plugin Contributions
    17

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Quote Originally Posted by sunflowertami View Post
    Update on php.

    I am on BlueHost and my cpanel says php 5.4.24.

    However from the way zencart is acting when I installed v1.54, I was told this is because I am running php 5.2.

    So I made the necessary changes and contacted support for BlueHost and complained about it.

    Just got an email back saying that I WAS running php 5.2 even if my cpanel is stating 5.4. Huh! So anyway they changed it to php 5.4 and I have since changed all the coding back and admin is running ok.

    So when in doubt, contact your server support.
    Glad you were able to get PHP updated. Your live site may now have issues though as it is not designed to work on that version. There are some temporary file patches that can be put in place if necessary. DrByte posted something about it and maybe it can be found again, but try to finish the upgrade as quickly as you can.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #15
    Join Date
    Jun 2007
    Posts
    65
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Does 1.3.9h work with php 5.4?

  6. #16
    Join Date
    Jul 2012
    Posts
    14,386
    Plugin Contributions
    17

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Quote Originally Posted by Joseph Heinen View Post
    Does 1.3.9h work with php 5.4?
    Not without some "creative" file modifications: see the server requirements located on the main page of this site: http://www.zen-cart.com/content.php?...o-run-zen-cart
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  7. #17
    Join Date
    Jun 2007
    Posts
    65
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Quote Originally Posted by mc12345678 View Post
    Not without some "creative" file modifications: see the server requirements located on the main page of this site: http://www.zen-cart.com/content.php?...o-run-zen-cart
    Thanks!

    So how do I keep the store working while I try to upgrade. The server has php 5.2.7

  8. #18
    Join Date
    Jul 2012
    Posts
    14,386
    Plugin Contributions
    17

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Quote Originally Posted by Joseph Heinen View Post
    Thanks!

    So how do I keep the store working while I try to upgrade. The server has php 5.2.7
    So I found this post/thread, but it relates to keeping ZC 1.5.1 operational while forced to use a higher PHP versionand in the process of upgrading the store. https://www.zen-cart.com/showthread....12#post1292812

    But, if the version of PHP remains at 5.2.17 (would be surprised if 5.2.7 was the current version.) Then at least ZC 1.5.4 can be installed (patches available at: http://www.zen-cart.com/showthread.p...s)-with-v1-5-4 related to PHP 5.2.17 use.) Some upgraded plugins may work still, but others may not until the php version is also upgraded... At any rate if the database (core data of the store) can be upgraded to ZC 1.5.4 then at least a skeleton site can be operational if need to shift to the higher php version before fully complete...

    All of this is pretty much a "crunch" repair/upgrade... Ideally setup a local site, get good at following these instructions: http://www.zen-cart.com/entry.php?3-...d-of-upgrading

    It's possible... I may not be doing a good job of explaining how as I tend to just *do it*...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  9. #19
    Join Date
    Jun 2007
    Posts
    65
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    wow thats over my head.
    I think I need someone to do it for me

    will 1.3.9 run with php 5.3?

  10. #20
    Join Date
    Jun 2007
    Posts
    65
    Plugin Contributions
    0

    Default Re: Upgraded Database from 139h to 154/ Store and Admin is Blank

    Update
    The server has php 5.2.17

    I have installed 5.3 but the admin page is blank. The catalog shows up fine

    I did this

    // echo @gethostname(); //what server am I working on?

    but admin is still blank.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 7
    Last Post: 12 Apr 2015, 08:38 PM
  2. Manually merging 151 database customer records into a 154 database
    By jmocallghan in forum Upgrading to 1.5.x
    Replies: 9
    Last Post: 28 Feb 2015, 01:31 PM
  3. Upgraded from 1.3.7 o 1.3.9 and can't log in to admin
    By saddlebred in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 14 Mar 2011, 10:17 AM
  4. Replies: 9
    Last Post: 4 Nov 2010, 08:43 PM
  5. upgraded to 1.3.9 admin is blank page and...
    By DarkAngel in forum Upgrading from 1.3.x to 1.3.9
    Replies: 24
    Last Post: 23 Apr 2010, 05:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR