Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2006
    Location
    Kihikihi, New Zealand
    Posts
    230
    Plugin Contributions
    3

    Default Zone Rates Module does not show correct Shipping Cost

    Hi,

    Recently I have moved to NZ and am currently installing a new Zen Cart and have run into problems with the built in shipping modules.
    I have installed several Zen Carts before, but never used the built in shipping modules.

    Currently installing "v1.5.4" with "responsive sheffield blue v2.0" template

    I need to offer different shipping cost in 7 zones that have been defined in the manager in "Zone Definitions - Taxes, Payment and Shipping".

    Shipping must be based on "weight" and "zone".

    I have altered the includes\modules\shipping\zones.php file to accommodate the extra fields needed:
    Code:
    // CUSTOMIZE THIS SETTING FOR THE NUMBER OF ZONES NEEDED
          $this->num_zones = 7;
    and altered includes\languages\english\modules\shipping\zones.php to change the "lb(s)" into "kg":
    Code:
    define('MODULE_SHIPPING_ZONES_TEXT_UNITS', 'kg');
    My general language settings in both shop and admin have been changed from lbs to kg. In admin I have defined:
    • maximum shipping weight: 25kg
    • Package Tare Small to Medium - added percentage:weight: 0:3
    • Larger packages - added packaging percentage:weight: 0


    In the shipping module if I set the the following:
    • Zone 1 Countries: NZ
    • Zone 1 Shipping Table: 5:26.40
    • Zone 1 Handling Fee: left blank
    • Handling Per Order or Per Box Zone 1 (when by weight): Box


    When purchasing a product with a weight of 2.5 kg I get the following message at step 1 of 3 during checkout:
    "The shipping rate cannot be determined at this time"

    When I change the shipping module to include a second weight:
    • Zone 1 Countries: NZ
    • Zone 1 Shipping Table: 5:26.40,10:52.80
    • Zone 1 Handling Fee: left blank
    • Handling Per Order or Per Box Zone 1 (when by weight): Box


    And purchase the same product I get the following at step 1 during checkout:
    "Shipping to NZ (1 x 5.50kg)" "$52.80"

    This problem also repeats itself for any further zones I define.

    How come the weight is not correct "5.50kg" instead of "2.5kg"

    Where does the "5.5" come from and why does it ignore the correct setting in the shipping module?

    Many thanks,

    Goshawk
    Time is but an illusion, there is only "now"!

  2. #2
    Join Date
    Aug 2006
    Location
    Kihikihi, New Zealand
    Posts
    230
    Plugin Contributions
    3

    Default Re: Zone Rates Module does not show correct Shipping Cost

    How come the weight is not correct "5.50kg" instead of "2.5kg"
    Hooray,

    Just worked it out! I am posting this fix so other people who run into this problem can fix it too:

    In admin I have defined:
    • maximum shipping weight: 25kg
    • Package Tare Small to Medium - added percentage:weight: 0:3
    • Larger packages - added packaging percentage:weight: 0
    What did escape me (perhaps due to the wording of the setting) "Package Tare Small to Medium - added percentage:weight" was that the setting does not refer to a percentage but: added 3 kg instead and the instructions on the "edit" field were not that clear at first glance.

    So I changed:
    • Package Tare Small to Medium - added percentage:weight: 0:3 to:
    • Package Tare Small to Medium - added percentage:weight: 0



    Perhaps something for the design team to attend to

    Regards,

    Goshawk
    Last edited by Goshawk; 3 Dec 2015 at 04:35 AM. Reason: error in syntax
    Time is but an illusion, there is only "now"!

  3. #3
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,474
    Plugin Contributions
    6

    Default Re: Zone Rates Module does not show correct Shipping Cost

    You should use the standard of 0:0 ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

 

 

Similar Threads

  1. v150 USPS Shipping Module does not show up under Modules/Shipping
    By JavaGoldMan in forum Addon Shipping Modules
    Replies: 30
    Last Post: 19 Aug 2017, 11:30 PM
  2. USPS module suddenly not giving correct insurance rates?
    By janosik1 in forum Addon Shipping Modules
    Replies: 21
    Last Post: 18 Mar 2014, 04:24 PM
  3. Replies: 23
    Last Post: 8 May 2013, 12:02 AM
  4. zone shipping rates module
    By abhishek77 in forum General Questions
    Replies: 0
    Last Post: 28 Apr 2008, 01:34 AM
  5. Zone Rates Shipping does not read table
    By joycebeck in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 2 Oct 2006, 10:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR