Results 1 to 7 of 7
  1. #1

    Default Initial Installation Issue - My SQL Database

    I am conducting an initial installation using Windows 10. I believe I have set up the sqlserver on my host server. While running zc_install, it attempts to install the SQL database (I believe), but when it gets to the installation page, there is a message of "Installation In Progress" that never goes away, where I can continue on to the next step. Does anyone have any suggestions? Please bear with me, as this is my first experience setting up any type of website......

  2. #2
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,835
    Plugin Contributions
    9

    Default Re: Initial Installation Issue - My SQL Database

    I believe I have set up the sqlserver
    You need mysql versus win sql - also apache, and php
    One must also setup the database before running ZenCart installation as part of this is defining host, user, and pass dor the database
    Zen-Venom Get Bitten

  3. #3

    Default Re: Initial Installation Issue - My SQL Database

    I think it is MySQL, as the host name is mysqlcluster....com

    I'm not sure I understand what winsql or apache are.....

  4. #4
    Join Date
    Jul 2012
    Posts
    11,636
    Plugin Contributions
    13

    Default Re: Initial Installation Issue - My SQL Database

    Quote Originally Posted by dartman24 View Post
    I think it is MySQL, as the host name is mysqlcluster....com

    I'm not sure I understand what winsql or apache are.....
    Winsql is the wndows version of a sql database. Apache is basically host/server software...

    As to the hang in the install and discussion of databases, a database must have been created on the database server, to include a username and password... That information is what is collected by zc_install... What zc_install then does is create the tables inside of the database...

    All that said, I've run across the eternal dots before on an install... I forget what it took to get past that... I thought there was some sort of known issue and it somewhat only occurred in particular conditions. But because of my uuncertainty I would suggest searching a little morre through the forum (probably from a search engine outside of the forum would be best) to see what else has been posted about it...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5

    Default Re: Initial Installation Issue - My SQL Database

    OK. I'll try doing the search. Thanks.

    I created the database with login and password on the server prior to the zc_install......

  6. #6
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: Initial Installation Issue - My SQL Database

    Are there any zcInstall*.log files in your site's /logs folder?

  7. #7

    Default Re: Initial Installation Issue - My SQL Database

    Yes, there are log files available.....

    this is what many of the log files say:

    [04-Dec-2015 14:29:04 America/New_York] PHP Fatal error: Call to a member function RecordCount() on boolean in /data/24/4/18/112/4344764/user/5007493/htdocs/zc_install/includes/functions/general.php on line 853

    This was also in a log file:

    Dec 04 2015 18:04 -- inspect
    System Inspection Results:
    ------------------------------
    NA: Webserver => Apache
    NA: HTTP Host => www.hodaonline.com
    NA: Path_Translated => /data/24/4/18/112/4344764/user/5007493/htdocs/zc_install/index.php(SCRIPT_FILENAME)
    NA: Real Path => /data/24/4/18/112/4344764/user/5007493/htdocs
    NA: Server Free Disk Space => 449.67 GB
    NA: PHP O/S => Linux
    NA: PHP API Mode => cgi-fcgi
    NA: PHP Max Execution Time per page => 30
    NA: Disabled PHP Functions => shell_exec, passthru, exec, system, pcntl_exec
    OK: MySQL Support => ON
    OK: PHP Version => 5.6.15-pl0-gentoo
    OK: PHP Sessions Support => ON
    OK: PHP Session.AutoStart => OFF
    OK: PHP session.use_trans_sid => OFF
    OK: Suggested SQL Cache Folder => /data/24/4/18/112/4344764/user/5007493/htdocs/cache
    OK: PHP GD Support => ON
    OK: GD Version => GD bundled (2.1.0 compatible)
    OK: PHP ZLIB Compression Support => ON
    OK: PHP OpenSSL Support => ON
    OK: PHP cURL Support => ON
    OK: CURL NON-SSL Capability => Okay
    OK: CURL SSL Capability => Okay
    OK: PHP Upload Support => ON upload_max_filesize=25M; post_max_size=25M
    OK: PHP Upload TMP dir => /data/tmp
    OK: Apache .htaccess Support => ON
    NA: PHP include_path => .:/usr/share/php:/usr/services/vux/lib/php
    NA: PHP SMTP destination => localhost
    NA: PHP sendmail path => /usr/sbin/sendmail -t -i
    NA: PHP sendmail 'from' =>
    OK: PHP open_basedir restrictions =>
    OK: PHP Output Buffering (gzip) => ON
    OK: PHP XML Support => ON
    OK: PHP Session.Save_Path => /data/24/4/18/112/4344764/user/5007493/htdocs/cache-->Writeable
    OK: includes/configure.php => Writeable
    OK: admin/includes/configure.php => Writeable
    OK: cache => OK 777 read/write/execute
    OK: images => OK 777 read/write/execute (INCLUDE SUBDIRECTORIES TOO)
    OK: includes/languages/english/html_includes => OK 777 read/write (INCLUDE SUBDIRECTORIES TOO)
    OK: logs => OK 777 read/write/execute
    OK: media => OK 777 read/write/execute
    OK: pub => OK 777 read/write/execute
    OK: admin/backups => OK 777 read/write
    OK: admin/images/graphs => OK 777 read/write/execute
    PHP Extensions compiled: Core, date, ereg, libxml, openssl, pcre, sqlite3, zlib, bcmath, bz2, calendar, ctype, curl, dba, dom, hash, fileinfo, filter, ftp, gd, gettext, SPL, iconv, session, json, mbstring, mcrypt, standard, mysqlnd, mysqli, mysql, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, readline, Reflection, imap, SimpleXML, soap, sockets, exif, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, cgi-fcgi, dbx, imagick, suhosin, mhash, ionCube Loader, Zend OPcache
    ------------------------------



    The following was also in a log file:
    Last edited by dartman24; 8 Dec 2015 at 03:37 AM.

 

 

Similar Threads

  1. v139h Problem Importing SQL database to new database ready for testing Zencart 1.5
    By gillpotsoffun in forum Upgrading to 1.5.x
    Replies: 8
    Last Post: 24 Aug 2015, 11:24 PM
  2. Last Name Issue when Customer has a middle initial...
    By Coins2012 in forum PayPal Express Checkout support
    Replies: 0
    Last Post: 30 May 2015, 07:38 PM
  3. Database v1.3.8a how subcategories are referenced to issue SQL commands?
    By icecold in forum Setting Up Categories, Products, Attributes
    Replies: 2
    Last Post: 3 May 2011, 08:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR