Page 1 of 9 123 ... LastLast
Results 1 to 10 of 87
  1. #1
    Join Date
    Apr 2006
    Posts
    358
    Plugin Contributions
    0

    Default Future Japanese Language Pack Status, version 1.5.5 and beyond...

    Currently I have an English/Japanese store (version 1.5.4) that works fine with Japanese Language Pack.

    Yesterday I began playing around with version 1.5.5 on a new store for an English/Japanese based site. I have not installed any Japanese files yet.

    I have not seen any activity surrounding the Japanese Language Pack for a few years so I'm wondering if the current language pack will work in 1.5.5 and upcoming version 1.6 (and beyond!).

    Would appreciate an overview of the situation as I need to know if I should stick with Zen or not.

    Thanks in advance!

  2. #2
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,762
    Plugin Contributions
    9

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    Would appreciate an overview of the situation as I need to know if I should stick with Zen or not.
    As you must also speak & write in Japanese - you can edit the english.php replacing English words with Japanese then renaming it to japanese.php and along with other language files.
    You could then offer it as a language pack for ZenCart v1.5.5
    Zen-Venom Get Bitten

  3. #3
    Join Date
    Apr 2006
    Posts
    358
    Plugin Contributions
    0

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    Actually my Japanese ability is limited but I'll look into it... If the 1.5.5 version is not too different I should be able to handle it.

  4. #4
    Join Date
    Dec 2009
    Location
    Amersfoort, The Netherlands
    Posts
    2,845
    Plugin Contributions
    25

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    I think there is also a Japanese fork on github of the Zen Cart repository. Not sure is it is actively maintained or up to date.

  5. #5
    Join Date
    Dec 2009
    Location
    Amersfoort, The Netherlands
    Posts
    2,845
    Plugin Contributions
    25

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...


  6. #6
    Join Date
    Aug 2004
    Location
    Osaka Japan
    Posts
    163
    Plugin Contributions
    0

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    I only have Japanese version 1.5.1, where did you find 1.5.4?

    The annoying part I find about ZenCart JP version is the admin configuration menus are fixed in Japanese, they should be multilingual but are not.

  7. #7
    Join Date
    Apr 2006
    Posts
    358
    Plugin Contributions
    0

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    I believe my version is 1.5.1, too. Anyway, whatever version it is, it seems to work fine with 1.5.4.

  8. #8
    Join Date
    Apr 2006
    Posts
    358
    Plugin Contributions
    0

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    I can choose English or Japanese for the Admin area. I usually download the English version and add the Japanese language files to it...

  9. #9
    Join Date
    Apr 2006
    Posts
    358
    Plugin Contributions
    0

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    I've decided to try and update the Japanese Language files to suit version 1.5.5.

    I've done a search but can't seem to find specific instructions as to the procedure or a list of files that need to be updated for both the store and the admin.

    Could someone point me in the right direction?

    Thanks!

  10. #10
    Join Date
    Jul 2012
    Posts
    16,481
    Plugin Contributions
    17

    Default Re: Future Japanese Language Pack Status, version 1.5.5 and beyond...

    Quote Originally Posted by Peace Freak View Post
    I've decided to try and update the Japanese Language files to suit version 1.5.5.

    I've done a search but can't seem to find specific instructions as to the procedure or a list of files that need to be updated for both the store and the admin.

    Could someone point me in the right direction?

    Thanks!
    Not sure I'm answering the right question, but all of the language files are in the appiicable languages directories. The action would be as I see it, assuming that the japanese version of the code is or will be the same as the english version of the code, would be to compare the includes/languages folders for all english files against the japanese language pack. Any defines in english not in japanese need to be translated, copied, or moved. Any define in the japanese version not in the english version to also be evaluated for removal/movement.

    There is also a plugin I thought that also looks for "multiple" definitions of a constant or something similar to help eliminate "unnecessary" duplication of definitions/identify the "best" location for a single define to be applicable for all cases.

    If the japanese version of ZC is or is to be different than the english version then the applicable constants would need to be evaluated for such.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

 

 
Page 1 of 9 123 ... LastLast

Similar Threads

  1. Japanese Language Pack problem
    By i.chan in forum Addon Language Packs
    Replies: 1
    Last Post: 14 Jun 2009, 11:21 PM
  2. Japanese Language Pack
    By namasa in forum Addon Language Packs
    Replies: 74
    Last Post: 22 Dec 2008, 03:29 PM
  3. japanese language pack...
    By fish_who in forum Addon Language Packs
    Replies: 1
    Last Post: 10 Aug 2006, 04:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR