Page 8 of 8 FirstFirst ... 678
Results 71 to 77 of 77
  1. #71
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,081
    Plugin Contributions
    267

    Default Re: AdminRequestSanitizer Error Log

    I'll take a work-around! :) OK will test tonight and let you know. Can you push to your repo?
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  2. #72
    Join Date
    Jun 2003
    Location
    Newcastle UK
    Posts
    2,879
    Blog Entries
    2
    Plugin Contributions
    2

    Default Re: AdminRequestSanitizer Error Log

    This should work.



    I note that if I add $sanitizer->setDebug(true); to the end of admin/includes/init_includes/init_sanitize.php I get Sanitize logs



    Quote Originally Posted by lat9 View Post
    I finally got the AdminRequestSanitizer to spit out some debug (shouldn't it have been as simple as calling the setDebug function with an argument of true?).
    Last edited by wilt; 13 May 2016 at 10:24 PM.

  3. #73
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,560
    Plugin Contributions
    73

    Default Re: AdminRequestSanitizer Error Log

    Quote Originally Posted by swguy View Post
    I'll take a work-around! :) OK will test tonight and let you know. Can you push to your repo?
    I've pushed the update to the eo_sanitization.php file to account for the add-product path (including the corrected check). I have not (and won't unless it's absolutely needed) pushed the work-around.

  4. #74
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,560
    Plugin Contributions
    73

    Default Re: AdminRequestSanitizer Error Log

    Quote Originally Posted by wilt View Post
    This should work.

    If I add $sanitizer->setDebug(true); to the end of admin/includes/init_includes/init_sanitize.php I get Sanitize logs
    When I added $eo_sanitizer->setDebug(true); to the end of admin/includes/extra_datafiles/eo_sanitization.php ... it doesn't.

  5. #75
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,081
    Plugin Contributions
    267

    Default Re: AdminRequestSanitizer Error Log

    Quote Originally Posted by lat9 View Post
    I've pushed the update to the eo_sanitization.php file to account for the add-product path (including the corrected check). I have not (and won't unless it's absolutely needed) pushed the work-around.
    The work around (the change to admin/includes/init_includes/init_sanitize.php suggested in https://www.zen-cart.com/showthread....78#post1310878) appears to not be needed. Your change to admin/includes/extra_datafiles/eo_sanitization.php works perfectly for the issues I was having.

    Thanks for your hard work on this fix.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  6. #76
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,560
    Plugin Contributions
    73

    Default Re: AdminRequestSanitizer Error Log

    Quote Originally Posted by swguy View Post
    The work around (the change to admin/includes/init_includes/init_sanitize.php suggested in https://www.zen-cart.com/showthread....78#post1310878) appears to not be needed. Your change to admin/includes/extra_datafiles/eo_sanitization.php works perfectly for the issues I was having.

    Thanks for your hard work on this fix.
    swguy, you're right! When I remove those commented-out lines from my client's fresh 1.5.5a/EO4.1.5-beta2 installation ... adding a product with attributes works! Sounds like it might be time to package up EO v4.1.5 for release (more likely tomorrow).
    Last edited by lat9; 15 May 2016 at 01:04 PM. Reason: Clarification

  7. #77
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,081
    Plugin Contributions
    267

    Default Re: AdminRequestSanitizer Error Log

    Cool. Great news.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

 

 
Page 8 of 8 FirstFirst ... 678

Similar Threads

  1. v155 [Done v155a and v155b] AdminRequestSanitizer Problem
    By JRGoold in forum Bug Reports
    Replies: 15
    Last Post: 12 Dec 2016, 01:16 PM
  2. v151 Filename cannot be empty error in error log
    By woodlandsprite in forum General Questions
    Replies: 2
    Last Post: 29 Nov 2012, 06:03 AM
  3. Site down, getting error in debug error log
    By rcrosier in forum General Questions
    Replies: 3
    Last Post: 25 Mar 2009, 03:01 PM
  4. Replies: 6
    Last Post: 7 Dec 2007, 03:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR