Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: fixes for v155

    Quote Originally Posted by DrByte View Post
    The Admin Request Sanitizer infrastructure has been updated to work more amicably with various plugins.

    In your Admin if you're getting & converted into & unexpectedly then you probably need to apply the following updates.

    These changes are applicable to v1.5.0-thru-v1.5.5a:
    a) /admin/includes/classes/AdminRequestSanitizer.php
    b) /admin/includes/init_includes/init_sanitize.php
    c) /admin/includes/auto_loaders/config.adminSanitize.php (this file doesn't require changing if you already have v155a)
    These files have been updated today to fix a few more admin cases where things like & symbols are incorrectly being converted to & amp;

    The links above will always give you the latest version of the file compatible with v155x
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  2. #12
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: fixes for v155

    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #13
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.5 / v1.5.5a

    Symptom: Admin Login "broken" in v1.5.5 - v1.5.5a with Google Chrome error: "Aw, snap"

    Google Chrome 54.0.2840.59 is now forcefully disallowing the use of javascript function declarations of 'animate'. This interferes with the "spinner" that appears during admin login since v1.5.0

    The fix, which will be included in v155b, is simple:
    1. Open /admin/login.php in a code-safe text editor, such as Sublime Text:
    2. Find and replace "animate(" with "waiting_spinner(". There will be 3 occurrences.
    3. Save
    That's it. Login should now work again.

    For a visual example of the changes, see: https://github.com/zencart/zencart/pull/1321/files
    (exact position and line numbers may differ between Zen Cart versions)


    Discussion: https://www.zen-cart.com/showthread....log-into-admin
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #14
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.5 / v1.5.5a / v1.5.5b

    Update: v1.5.5b has been released, and addresses the issues listed earlier in this thread.

    Details of inclusions and changed files: https://www.zen-cart.com/showthread....70#post1321070
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #15
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.5 , a, b, c

    v1.5.5c has been released!

    This fixes a critical bug in PHPMailer, which is the subsystem used for sending emails in Zen Cart. (PATCH REQUIRED FOR ALL ZEN CART VERSIONS)

    Also addresses the following since v155b:


    • Fix serious PHPMailer bug (upgraded to 5.2.19) -- [EDIT: Updated in v1.5.5d to 5.2.21]
    • Fix some variable strict-type rule enforcement issues for better PHP 7 compatibility
    • Fix sanitizer (admin) overzealous cleaning for Attribute Option Comments
    • Fixed bug preventing sending Coupon and GV emails to "all customers"
    • Fixed rarely-triggered bug with product-type overrides for delete/copy logic
    • Fixed problem where deleting a customer wouldn't delete old product-notification requests associated with that customer
    • Fixed PayPal Standard to no longer transmit a comma as thousands-separator. (PayPal is being more strict about this in 2017.)
    • Fixed shopping-basket quantity alert problem where changing quantities didn't always fire if min/mix rules were set
    • Make null-exception treatment consistent in admin to match catalog
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #16
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.5 , a, b, c, d

    AFFECTS ONLY v1.5.5c and v1.5.5d :

    Symptom: SQL error: Incorrect datetime value: 'null' when editing products in the Admin.

    Solution:
    The quickest fix is to revert the /admin/includes/functions/database.php file to what was in v155b, by changing the 2 uppercase 'NULL' back to lowercase 'null' in the zen_db_perform() function, on lines 26 and 42:

    Code:
              case 'NULL':
    becomes
    Code:
              case 'null':
    https://github.com/zencart/zencart/c...ee18989eadd481

    https://www.zen-cart.com/showthread....49#post1323749


    NOTE: IN FUTURE VERSIONS IT WILL BE CHANGED BACK TO UPPERCASE 'NULL'. So if you're using something newer than v1.5.5d, THE ABOVE "fix" DOES NOT APPLY TO YOU
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #17
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Known Bugs (and fixes) with v1.5.5 , a, b, c, d, e

    v1.5.5e fixes a bug introduced in v1.5.5c related to deleting customers:

    Symptom: If you try to delete a customer via the Admin, it would delete but would result in a blank page or an error message.

    Fix: See: https://github.com/zencart/zencart/pull/1398/files
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  8. #18
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default PHP Warning: A non-numeric value encountered in functions_taxes.php on line 172

    Symptom:
    PHP Warning: A non-numeric value encountered in /includes/functions/functions_taxes.php on line 172

    Fix (applies to ZC v1.3.8-to-v1.5.5e):
    https://github.com/zencart/zencart/pull/1437/files
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. v154 Known Bugs (and fixes) with v1.5.4
    By DrByte in forum Upgrading to 1.5.x
    Replies: 18
    Last Post: 18 Oct 2016, 06:17 PM
  2. v154 Known Bugs (and fixes) with v1.5.4
    By DrByte in forum Bug Reports
    Replies: 4
    Last Post: 6 Jan 2015, 09:45 PM
  3. v153 Known Bugs (and fixes) with v1.5.3
    By swguy in forum Bug Reports
    Replies: 1
    Last Post: 7 Jul 2014, 05:57 PM
  4. Known Bugs (and fixes) with v1.3.9
    By DrByte in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 31 Oct 2010, 01:11 AM
  5. Known Bugs (and fixes) with v1.3.8 / v1.3.8a
    By DrByte in forum Upgrading from 1.3.x to 1.3.9
    Replies: 41
    Last Post: 17 Feb 2010, 01:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR