Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Aug 2013
    Location
    Bridlington
    Posts
    151
    Plugin Contributions
    0

    Default Getting ajax error in v155 with v154 Westminster template

    Okay since upgrading to 155 I am having an issue with clicking on the LOGIN option, when I click it I am getting this come up ..
    Name:  attachment.jpg
Views: 303
Size:  23.1 KB

    This is happening on a site I have upgraded from 154 to 155 and it is also happening on a new site running 155. However a site running 154 with the same theme works fine??

    The site that's working okay on 154 is .. http://www.testmcs.mikes-cs.co.uk/

    The site that has the issue is .. http://www.suessweets.co.uk/

    I know those 2 links are running different themes but even if I use the same theme the error is still there.

    Any advice but be appreciated as I have no idea where to look. Many thanks in advance.

  2. #2
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Getting ajax error in v155

    That's an error during an ajax call ... which suggests that the ajax-related files (/ajax.php, /includes/classes/ajax/*, and /includes/templates/your_template/jscript/jscript_framework.php) are damaged or altered from what comes with v155 out-of-the-box.

    Can you confirm WITH ABSOLUTE CERTAINTY that it has nothing to do with the new templates you've been adding?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Dec 2008
    Location
    New Zealand
    Posts
    87
    Plugin Contributions
    1

    Default Re: Getting ajax error in v155

    I previously had an error with ajax.php because the subversion script I had to update for changes didn't update the files in the root directory.

    Check that your /ajax.php file has been properly updated.

  4. #4
    Join Date
    Aug 2013
    Location
    Bridlington
    Posts
    151
    Plugin Contributions
    0

    Default Re: Getting ajax error in v155

    The suessweets website was a clean install of 155 and a clean install of the theme, the other website in my post is running 154. My own website gets the same error when using the same theme however if I change the theme back to Bask Black the login link works.

    I have also attempted to replace the ajax.php file from the Zencart 155 zip

  5. #5
    Join Date
    Aug 2013
    Location
    Bridlington
    Posts
    151
    Plugin Contributions
    0

    Default Re: Getting ajax error in v155

    DRBYTE taking your comments I changed the Sues Sweets theme to the default responsive theme that comes with 155 and it worked, swapped it back to Winchester Blue and the error comes back ???

    It seems weird that I`m using the same files uploaded to 2 sites, the one on 154 works fine the one on 155 errors ??
    Last edited by MCS_Computers; 21 Mar 2016 at 01:11 AM.

  6. #6
    Join Date
    Jan 2004
    Posts
    66,350
    Blog Entries
    7
    Plugin Contributions
    271

    Default Re: Getting ajax error in v155

    As I said earlier, the Westminster template replaces some core v155 files with older versions.
    Two of note are:
    /includes/templates/YOUR_TEMPLATE_FOLDER/jscript/jscript_framework.php
    /
    includes/classes/Mobile_Detect.php

    And maybe others. Copy the v155 versions of those files back in, and see what happens.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    Aug 2013
    Location
    Bridlington
    Posts
    151
    Plugin Contributions
    0

    Default Re: Getting ajax error in v155

    Quote Originally Posted by DrByte View Post
    As I said earlier, the Westminster template replaces some core v155 files with older versions.
    Two of note are:
    /includes/templates/YOUR_TEMPLATE_FOLDER/jscript/jscript_framework.php
    /
    includes/classes/Mobile_Detect.php

    And maybe others. Copy the v155 versions of those files back in, and see what happens.
    I have replaced the mobile_detect.php as advised but I`m unsure what you want me to do about the Jscript_framework, you say that the Westminster replaces the core files but the file you specify is in the Westminster folder anyway ??

  8. #8
    Join Date
    Jul 2012
    Posts
    15,914
    Plugin Contributions
    17

    Default Re: Getting ajax error in v155

    Quote Originally Posted by MCS_Computers View Post
    I have replaced the mobile_detect.php as advised but I`m unsure what you want me to do about the Jscript_framework, you say that the Westminster replaces the core files but the file you specify is in the Westminster folder anyway ??
    Yes, and in the code following loading sequence, the template's version of the file (especially if called the same filename) is loaded in place/ahead of the same file in the template_default equivalent location. Therefore it "replaces" the default version of the file... So either physically replace the file in YOUR_TEMPLATE directory structure or remove it from there, I would suggest replacing instead but I haven't looked at the two sets of code to identify if there is anything that needs to be merged between the two.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  9. #9
    Join Date
    Aug 2013
    Location
    Bridlington
    Posts
    151
    Plugin Contributions
    0

    Default Re: Getting ajax error in v155

    Okay I have looked in the clean 155 folder and this file is in there twice in the jscript folder of the themes, therefore I`m not sure how uploading the Westminster theme had replaced these files however I have replaced this file in the themes folders as specified and also uploaded the Westminsters version back to the Westminster folder and it is still the same.

  10. #10
    Join Date
    Apr 2006
    Location
    West Salem, IL
    Posts
    2,603
    Plugin Contributions
    0

    Default Re: Getting ajax error in v155

    It doesn't "replace" them in the strictest sense of the word. The code in the new template overrides them, so that their code is not executed, which is the same effect if they had "replaced" the core files. So being they are overriding core you need to take the core files and use them to actually replace the same files in the new template.
    Mike
    GeekHost - Zen Cart Certified & PCI Compliant Hosting
    The Zen Cart Forum...Better than a monitor covered with post-it notes!

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 26
    Last Post: 25 Jul 2016, 12:20 PM
  2. v155 Getting ajax error in v155 with v154 Westminster template
    By godt in forum General Questions
    Replies: 3
    Last Post: 11 Jul 2016, 12:41 AM
  3. Ajax error with winchester black template
    By bluestorm in forum General Questions
    Replies: 2
    Last Post: 4 May 2016, 01:39 AM
  4. v155 For what does ZC v155 make use of ajax?
    By carlwhat in forum General Questions
    Replies: 3
    Last Post: 21 Mar 2016, 11:40 PM
  5. v154 V154 Still Getting Handshake Error After Upgrade
    By Rick5150 in forum PayPal Express Checkout support
    Replies: 31
    Last Post: 6 Feb 2015, 10:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR