Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default install freezes at "Loading Character Set specific data 59%"

    Doing a fresh install of v1.5.5 (in process of upgrade) and the install process froze on the screen where it is "loading character set specific data". Should I simply refresh the page, delete everything and start over or ??

    Have done many installs but this new version is not as familiar as the old install.

    Help!

  2. #2
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: install freezes at "Loading Character Set specific data 59%"

    It's rare for that to happen, but if it does I'd first just reload the page and fill in the DB info again, and let it do its install over. Or go back one page and go from there.

    If it's halting due to some sort of error, it's most likely logged in the /logs/ folder in zcInstall-DEBUG-xxxxxx.log files.

    It might be a result of incomplete files from a bad FTP upload, too.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Well, I tried starting over with the install and running it again. This time it froze on the same screen but at 64%. Maybe if I try it a few more times, it will finish that step! :)

  4. #4
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Ok, I'm at a total loss here. Third time running the install and it freezes now at 58%. I can see no data has been added to the database and there is no DEBUG log file (there are other log files that don't say DEBUG, though).

    Guess the next step will be to completely delete all the ZC files and the database and start over.

  5. #5
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: install freezes at "Loading Character Set specific data 59%"

    By the time it's at the stage of loading "character set specific data", it's already built all the tables, and is starting to fill some of them with basic data such as country names etc.

    So, if your database is truly still empty at that point, then that suggests to me you're checking the wrong database when trying to debug it.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #6
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Hmmm... maybe I just didn't look in enough tables, but I'm very sure I was looking at the correct database in phpMyAdmin. I will have to come back to this tomorrow as I ran out of time to troubleshoot this install. Thought it would just take a few minutes but an hour later, I am out of time.

  7. #7
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Ok, I restarted this project today. I completely deleted the previous test store directory (in Filezilla) and I completely deleted the database I created yesterday. I even redownloaded the 1.5.5 zip file from SourceForge. Unfortunately, I'm still stalling out in "loading character set specific data." Comparing the database data to the mysql_utf8.sql file in the install folder, I can see that the countries were added except the last one and no zones have been added. Unlike yesterday, this time a DEBUG log file was generated and it has 14 lines that all say:


    Code:
    [13-Apr-2016 10:45:59 America/New_York] PHP Warning:  mysqli_connect(): (HY000/2002): No such file or directory in /homepages/PATH_TO_STORE/includes/classes/db/mysql/query_factory.php on line 102
    In case any of this is pertinent to the problem, here is as much information as I can collect about the server and site:

    Host: 1&1
    PHP version: 5.5.34
    MYSQL version: 5.5

    Thanks, DrByte for your previous assistance on this. Is there anything else that would shed light on this issue?

  8. #8
    Join Date
    Oct 2006
    Location
    Worcester, MA
    Posts
    372
    Plugin Contributions
    0

    Default Re: install freezes at "Loading Character Set specific data 59%"

    On closer inspection, I'm not sure that debug line is related to the problem of running the [COLOR=#333333]mysql_utf8.sql file. The time stamp on that file is earlier than the last zcInstallLog file that ends with:


    Apr 13 2016 10:49 -- General
    processing file /homepages/22/d250293540/htdocs/155_store_upgrade/zc_install/sql/install/mysql_utf8.sql

    Not knowing exactly how this new installation works, it sure looks to me like the process partially completes the SQL statements in that file but doesn't finish and doesn't do anything further.

    Hope there is some way to complete this install on this server. The host is forcing my client to upgrade to php 7 soon (or pay extra money) and I'm aware that only zc 1.5.5 works with php 7.

  9. #9
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Quote Originally Posted by earmsby View Post
    Code:
    [13-Apr-2016 10:45:59 America/New_York] PHP Warning:  mysqli_connect(): (HY000/2002): No such file or directory
    While the wording is strange, that combination of error number and error message usually means it can't connect to the database. And often it's because of mismatches in the way the server's name-resolution is working.
    Sometimes changing the DB_SERVER from 'localhost' to '127.0.0.1' is enough to fix it.

    It could be that you were getting those errors before zc_install asked you for the db details (and thus the errors are just a byproduct of the system-inspection probing that zc_install does) ... and then those errors stopped after you gave it your real db details. In that case those errors can be ignored.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  10. #10
    Join Date
    Jan 2004
    Posts
    65,335
    Blog Entries
    7
    Plugin Contributions
    229

    Default Re: install freezes at "Loading Character Set specific data 59%"

    Quote Originally Posted by earmsby View Post
    On closer inspection, I'm not sure that debug line is related to the problem of running the [COLOR=#333333]mysql_utf8.sql file. The time stamp on that file is earlier than the last zcInstallLog file that ends with:


    Apr 13 2016 10:49 -- General
    processing file /homepages/22/d250293540/htdocs/155_store_upgrade/zc_install/sql/install/mysql_utf8.sql

    Not knowing exactly how this new installation works, it sure looks to me like the process partially completes the SQL statements in that file but doesn't finish and doesn't do anything further.
    You are correct in your understanding of the flow.

    I'm still puzzled about why it's halting, and at different points each time.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Installation Errors "Unexpected character" "syntax error"
    By TheHTMLMan in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 6 Mar 2012, 05:39 PM
  2. Replies: 2
    Last Post: 5 Nov 2010, 10:34 PM
  3. "forgot password" freezes access
    By Schnak in forum General Questions
    Replies: 2
    Last Post: 14 Jul 2008, 05:15 AM
  4. site "freezes" while in admin
    By craftzombie in forum General Questions
    Replies: 15
    Last Post: 3 Dec 2006, 02:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR