Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Apr 2016
    Location
    Lawton, IA
    Posts
    5
    Plugin Contributions
    0

    Default [Done v155a] Failed to send Email to all recipients: AllCustomers (0)

    I have done a fresh install of v1.55 and was just finishing testing and get the error: Notice: FAILED to send Email to all recipients: AllCustomers (0) when trying to use the Admin>Tools>Send Email then selecting All Customers.

    I can send from this area to individual customers and I can also send from Newsletter feature, the problem seems to be limited to the Send Mail -All Customers

    Name:  email error.jpg
Views: 439
Size:  35.8 KB.

    I found similar issues in the forum for older versions, tried using different email options, php, sendmail and smtp all produce the same error. Read the Email Issues document and the tips suggested seem to have had no effect. If this has already been addressed for v1.55 could you please point me in the direction of where to find the answers.

    My live store is using v1.39, using the same host, but different directory and database and emails send perfectly.

  2. #2
    Join Date
    Jan 2004
    Posts
    65,455
    Blog Entries
    7
    Plugin Contributions
    237

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    Appears to be a bug. Will investigate


    UPDATE: This is fixed in v1.5.5a by applying the updates to the Sanitizer components.

    If you're using v1.5.5 but not v1.5.5a then please upgrade to v155a by simply updating the files named here: https://www.zen-cart.com/docs/change...5-5.html#v155a by copying them from v155a (for quick access to a zip use: https://github.com/zencart/zencart/archive/v155.zip which contains all the latest files in the v155 series).
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Mar 2016
    Posts
    14
    Plugin Contributions
    0

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    Same problem here with v1.5.5


    tools > send email > all customers
    and
    tools > send email > all newsletter subscribers
    ...do not work.

    Tried various transport methods.

    tools > newsletter and product notification manager > (sending from here works fine)

  4. #4
    Join Date
    Jul 2012
    Posts
    15,170
    Plugin Contributions
    17

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    Quote Originally Posted by pr0c3ss View Post
    Same problem here with v1.5.5


    tools > send email > all customers
    and
    tools > send email > all newsletter subscribers
    ...do not work.

    Tried various transport methods.

    tools > newsletter and product notification manager > (sending from here works fine)
    Note, the title of this thread has changed to indicate that the problem was fixed in ZC 1.5.5a. Is the information provided above from 1.5.5 as reported or found to still be an issue in 1.5.5a?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Mar 2016
    Posts
    14
    Plugin Contributions
    0

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    Yeah sorry, I was referring to 1.5.5

    Ahh ye just got a 1.5.5a notification in Zenadmin. I think I'll skip it for now. It has taken me ages to get this near completion and I don't wanna screw it all up with an update now and have to reinstall plugins/configs


  6. #6
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    69,437
    Plugin Contributions
    6

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    This has been fixed in v155a ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.5]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...
    Signup for our Announcements Forums to stay up to date on important changes and updates!

  7. #7
    Join Date
    Jan 2004
    Posts
    65,455
    Blog Entries
    7
    Plugin Contributions
    237

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    This is fixed in v1.5.5a by applying the updates to the Sanitizer components. (3 files containing "sanitize" in the filename; details in the following links)

    If you're using v1.5.5 but not v1.5.5a then please upgrade to v155a by simply updating the files named here: https://www.zen-cart.com/docs/change...5-5.html#v155a by copying them from v155a (for quick access to a zip use: https://github.com/zencart/zencart/archive/v155.zip which contains all the latest files in the v155 series).

    There's no point in only updating the Sanitizer files. While you're at it you're best to update the dozen other files too, to benefit from the related bugfixes.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  8. #8
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    27,789
    Plugin Contributions
    9

    Default Re: [Done v155a] Failed to send Email to all recipients: AllCustomers (0)

    Quote Originally Posted by pr0c3ss
    I think I'll skip it for now. It has taken me ages to get this near completion and I don't wanna screw it all up with an update now and have to reinstall plugins/configs
    I do not think that you fully understand the upgrade process here - it is only replacing the files listed
    Zen-Venom Get Bitten

  9. #9
    Join Date
    Jun 2016
    Location
    New York, NY
    Posts
    67
    Plugin Contributions
    0

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    I am having a similar problem with v1.5.5b (I upgraded from v1.5.5a replacing the files per your instructions for that upgrade.)
    I can successfully email individual customers from Discounts/Coupon Admin - but if I select All Customers (of which there are many) and send the email I get:
    Notice: Email sent to: AllCustomers(0)
    and no emails are sent because it sends to "0".

    Would appreciate advice.


    Quote Originally Posted by DrByte View Post
    This is fixed in v1.5.5a by applying the updates to the Sanitizer components. (3 files containing "sanitize" in the filename; details in the following links)

    If you're using v1.5.5 but not v1.5.5a then please upgrade to v155a by simply updating the files named here: https://www.zen-cart.com/docs/change...5-5.html#v155a by copying them from v155a (for quick access to a zip use: https://github.com/zencart/zencart/archive/v155.zip which contains all the latest files in the v155 series).

    There's no point in only updating the Sanitizer files. While you're at it you're best to update the dozen other files too, to benefit from the related bugfixes.

  10. #10
    Join Date
    Jan 2004
    Posts
    65,455
    Blog Entries
    7
    Plugin Contributions
    237

    Default Re: FAILED to send Email to all recipients: AllCustomers (0)

    Quote Originally Posted by SPython View Post
    I can successfully email individual customers from Discounts/Coupon Admin - but if I select All Customers (of which there are many) and send the email I get:
    Notice: Email sent to: AllCustomers(0)
    Your issue is specific to sending Coupons. (The fix above was for sending general emails.)

    I'm pretty sure this will solve your issue:
    Edit line 208 of /admin/includes/init_includes/init_sanitize.php, adding , 'coupon_admin', 'gv_mail' as shown:
    Code:
    $group = array('customers_email_address' => array('sanitizerType' => 'SANITIZE_EMAIL_AUDIENCE', 'method' => 'post', 'pages' => array('mail', 'coupon_admin', 'gv_mail')));
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. v139h Notice: FAILED to send Email to all recipients
    By m.subhasish in forum General Questions
    Replies: 1
    Last Post: 18 Jan 2012, 09:59 PM
  2. Mercury email SMTP Error: The following recipients failed: [email protected]
    By slickyoz in forum Installing on a Windows Server
    Replies: 2
    Last Post: 25 Jun 2011, 04:41 AM
  3. Replies: 15
    Last Post: 22 Dec 2010, 04:52 AM
  4. Replies: 0
    Last Post: 27 Jul 2009, 12:22 PM
  5. email problem -- SMTP Error: The following recipients failed:
    By rogeruk1977 in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 30 Aug 2008, 11:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR