Results 1 to 9 of 9
  1. #1
    Join Date
    Sep 2008
    Location
    Calgary, AB
    Posts
    27
    Plugin Contributions
    0

    Default v155 System Setup needs URL for intranet install?

    Have installed v1.5.5a on my localhost (XAMPP on windows 7) and also on our live website. But cannot install it onto our internal server intranet (XAMPP on Windows X).

    Am at the System Setup page which resides at:
    http://our-server-name/store-name/zc...e=system_setup

    Have entered the following:

    Admin Server Domain: our-server-name
    Storefront HTTP Domain: http://our-server-name
    Storefront HTTP URL: http://our-server-name/store-name
    etc.

    But the System Setup screen keeps coming up with red errors for the Domain and URL fields:
    "Enter the domain-part of the URL for your store. eg: http://www.example.com"
    "Enter the entire URL for your store. eg: http://www.example.com/zencart/"
    etc.

    Is there some trick to install on something other than localhost or example.com? Thanks.
    My Sewing Room
    #148, 8228 Macleod Tr SE, Calgary, AB T2H 2B8
    mysewingroom.ca

  2. #2
    Join Date
    Aug 2007
    Location
    Gijón, Asturias, Spain
    Posts
    1,724
    Plugin Contributions
    25

    Default Re: v155 System Setup needs URL for intranet install?

    Have entered the following:
    Are the auto-generated values not correct, without entering anything?
    Steve
    github.com/torvista: Apsona (php7), BackupMySQL Admin/Auto, CEON URI Mapping (php7), Image Checker, Redsys payment module, Spanish Language Pack, Structured Data

  3. #3
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: v155 System Setup needs URL for intranet install?

    It probably won't accept an "our-server-name" that doesn't have a valid suffix on it (ie: .com, .photography, .ca, etc)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Sep 2008
    Location
    Calgary, AB
    Posts
    27
    Plugin Contributions
    0

    Default Re: v155 System Setup needs URL for intranet install?

    Quote Originally Posted by torvista View Post
    Are the auto-generated values not correct, without entering anything?
    No, and that's the problem. When I start at http://our-server-name/store-name/zc_install, it automatically fills in the boxes as listed above, but rejects them. So it seems that the installer expects a url.tld (.com, .org, etc.) format, but allows the use of "localhost" as the only exception.
    My Sewing Room
    #148, 8228 Macleod Tr SE, Calgary, AB T2H 2B8
    mysewingroom.ca

  5. #5
    Join Date
    Sep 2008
    Location
    Calgary, AB
    Posts
    27
    Plugin Contributions
    0

    Default Re: v155 System Setup needs URL for intranet install?

    Quote Originally Posted by DrByte View Post
    It probably won't accept an "our-server-name" that doesn't have a valid suffix on it (ie: .com, .photography, .ca, etc)
    Thanks. So if I'm trying to install Zen Cart on our server from my computer over our intranet, could I use "localhost"? Or, do I need to log onto the server computer itself to use "localhost"?
    And either way, will I be able to access it from the networked computers suing the our-server-name/store-name?
    My Sewing Room
    #148, 8228 Macleod Tr SE, Calgary, AB T2H 2B8
    mysewingroom.ca

  6. #6
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,977
    Plugin Contributions
    63

    Default Re: v155 System Setup needs URL for intranet install?

    I use XAMPP for my local testbeds and zc_install has never had an issue when I set
    Code:
      define('HTTP_SERVER', 'http://localhost');
      define('HTTPS_SERVER', 'https://localhost');

  7. #7
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: v155 System Setup needs URL for intranet install?

    "localhost" is a special case, and is allowed. It always means "this computer I'm currently on". So that doesn't scale well if you're wanting to access that server from another computer in your office.

    You could install it using "localhost", and then change it in your configure.php files after installation is done.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  8. #8
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,440
    Plugin Contributions
    9

    Default Re: v155 System Setup needs URL for intranet install?

    Here is an example of a configure.php file on one of my local development sites (LAMP on Linux Mint 17.3), uses the IP address of this computer. Has worked for me for years.... the site can be accessed by anyone on the same network.

    PHP Code:
    <?php
    /**
     * @package Configuration Settings
     * @copyright Copyright 2003-2016 Zen Cart Development Team
     * @copyright Portions Copyright 2003 osCommerce
     * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
     * File Built by Zen Cart Installer on Sun May 01 2016 01:00:18
     */

    /*************** NOTE: This file is VERY similar to, but DIFFERENT from the "admin" version of configure.php. ***********/
    /***************       The 2 files should be kept separate and not used to overwrite each other.              ***********/

    /**
     * Enter the domain for your store
     * HTTP_SERVER is your Main webserver: eg-http://www.yourdomain.com
     * HTTPS_SERVER is your Secure/SSL webserver: eg-https://www.yourdomain.com
     */
    define('HTTP_SERVER''http://192.168.0.20');
    define('HTTPS_SERVER''https://192.168.0.20');

    /**
     *  If you want to tell Zen Cart to use your HTTPS URL on sensitive pages like login and checkout, set this to 'true'. Otherwise 'false'. (Keep the quotes)
     */
    define('ENABLE_SSL''');

    /**
     * These DIR_WS_xxxx values refer to the name of any subdirectory in which your store is located.
     * These values get added to the HTTP_CATALOG_SERVER and HTTPS_CATALOG_SERVER values to form the complete URLs to your storefront.
     * They should always start and end with a slash ... ie: '/' or '/foldername/'
     */
    define('DIR_WS_CATALOG''/mylocalsite/');
    define('DIR_WS_HTTPS_CATALOG''/mylocalsite/');

    /**
     * This is the complete physical path to your store's files.  eg: /var/www/vhost/accountname/public_html/store/
     * Should have a closing / on it.
     */
    define('DIR_FS_CATALOG''/var/www/mylocalsite/');

    /**
     * The following settings define your database connection.
     * These must be the SAME as you're using in your non-admin copy of configure.php
     */
    define('DB_TYPE''mysql'); // always 'mysql'
    define('DB_PREFIX''zen_'); // prefix for database table names -- preferred to be left empty
    define('DB_CHARSET''utf8'); // 'utf8' or 'latin1' are most common
    define('DB_SERVER''localhost');  // address of your db server
    define('DB_SERVER_USERNAME''userwhatever');
    define('DB_SERVER_PASSWORD''passwordwhatever');
    define('DB_DATABASE''onefivefive');

    /**
     * This is an advanced setting to determine whether you want to cache SQL queries.
     * Options are 'none' (which is the default) and 'file' and 'database'.
     */
    define('SQL_CACHE_METHOD''none');

    /**
     * Reserved for future use
     */
    define('SESSION_STORAGE''reserved for future use');

    /**
     * Advanced use only:
     * The following are OPTIONAL, and should NOT be set unless you intend to change their normal use. Most sites will leave these untouched.
     * To use them, uncomment AND add a proper defined value to them.
     */
    // define('DIR_FS_SQL_CACHE' ...
    // define('DIR_FS_DOWNLOAD' ...
    // define('DIR_FS_LOGS' ...

    // End Of File

  9. #9
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: v155 System Setup needs URL for intranet install?

    It's not uncommon for ip-address-only to fail to set cookies properly, causing login problems.
    I do NOT recommend using an IP address in HTTP_SERVER or HTTPS_SERVER.

    (I'm glad it's worked for frank18, but it usually runs into issues with most folks.)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. Replies: 5
    Last Post: 13 Sep 2011, 11:35 PM
  2. 'System Setup Required' after install error
    By EggDesign in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 7 Sep 2010, 11:07 AM
  3. Zencart Install> System Setup> Physical path is incorrect
    By dsydius in forum General Questions
    Replies: 2
    Last Post: 9 Aug 2010, 03:50 PM
  4. New install repeats 'Welcome' after 'System Setup'
    By WebtrixAU in forum Installing on a Linux/Unix Server
    Replies: 0
    Last Post: 15 Jul 2007, 11:34 AM
  5. Can't get past "system setup" on install
    By WhotEva in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 15 Nov 2006, 09:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR