Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2013
    Location
    Spokane, Washington, United States
    Posts
    8
    Plugin Contributions
    0

    Default Should I upgrade to UTF-8 mb4 unicode?

    I am upgrading from 1.54 to 1.55d. So far everything seems to be work fine. I read somewhere that UTF-8 mb4 can handle special characters better than the standard UTF-8 Unicode database format. I have searched everywhere for answers, and nobody talks about which UTF-8 format I should use.

    Can I simply create a new "UTF-8 mb4 Unicode Ci" database and then import the old "UTF-8 Unicode Ci" tables into it?

    I am wanting a web store that will be visible in different countries, and will allow different languages in the future. Is UTF-8 mb4 significantly better?

    Charles

  2. #2
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Should I upgrade to UTF-8 mb4 unicode?

    The 'utf8mb4' charset and 'utf8mb4_unicode_ci' collation in MySQL 5.7 are being popularized by sites that regularly store Emoji multibyte characters.
    If you don't need those characters in your product descriptions and customer names etc then it's possible you don't really need to switch.
    If you were running a blog and encouraging informal comments and other casual chat which you were storing in your database, then that might warrant a change for the tables which store that data.

    There's a downside to switching: If you have fields in your database set to VARCHAR(255) (or actually any number greater than 191) then you'll have to change them down to VARCHAR(191) to accommodate the shorter limits allowed in the utf8mb4 spec. In doing so you could lose data for fields that are actually storing more than 191 characters.

    There may be other caveats involved in the conversion of existing data, too.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Jun 2013
    Location
    Spokane, Washington, United States
    Posts
    8
    Plugin Contributions
    0

    Default Re: Should I upgrade to UTF-8 mb4 unicode?

    Thank you so much!

    What are the language limitations of the UTF-8 Unicode-ci Database? If for example, I wanted to use a Chinese language pack on my site, would I be required to use the UTF-8mb4 format? I am considering adding new languages to my site.

    Could you briefly explain what I would need to do to upgrade my database from UTF-8 Unicode ci, to UTF-8mb4 Unicode ci? I had read that you can import the old UTF-8 database directly into the new UTF-8mb4 database without any conversion. Is this true?
    Last edited by Ritalie; 28 Feb 2017 at 05:33 AM.

  4. #4
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Should I upgrade to UTF-8 mb4 unicode?

    Quote Originally Posted by Ritalie View Post
    What are the language limitations of the UTF-8 Unicode-ci Database? If for example, I wanted to use a Chinese language pack on my site, would I be required to use the UTF-8mb4 format?
    I don't know. I've never used Chinese language.

    Quote Originally Posted by Ritalie View Post
    Could you briefly explain what I would need to do to upgrade my database from UTF-8 Unicode ci, to UTF-8mb4 Unicode ci? I had read that you can import the old UTF-8 database directly into the new UTF-8mb4 database without any conversion. Is this true?
    Not sure. I imagine your insights into the languages may afford you better results while searching google than I would get.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 

Similar Threads

  1. Replies: 3
    Last Post: 22 Nov 2013, 03:29 PM
  2. How do I upgrade an existing site to UTF-8
    By totalsam in forum Addon Language Packs
    Replies: 1
    Last Post: 14 Aug 2011, 02:17 AM
  3. my language is Spanish -- should I install ZenCart using 8859-1 or UTF-8?
    By JuanLuis in forum Installing on a Windows Server
    Replies: 0
    Last Post: 12 Apr 2011, 08:12 AM
  4. Should I upgrade?
    By openvista in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 7 May 2010, 08:59 PM
  5. Should I upgrade?
    By Paddski in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 7 Nov 2008, 04:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR