Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Join Date
    May 2012
    Posts
    105
    Plugin Contributions
    0

    red flag suddenly ssl not working

    [Note: remember to include site URL, ZC version, list of plugins, PHP version, etc ... read the Posting Tips shown above for information to include in your post here. And, remove this comment before actually posting!]
    Yesterday I get one customer tell me, that my zencart not function good,
    they try to check out the amount change to 0, and when checkout it shows not transfer save
    I have SSL ,and I confirm with FATCAW they said my https is running, but every time I try to check out, it show unsafe sign, and also I cannot log in my store backend, also show unsafe and I try to approve, but I not let me log in

    Is any have this problem, and how to salve

  2. #2
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    4,608
    Plugin Contributions
    1

    Default Re: ssl not working cannot login to my backend

    Unfortunately you have more than one problem going on.

    1. Looks you are using a template from TemplateMonster. Their templates are known to cause problems and suggest using another. Search the forum for more on TemplateMonster.

    2. Although you are using https in your configure.php you have many page links that use http and Browsers will giving Warning msg. They all need to be replaced.

    3. Something wrong in your setup as the 'zenid' in the URL never goes away. Someone else had same problem but solution wasn't found. Perhaps also template related... just guessing though.
    The learning is in the doing.

    Potent Products

  3. #3
    Join Date
    May 2012
    Posts
    105
    Plugin Contributions
    0

    Default Re: ssl not working cannot login to my backend

    Quote Originally Posted by Website Rob View Post
    Unfortunately you have more than one problem going on.

    1. Looks you are using a template from TemplateMonster. Their templates are known to cause problems and suggest using another. Search the forum for more on TemplateMonster.

    2. Although you are using https in your configure.php you have many page links that use http and Browsers will giving Warning msg. They all need to be replaced.

    3. Something wrong in your setup as the 'zenid' in the URL never goes away. Someone else had same problem but solution wasn't found. Perhaps also template related... just guessing though.
    I use the template and website for 3 years already , and works no problems
    and this just happen last week. is possible cause by the ISP FatCow ?
    I get their email as:
    Sorry for the inconvenience this might have caused you. We have upgraded the SHA signature of SSL certificate installed for domain www.directsilk.com . Also, the store at https://directsilk.com is loading fine without any issues. Please clear your browser cache and check the website functionality.

    However, when trying to add products to cart and checkout I could see that the products are not getting added properly. I could not find any issues from our server end. The PHP variables are all updated fine. So, please recheck the configuration of the website with help of your application vendor or web developer.

  4. #4
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: ssl not working cannot login to my backend

    Since you appear to have either an htaccess rule or something else in place to force visitors to go to https:, you should also update your includes/configure.php to have all visits directed to https:. Change HTTP_SERVER to begin with https:

    It has also been suggested to set the ENABLE_SSL to false in that situation, but would want to know what payment modules you use before making that change as there are some minor modifications needed for a ZC 1.5.4 site to operate that way.

    Otherwise, as for the 0ing of the price, reportedly there are some server settings that if not otherwise handled can cause that sort of issue. Basically that an empty "value" is attempted to be stored into a database field that would accept a zero, but not blank and ZC needs to cast that value as a float in order for it to pass on properly.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    3,440
    Plugin Contributions
    9

    Default Re: ssl not working cannot login to my backend

    Tend to agree with Website Rob re Template Monster template, they are monsters!

    Did you check the /logs folder for error entries? If not, you should do that and post recent errors here.

    Which PHP version are you using?

    Did your host recently change the PHP version on your server?

    Also noted that you are still using ZC version 1.5.4 - should be upgraded to the latest v 1.5.5e (which may or may not cause further problems with your template)

  6. #6
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: ssl not working cannot login to my backend

    When your host changed your SSL, it appears they changed your domain configuration to also make every page be served as https. This is a growing trend, and is usually a good idea.

    But ... if you're going to do that you need to change your Zen Cart configure.php files to define HTTP_SERVER to have an https URL in it ... in both admin and non-admin versions of the configure.php files. (NOTE: The files are not identical, so edit them separately. Don't copy one over-top of the other.)
    After you've done that you'll need to visit every page to find out whether the padlock stays active on each page, and then fix whatever assets are coded wrong in your template: This page contains both secure and nonsecure items (or "Unauthenticated content" or "connection partially encrypted").

    Or you could have your hosting company put the domain back to allowing you to control when you want to serve pages over https.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  7. #7
    Join Date
    May 2012
    Posts
    105
    Plugin Contributions
    0

    Default Re: ssl not working cannot login to my backend

    Quote Originally Posted by DrByte View Post
    When your host changed your SSL, it appears they changed your domain configuration to also make every page be served as https. This is a growing trend, and is usually a good idea.

    But ... if you're going to do that you need to change your Zen Cart configure.php files to define HTTP_SERVER to have an https URL in it ... in both admin and non-admin versions of the configure.php files. (NOTE: The files are not identical, so edit them separately. Don't copy one over-top of the other.)
    After you've done that you'll need to visit every page to find out whether the padlock stays active on each page, and then fix whatever assets are coded wrong in your template: This page contains both secure and nonsecure items (or "Unauthenticated content" or "connection partially encrypted").

    Or you could have your hosting company put the domain back to allowing you to control when you want to serve pages over https.
    Thanks I try to contact FATCOW, hope they can put my domain back to control by zencart

  8. #8
    Join Date
    May 2012
    Posts
    105
    Plugin Contributions
    0

    red flag Since my SSL not working for my site, can I use PAYPAL to collect the money

    [Note: remember to include site URL, ZC version, list of plugins, PHP version, etc ... read the Posting Tips shown above for information to include in your post here. And, remove this comment before actually posting!]
    the FATCOW update their SSL system, my website (directsilk.com) cannot login my backend , and cannot place the order.
    Can I just turn off the SSL, and when I collect the money, I use paypal change to their website to collect money
    Hope that can work

  9. #9
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Since my SSL not working for my zencart, can I use PAYPAL to collect the money

    Yes you can just turn off ssl (includes/configure.php and admin/includes/configure.php) change ENABLE_SSL to false and be sure that HTTP_HOST has http: in it. Also if they have created a file at the store or a directory above called .htaccess, it may need a modification to prevent all users from still being redirected to https:.
    Then there is a process to follow to first be sure that things are ready to support using the ssl in the future: https://www.zen-cart.com/content.php...alled-zen-cart
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  10. #10
    Join Date
    May 2012
    Posts
    105
    Plugin Contributions
    0

    red flag purchase an item but try to check shows no order

    I purchase an item but try to check shows no order, the zencart works fine for 3years, but suddenly not let me go through the purchasing procedure
    Recently resolved a sudden SSL problem on my site.

    how I solve the checkout problem

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. v151 AIM Authorize.net module suddenly quit working due to SSL communications error?
    By Johnnycopilot in forum Addon Payment Modules
    Replies: 13
    Last Post: 30 Aug 2016, 07:20 PM
  2. v139h suddenly access to admin not working
    By stitchnkitty in forum General Questions
    Replies: 21
    Last Post: 1 Sep 2014, 02:28 AM
  3. Product URL suddenly not working
    By SethF in forum General Questions
    Replies: 1
    Last Post: 12 Dec 2011, 05:18 PM
  4. International Shipping suddenly not working
    By Aderra in forum Built-in Shipping and Payment Modules
    Replies: 2
    Last Post: 12 Dec 2009, 05:47 PM
  5. SSL Stopped Working Suddenly
    By davik1000 in forum General Questions
    Replies: 8
    Last Post: 25 Aug 2006, 04:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR