Results 1 to 5 of 5
  1. #1
    Join Date
    May 2005
    Posts
    517
    Plugin Contributions
    0

    Default PHP Warning: MySQL Headers and client library minor version mismatch

    PHP Warning: mysqli_connect(): Headers and client library minor version mismatch. Headers:50635 Library:50552


    I have read somewhere I need to get the php modules for mysqlnd etc repaired or installed or flushed out or something.

    But not worked. using cpanel and hosting company has just told me to select my desired version of php and select the modules. Done this. still get errors in logs.


    So what version of PHP for zc 1.5.5e should I use. cpanel give option of php 7 and 5.6 and 5.5 and 5.4 etc. Currently tried php 7 and selected various php mysql modules but still getting this error log - which is preventing the site from loading completely.

    Any ideas to try?

    I am getting rather dissolutioned. All started trying to cure a error with too many redirects - has forced my to try a complete upgrade. still not sure if resolved as not got new problems.


    Thanks

  2. #2
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    957
    Plugin Contributions
    1

    Default Re: PHP Warning: mysqli_connect():

    your hosting company should be able to help.

    that said, under the modules you want to remove:

    php5-mysql

    and install this instead:

    php5-mysqlnd

    i would start with php 5.6 - which is compatible with 1.5.5e. see:

    https://www.zen-cart.com/content.php...o-run-zen-cart

    in addition, i am not sure that this error (which looks to be a warning) would prevent your site from loading. but i could be wrong....

    finally, too many redirects hardly seems like a reason for a complete upgrade; although running the latest version, when possible, is always a good idea.

    good luck!
    feel free to donate money to carl or to the Zen-Cart Team

  3. #3
    Join Date
    May 2005
    Posts
    517
    Plugin Contributions
    0

    Default Re: PHP Warning: mysqli_connect():

    carlwhat

    thank you for your reply. Have just tried various combinations:

    mysql
    mysqli
    mysqlnd

    with both php 5.6 and php7.

    if I turn mysqli off then all fails if I have mysqli on its own or any of the others I get all the error logs occurring with

    mysqli_connect(): Headers and client library minor version mismatch. Headers:50634 Library:50552

    I am looking into why part of my front page does not load. obviously something else if you don't think this would cause a part of the code not to load. I suspect a setting.

    The reason the redirects error was an issue was it came up as a blank error page in every browser and customers could not go from shopping cart to check out the page would never load. it just came up with this error which in chrome was err_too_many_redirects. In ms iexplorer it cam up as a connection error with their fix connection button. Not a very good user experience especially since they could not get past that page.

    So trying a whole new install. 1.5.5e

    Thanks for the heads up. I will see if the hosting company will find the compatibility with versions and settings to get rid of the warnings.

    so far it has generated 700+ log files though with me just testing.

  4. #4
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    957
    Plugin Contributions
    1

    Default Re: PHP Warning: mysqli_connect():

    you definitely need mysqli.

    if you send me your url, we can look at what is not loading on your front page.

    best.
    feel free to donate money to carl or to the Zen-Cart Team

  5. #5
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    4,608
    Plugin Contributions
    1

    Default Re: PHP Warning: mysqli_connect():

    Quote Originally Posted by MikeyG View Post
    PHP Warning: mysqli_connect(): Headers and client library minor version mismatch. Headers:50635 Library:50552
    Unless you have server access, this is not a problem you can correct. The PHP version being used (no matter which version) has not been compiled to use the current version of MySQL. Your Hoster will need to correct this problem.
    The learning is in the doing.

    Potent Products

 

 

Similar Threads

  1. mysqli_connect(): Headers and client library minor version mismatch.
    By aurum.genesis in forum General Questions
    Replies: 3
    Last Post: 15 Feb 2017, 04:12 PM
  2. Replies: 1
    Last Post: 14 Feb 2017, 11:59 PM
  3. v153 PHP and MySQL version recommendation?
    By RixStix in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 5 Aug 2014, 01:32 AM
  4. phpMyAdmin SQL library version mismatch info message
    By sloruss in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 2 Nov 2008, 06:42 AM
  5. Which webhost and PHP/MySQL version best for Zen Cart?
    By dinosoup in forum General Questions
    Replies: 1
    Last Post: 15 May 2007, 04:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR