Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,977
    Plugin Contributions
    63

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Quote Originally Posted by lindagal2 View Post
    Thx Rick -- was just coming back to edit my post and say I'd fixed the maintenance text.

    Now I still need to find where to access and download prior versions of ZenCart!
    The prior releases can be downloaded from here (the Zen Cart Source Forge repository).

  2. #12
    Join Date
    Jul 2012
    Posts
    11,625
    Plugin Contributions
    13

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Quote Originally Posted by lindagal2 View Post
    Thanks very much for the responses. So that leaves me with two questions.

    First off, I believe my process will be:
    1. Turn off store / create "down for maintenance" message;
    2. Attempt hard reset the password through phpMyAdmin;
    3. Attempt upgrade from 1.2.6 to 1.5.5e using the latest 1.5.5e install (hopefully being able to ACCESS it with new pw).
    4. If either the new pw doesn't work OR the sequential upgrade built into 1.5.5e doesn't work ....
    5. Download an earlier copy of zencart (note -- have to search where to locate one!) and try interim install.

    So question 1: Where do I find earlier downloads of ZenCart if I have to attempt interim upgrades rather than go through 1.5.5e upgrade page?


    And question 2: How do I change the text of the "down for maintenance" file? (My php knowledge is woefully small). I found the down_for_maintenance info in /includes/modules/pages/down_for_maintenance/header_php.php but don't know how to find the text to change. Here is what the header.php reads:

    Code:
    <?php
    /**
     * Down For Maintenance
     *
     * @package page
     * @copyright Copyright 2003-2006 Zen Cart Development Team
     * @copyright Portions Copyright 2003 osCommerce
     * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
     * @version $Id: header_php.php 4045 2006-07-30 23:10:08Z drbyte $
     */
    require(DIR_WS_MODULES . zen_get_module_directory('require_languages.php'));
    $breadcrumb->add(NAVBAR_TITLE);
    
    if (DOWN_FOR_MAINTENANCE_COLUMN_RIGHT_OFF == 'true') $flag_disable_right = true;
    if (DOWN_FOR_MAINTENANCE_COLUMN_LEFT_OFF == 'true') $flag_disable_left = true;
    if (DOWN_FOR_MAINTENANCE_FOOTER_OFF == 'true') $flag_disable_footer = true;
    if (DOWN_FOR_MAINTENANCE_HEADER_OFF == 'true') $flag_disable_header = true;
    
    if (DOWN_FOR_MAINTENANCE == 'true') {
      $sql = "SELECT last_modified from " . TABLE_CONFIGURATION . " 
              WHERE configuration_key = 'DOWN_FOR_MAINTENANCE'";
      
      $maintenance_on_at_time = $db->Execute($sql);
      define('TEXT_DATE_TIME', $maintenance_on_at_time->fields['last_modified']);
    }
    
    header("HTTP/1.1 503 Service Unavailable"); 
    
    ?>

    NOTE: I used the following directions from a prior ZC forum thread to find this file but am rather lost now: "All text is edited in the language files or through the admin.

    Put the phrase you want to change in the Admin> Tools> Developer's Tool kit, lower left, choose all files, click go- the exact file to copy to your overrides will be listed."

    When I searched for "down for maintenance" under all files there were no hits, only when I searched "template things" did I get this page.
    To be sure about this "process", you are doing this with/to your backup copy of your store, correct? You are not taking down your active, functional, live site at this moment, correct?

    All files, folders, database etc, are a backup copy and can be replaced if something goes wrong, correct?

    And you have looked at and/or are considering using the guidance/instruction provided here to perform even this test upgrade?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  3. #13
    Join Date
    Jan 2008
    Posts
    76
    Plugin Contributions
    0

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Quote Originally Posted by mc12345678 View Post
    To be sure about this "process", you are doing this with/to your backup copy of your store, correct? You are not taking down your active, functional, live site at this moment, correct?

    All files, folders, database etc, are a backup copy and can be replaced if something goes wrong, correct?

    And you have looked at and/or are considering using the guidance/instruction provided here to perform even this test upgrade?
    YES, definitely installing in a new test directory AND using a backup copy of the original store database.

    However, I'm still up against another brick wall. Have tried hard reset of password by running query through phpMyAdmin and then using Admin/admin user/pw combo ... does not work. Then I tried a fresh install an old version of ZenCart downloaded from sourceforge ... couldn't even get the install to work. Gave me an error message re access to db, even a newly created db with new user and password. So couldn't complete the install of the older version of ZC. (Note: I have no trouble installing version 1.5.5e and accessing db for fresh install -- the only problem accessing db is when I replace db with backup from original store, it won't read the imported db backup ).

    So I'm really stumped. Any other ideas before I have to start from scratch and re-enter a ton of information?

    PS A thought ... I'm not adding prior store customizations to new install. At this point I'm just trying to get it to work with existing product even if I lose all customizations. Could this cause a problem?
    Last edited by lindagal2; 5 Jul 2017 at 01:30 AM.

  4. #14
    Join Date
    Jul 2012
    Posts
    11,625
    Plugin Contributions
    13

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    No. Your store should operate just fine without other customizations applied.

    Now, earlier there was discussion of a DB_PREFIX, but don't seem to recall seeing the result/answer. The other thing I don't think I recall seeing is what version of PHP is involved? An older version say, ZC 1.3.9 which operates within a relatively low band of php.

    Another thing/thought. When you ran the hard password reset against your old database, what sql did you apply?
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #15
    Join Date
    Jan 2008
    Posts
    76
    Plugin Contributions
    0

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Quote Originally Posted by mc12345678 View Post
    No. Your store should operate just fine without other customizations applied.

    Now, earlier there was discussion of a DB_PREFIX, but don't seem to recall seeing the result/answer. The other thing I don't think I recall seeing is what version of PHP is involved? An older version say, ZC 1.3.9 which operates within a relatively low band of php.

    Another thing/thought. When you ran the hard password reset against your old database, what sql did you apply?
    Re the prefix, my hosting site uses french_ as a prefix for all dbs but there are no prefixes for the store, so that was ruled out.

    Re the php version, I'm beginning to believe that may be the culprit. When I tried to install version 1.5.1, it simply would not read db no matter what I did. Yt 1.5.4 installed fine, and upon importing db, recognized the Admin/admin and upgraded everything from 1.5.0 onward but NOT anything below, like 1.3x. Simply would not recognize db.

    Re the phpMyAdmin, there are two scripts. I applied the 1.5.x script rather than the 1.3.9.older script simply because the second script wouldn't work (did not recognize column with admin-level) and the former did. Perhaps that's why nothing prior to 1.3.9 would upgrade??

    BTW, here is response when I ran 1.5.x password reset script:
    Code:
    0 rows affected. (Query took 0.0006 seconds.)
    DELETE FROM admin WHERE admin_name = 'Admin'
    [ Edit inline ] [ Edit ] [ Create PHP code ]
    1 row inserted. [br] Inserted row id: 1 (Query took 0.0011 seconds.)
    INSERT INTO admin (admin_name, admin_email, admin_pass, admin_profile) VALUES ('Admin', 'admin@localhost', '351683ea4e19efe34874b501fdbf9792:9b', 1)
    What do you think?

    ADDENDUM: Just tried to upgrade 1.5.4 again. The password reset does work on that version but the upgrade still doesn't. Here are the errors displayed:

    Code:
    127 statements processed.
    Note: 61 statements ignored. See "upgrade_exceptions" table for additional details.
    11 statements processed.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details.
    14 statements processed.
    62 statements processed.
    Note: 39 statements ignored. See "upgrade_exceptions" table for additional details.
    32 statements processed.
    Note: 3 statements ignored. See "upgrade_exceptions" table for additional details.
    16 statements processed.
    Note: 3 statements ignored. See "upgrade_exceptions" table for additional details.
    69 statements processed.
    Note: 7 statements ignored. See "upgrade_exceptions" table for additional details.
    32 statements processed.
    Note: 2 statements ignored. See "upgrade_exceptions" table for additional details.
    13 statements processed.
    34 statements processed.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details.
    6 statements processed.
    AND FURTHER DETAIL on which statements were skipped:

    Code:
    SKIPPED: Cannot insert prod-type-layout configuration_key "SHOW_PRODUCT_INFO_ADDITIONAL_IMAGES" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "SHOW_PRODUCT_MUSIC_INFO_ADDITIONAL_IMAGES" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "SHOW_DOCUMENT_GENERAL_INFO_ADDITIONAL_IMAGES" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "SHOW_DOCUMENT_PRODUCT_INFO_ADDITIONAL_IMAGES" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "SHOW_PRODUCT_FREE_SHIPPING_INFO_ADDITIONAL_IMAGES" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTES_DISPLAY_ONLY" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTE_IS_FREE" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTES_DEFAULT" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTES_DISCOUNTED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTES_PRICE_BASE_INCLUDED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_ATTRIBUTES_REQUIRED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_PRICE_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTES_DISPLAY_ONLY" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTE_IS_FREE" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTES_DEFAULT" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTES_DISCOUNTED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTES_PRICE_BASE_INCLUDED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_ATTRIBUTES_REQUIRED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_PRICE_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_MUSIC_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTES_DISPLAY_ONLY" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTE_IS_FREE" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTES_DEFAULT" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTES_DISCOUNTED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTES_PRICE_BASE_INCLUDED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_ATTRIBUTES_REQUIRED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_PRICE_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_GENERAL_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTES_DISPLAY_ONLY" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTE_IS_FREE" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTES_DEFAULT" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTES_DISCOUNTED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTES_PRICE_BASE_INCLUDED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_ATTRIBUTES_REQUIRED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_PRICE_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_DOCUMENT_PRODUCT_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTES_DISPLAY_ONLY" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTE_IS_FREE" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTES_DEFAULT" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTES_DISCOUNTED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTES_PRICE_BASE_INCLUDED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_ATTRIBUTES_REQUIRED" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_PRICE_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot insert prod-type-layout configuration_key "DEFAULT_PRODUCT_FREE_SHIPPING_PRODUCTS_ATTRIBUTES_WEIGHT_PREFIX" because it already exists
    SKIPPED: Cannot CHANGE column month because it does not exist.
    SKIPPED: Cannot ADD column session_counter because it already exists.
    SKIPPED: Cannot ADD column products_options_rows because it already exists.
    SKIPPED: Cannot create table ezpages because it already exists
    SKIPPED: Cannot create table meta_tags_categories_description because it already exists
    SKIPPED: Cannot drop index idx_categories_parent_id_zen on table categories because it does not exist.
    SKIPPED: Cannot drop index idx_customer_id_zen on table coupon_gv_customer because it does not exist.
    SKIPPED: Cannot drop index idx_orders_id_zen on table orders_products because it does not exist.
    SKIPPED: Cannot drop index idx_paypal_paypal_ipn_id_zen on table paypal because it does not exist.
    SKIPPED: Cannot drop index idx_prod_opt_val_id_zen on table products_options_values because it does not exist.
    SKIPPED: Cannot drop index orders_id_prod_id_zen on table orders_products because it does not exist.
    SKIPPED: Cannot add index idx_orders_id_prod_id_zen to table orders_products because it already exists.
    SKIPPED: Cannot add index idx_tpl_lang_zen to table template_select because it already exists.
    SKIPPED: Cannot add index idx_ot_class_zen to table orders_total because it already exists.
    SKIPPED: Cannot add index idx_coupon_code_zen to table coupons because it already exists.
    SKIPPED: Cannot add index idx_coupon_type_zen to table coupons because it already exists.
    SKIPPED: Cannot add index idx_coupon_type_zen to table coupons because it already exists.
    SKIPPED: Cannot add index idx_coupon_type_zen to table coupons because it already exists.
    SKIPPED: Cannot add index idx_coupon_type_zen to table coupons because it already exists.
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot insert configuration_group_title "EZ-Pages Settings" because it already exists
    SKIPPED: Cannot add index idx_layout_box_sort_order_zen to table layout_boxes because it already exists.
    SKIPPED: Cannot add index idx_clip_type_zen to table media_clips because it already exists.
    SKIPPED: Cannot add index idx_media_name_zen to table media_manager because it already exists.
    SKIPPED: Cannot add index idx_type_name_zen to table media_types because it already exists.
    SKIPPED: Cannot add index idx_products_date_available_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_products_ordered_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_products_model_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_products_price_sorter_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_master_categories_id_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_products_sort_order_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_manufacturers_id_zen to table products because it already exists.
    SKIPPED: Cannot add index idx_opt_sort_order_zen to table products_attributes because it already exists.
    SKIPPED: Cannot add index idx_products_options_sort_order_zen to table products_options because it already exists.
    SKIPPED: Cannot add index idx_products_options_name_zen to table products_options because it already exists.
    SKIPPED: Cannot add index idx_products_options_values_name_zen to table products_options_values because it already exists.
    SKIPPED: Cannot add index idx_products_options_values_sort_order_zen to table products_options_values because it already exists.
    SKIPPED: Cannot add index idx_products_options_id_zen to table products_options_values_to_products_options because it already exists.
    SKIPPED: Cannot add index idx_products_options_values_id_zen to table products_options_values_to_products_options because it already exists.
    SKIPPED: Cannot add index idx_artists_id_zen to table product_music_extra because it already exists.
    SKIPPED: Cannot add index idx_record_company_id_zen to table product_music_extra because it already exists.
    SKIPPED: Cannot add index idx_admin_email_zen to table admin because it already exists.
    SKIPPED: Cannot add index idx_expires_date_zen to table banners because it already exists.
    SKIPPED: Cannot add index idx_date_scheduled_zen to table banners because it already exists.
    SKIPPED: Cannot add index idx_expires_date_zen to table featured because it already exists.
    SKIPPED: Cannot add index idx_expires_date_zen to table specials because it already exists.
    SKIPPED: Cannot add index idx_date_purchased_zen to table orders because it already exists.
    SKIPPED: Cannot add index idx_address_format_id_zen to table countries because it already exists.
    SKIPPED: Cannot add index idx_iso_2_zen to table countries because it already exists.
    SKIPPED: Cannot add index idx_iso_3_zen to table countries because it already exists.
    SKIPPED: Cannot add index idx_zone_country_id_zen to table zones because it already exists.
    SKIPPED: Cannot add index idx_zone_code_zen to table zones because it already exists.
    SKIPPED: Cannot add index idx_zones_zen to table zones_to_geo_zones because it already exists.
    SKIPPED: Cannot add index idx_type_id_sort_order_zen to table product_type_layout because it already exists.
    SKIPPED: Cannot add index idx_status_zen to table reviews because it already exists.
    SKIPPED: Cannot add index idx_date_added_zen to table reviews because it already exists.
    SKIPPED: Cannot add index idx_sale_date_start_zen to table salemaker_sales because it already exists.
    SKIPPED: Cannot add index idx_sale_date_end_zen to table salemaker_sales because it already exists.
    SKIPPED: Cannot add primary key to table authorizenet because a primary key already exists.
    SKIPPED: Cannot drop index idx_auth_net_id on table authorizenet because it does not exist.
    SKIPPED: Cannot drop index idx_auth_net_id on table authorizenet because it does not exist.
    SKIPPED: Cannot drop index idx_auth_net_id on table authorizenet because it does not exist.
    SKIPPED: Cannot drop index idx_auth_net_id on table authorizenet because it does not exist.
    SKIPPED: Cannot ADD column get_term_table because it already exists.
    SKIPPED: Cannot ADD column get_term_name_field because it already exists.
    SKIPPED: Cannot ADD column get_term_name_field because it already exists.
    SKIPPED: Cannot ADD column get_term_name_field because it already exists.
    SKIPPED: Cannot ADD column get_term_name_field because it already exists.
    SKIPPED: Cannot ADD column coupon_zone_restriction because it already exists.
    SKIPPED: Cannot ADD column customers_paypal_payerid because it already exists.
    SKIPPED: Cannot ADD column customers_paypal_ec because it already exists.
    SKIPPED: Cannot insert configuration_key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists
    SKIPPED: Cannot insert configuration_key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists
    SKIPPED: Cannot insert configuration_key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists
    SKIPPED: Cannot insert configuration_key "DEFINE_PAGE_NOT_FOUND_STATUS" because it already exists
    SKIPPED: Cannot ADD column module_name because it already exists.
    SKIPPED: Cannot ADD column module_mode because it already exists.
    SKIPPED: Cannot ADD column module_name because it already exists.
    SKIPPED: Cannot ADD column module_mode because it already exists.
    SKIPPED: Cannot CHANGE column zen_order_id because it does not exist.
    SKIPPED: Cannot CHANGE column zen_order_id because it does not exist.
    SKIPPED: Cannot ALTER or INSERT/REPLACE into table linkpoint_api because it does not exist. CHECK PREFIXES!
    SKIPPED: Cannot add index idx_prod_id_orders_id_zen to table orders_products because it already exists.
    SKIPPED: Cannot add index idx_cust_id_orders_id_zen to table orders because it already exists.
    SKIPPED: Cannot ADD column status because it already exists.
    Last edited by lindagal2; 5 Jul 2017 at 03:46 AM. Reason: added additional response from upgrade attempt

  6. #16
    Join Date
    Jan 2008
    Posts
    76
    Plugin Contributions
    0

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    ADDENDUM #2 to my response above:

    I then chose to run the upgrade again (which I think tries to upgrade any versions not done in the first upgrade process), and got a different set of remarks/skips ...these may be the problem with the pw for earlier versions. (ZC forum will not let me include those in my response because they are too long!).

  7. #17
    Join Date
    Jan 2008
    Posts
    76
    Plugin Contributions
    0

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    ADDENDUM #3 to above thread:

    So after running the 1.5.4 upgrade multiple times, it upgrades most of the versions (skipping some statements but still upgrades) yet still says "database upgrade required. please run the 1.3.9-to-1.5.0 upgrade via zc_install" when I try to access login.

    Upon re-running the upgrade, these are the versions that will not upgrade:
    Upgrade DB from 1.3.0.2 to 1.3.5
    Upgrade DB from 1.3.7 to 1.3.8
    Upgrade DB from 1.5.1 to 1.5.2

    So that's where I'm stuck.

  8. #18
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    If you're using the v1.5.4 zc_install to do the db upgrade, the v1.3.9-to-1.5.0 step is looking for a "reset_token" and "last_failed_ip" field in the "admin" table in the database.
    I wonder if your admin table has been changed somehow that's causing these fields to go missing?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  9. #19
    Join Date
    Jul 2012
    Posts
    11,625
    Plugin Contributions
    13

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Like I said before about the "messages" some of them can just be ignored because they are stating a point of fact.As for the database sql... the sql applies to the contents of the database not to the files or the new version. Think about it a little. There is a system that is expecting to handle/manage an old version of ZC. Therefore, the password, among other things are expected to be as one would have found "back in the day". Therefore, to verify allowance to access/upgrade, the table(s) need to be arranged and authorized like they were back then...As for the "checkboxes". The update should be done from start to finish not in pieces (or at least not in skipping of pieces). That said, there are some sections of the upgrade that may have already "been done" by the use of more recently upgraded/updated plugins. So in fact while the software may not be installed in this test case, the fact that "it" was installed could have prevented one or more of the individual upgrade steps from being performed. Now, as for all of the messages, I skimmed through them and didn't see anything other than can't do because already done or because missing... those are "normal". It is something like "check prefixes" or something more "informative".
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  10. #20
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    4,608
    Plugin Contributions
    1

    Default Re: Imported old db to new test store install -- trying to upgrade & cannot log in

    Quote Originally Posted by lindagal2 View Post
    ADDENDUM: Just tried to upgrade 1.5.4 again. The password reset does work on that version but the upgrade still doesn't. Here are the errors displayed:

    Code:
    127 statements processed.
    Note: 61 statements ignored. See "upgrade_exceptions" table for additional details.
    11 statements processed.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details.
    14 statements processed.
    62 statements processed.
    Note: 39 statements ignored. See "upgrade_exceptions" table for additional details.
    32 statements processed.
    Note: 3 statements ignored. See "upgrade_exceptions" table for additional details.
    16 statements processed.
    Note: 3 statements ignored. See "upgrade_exceptions" table for additional details.
    69 statements processed.
    Note: 7 statements ignored. See "upgrade_exceptions" table for additional details.
    32 statements processed.
    Note: 2 statements ignored. See "upgrade_exceptions" table for additional details.
    13 statements processed.
    34 statements processed.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details.
    6 statements processed.
    If you were to use phpMyAdmin and look at the "upgrade_exceptions" TABLE, should find a lot of helpful information. Note that you may have two of these TABLES and if so, Browse the one that doesn't have 0 Rows.
    The learning is in the doing.

    Potent Products

 

 
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. v154 Install new store on Subdomain on different Server then old store
    By kwright in forum Installing on a Linux/Unix Server
    Replies: 10
    Last Post: 3 Feb 2016, 04:50 PM
  2. v154 New Install - Cannot change template 6th & 7th try Help
    By bearlymakinit in forum Templates, Stylesheets, Page Layout
    Replies: 16
    Last Post: 15 Apr 2015, 12:50 PM
  3. Cannot test store?
    By gourmets in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 9 Feb 2007, 04:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR