Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Database needs patching to a higher level

    I have a zen cart based store in operation for years here www.bookstore.sriramanamaharshi.org based on version 1.5.1. In order to upgrade to version 1.5.5e I did a fresh install in a test directory www.newstore.sriramanamaharshi.org with a new subdomain. Used mysqldump to repopulate the new store. While products are all showing OK I am having two issues. There is a message in admin. Your database appears to need patching to a higher level. See Tools->Server Information to review patch levels
    More seriously when I try to register my name as a new customer as the last step I get the error "refresh the page and try again" The login thereafter fails both with forgot password and the used password.
    Debug error log says state column missing in country. I have prset country to India and states of India show after first attempt but not initially. I didn't run a demo and suspect compatibility issues between the databases of 1.5.1 and 1.5.5. The environment is bluehost dedicated server running under nginx 1.13.3 after a recent upgrade to easyapache4 from easyapache3. Can someone help me with mysql database upgrade. I don't know which patch to use or how to do it correctly.

  2. #2
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Database needs patching to a higher level

    In what you posted, I don't see anywhere that you used zc_install to perform the actual database upgrade. That would explain many of your symptoms.

    Ref: http://www.zen-cart.com/entry.php?3-...d-of-upgrading
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Database needs patching to a higher level

    Does it mean that using mysqldump to populate the database prior to zc_install is a mistake and I have to redo the whole install?

  4. #4
    Join Date
    Jul 2012
    Posts
    11,640
    Plugin Contributions
    13

    Default Re: Database needs patching to a higher level

    Quote Originally Posted by Arunachala View Post
    Does it mean that using mysqldump to populate the database prior to zc_install is a mistake and I have to redo the whole install?
    If you check the referenced link. No it is not a mistake to place the database before running zc_install (a second time). In otherwords, right now if you were to upload a clean copy of the zc_install folder and follow the instructions to only do a database upgrade (do *not* choose to install) then the message will go away. (store will be in maintenance mode as well).
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Database needs patching to a higher level

    Thank You Dr. Byte. You are the man. I had done everything correct except pushed the button of fresh install instead of upgrade. In part it was caused by a bad memory which rightly believed that files are fresh install. Thanks

 

 

Similar Threads

  1. Database need higher patching level
    By mmambou in forum Upgrading from 1.3.x to 1.3.9
    Replies: 9
    Last Post: 18 Sep 2010, 02:45 AM
  2. Database needs patching to a higher level...?
    By bsp in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 14 Jan 2008, 04:37 AM
  3. Database needs patching to higher level (???)
    By Stormshade in forum Upgrading from 1.3.x to 1.3.9
    Replies: 8
    Last Post: 10 Dec 2007, 04:25 AM
  4. Database needs patching to higher level
    By tiger in forum Upgrading from 1.3.x to 1.3.9
    Replies: 12
    Last Post: 31 Jul 2007, 08:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR