Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2004
    Posts
    1,050
    Plugin Contributions
    1

    Default Upgrade error: Could not update to version 1.5.3. We detect that you currently...

    I am in the process of upgrading from 1.5.1 to 1.5.5e. When I'm upgrading the database, I'm getting an error that I've never seen before. I searched the forums but didn't get any results.

    I've attached a screenshot of what is happening. I cannot get it to upgrade from 1.5.2 to 1.5.3. It is stuck for some reason. I tried doing the database version upgrades one at a time, but still receive the same error.

    What do I need to do to resolve this error?

    Thank you!

    Name:  upgrade.jpg
Views: 50
Size:  37.6 KB
    Danielle

  2. #2
    Join Date
    Oct 2004
    Posts
    1,050
    Plugin Contributions
    1

    Default Re: Upgrade error: Could not update to version 1.5.3. We detect that you currently...

    This is what is in the log file:

    ---------------
    Aug 10 2017 6:11 -- upgradeException
    INSERT INTO address_format VALUES (7, '$firstname $lastname$cr$streets$cr$city $state $postcode$cr$country','$city $state / $country'); 1062: Duplicate entry '7' for key 'PRIMARY'

    ---------------
    Aug 10 2017 6:11 -- upgradeException
    ALTER TABLE countries ADD status tinyint(1) DEFAULT '1'; 1060: Duplicate column name 'status'

    ---------------
    Aug 10 2017 6:11 -- upgradeException
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('PA-DSS Admin Session Timeout Enforced?', 'PADSS_ADMIN_SESSION_TIMEOUT_ENFORCED', '1', 'PA-DSS Compliance requires that any Admin login sessions expire after 15 minutes of inactivity. <strong>Disabling this makes your site NON-COMPLIANT with PA-DSS rules, thus invalidating any certification.</strong>', 1, 30, now(), now(), NULL, 'zen_cfg_select_drop_down(array(array(\'id\'=>\'0\', \'text\'=>\'Non-Compliant\'), array(\'id\'=>\'1\', \'text\'=>\'On\')),'); 1364: Field 'configuration_tab' doesn't have a default value

    ---------------
    Aug 10 2017 6:11 -- upgradeException
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('PA-DSS Strong Password Rules Enforced?', 'PADSS_PWD_EXPIRY_ENFORCED', '1', 'PA-DSS Compliance requires that admin passwords must be changed after 90 days and cannot re-use the last 4 passwords. <strong>Disabling this makes your site NON-COMPLIANT with PA-DSS rules, thus invalidating any certification.</strong>', 1, 30, now(), now(), NULL, 'zen_cfg_select_drop_down(array(array(\'id\'=>\'0\', \'text\'=>\'Non-Compliant\'), array(\'id\'=>\'1\', \'text\'=>\'On\')),'); 1364: Field 'configuration_tab' doesn't have a default value

    ---------------
    Aug 10 2017 6:11 -- upgradeException
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Show linked status for categories', 'SHOW_CATEGORY_PRODUCTS_LINKED_STATUS', 'true', 'Show Category products linked status?', '1', '19', 'zen_cfg_select_option(array(\'true\', \'false\'), ', now()); 1364: Field 'configuration_tab' doesn't have a default value
    Danielle

  3. #3
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,977
    Plugin Contributions
    63

    Default Re: Upgrade error: Could not update to version 1.5.3. We detect that you currently...

    You'd installed a Numinix plugin on your prior database that added the field configuration_tab ... which, as the message in the log indicates, doesn't have a default value.

    You'll need to use your webhost's cPanel to access your site's phpMyAdmin and give that field (configuration table, configuration_tab field) a default value. I'd suggest 0 if the field is an integer value or '' for a character field-type.

  4. #4
    Join Date
    Oct 2004
    Posts
    1,050
    Plugin Contributions
    1

    Default Re: Upgrade error: Could not update to version 1.5.3. We detect that you currently...

    I have resolved this issue. For anyone receiving a similar error, it was the tabbed configuration that is used in many of the Numinix modules that was causing the problem.

    I removed the tabbed configuration using the instructions in this post: https://www.zen-cart.com/showthread....49#post1232649

    After that, I restarted the upgrade and it completed with no issues.
    Danielle

  5. #5
    Join Date
    Oct 2004
    Posts
    1,050
    Plugin Contributions
    1

    Default Re: Upgrade error: Could not update to version 1.5.3. We detect that you currently...

    Quote Originally Posted by lat9 View Post
    You'd installed a Numinix plugin on your prior database that added the field configuration_tab ... which, as the message in the log indicates, doesn't have a default value.

    You'll need to use your webhost's cPanel to access your site's phpMyAdmin and give that field (configuration table, configuration_tab field) a default value. I'd suggest 0 if the field is an integer value or '' for a character field-type.
    Thank you! I figured it out while you were posting this, although I fixed it by completely removing the tabbed configuration. I usually remove it from my sites anyways because it often causes issues when installing non-numinix modules.
    Danielle

 

 

Similar Threads

  1. Replies: 25
    Last Post: 29 May 2017, 03:51 AM
  2. v155 We detect that you currently have v1.5.2, and must perform the updates to get to...
    By badarac in forum Installing on a Linux/Unix Server
    Replies: 39
    Last Post: 20 Apr 2016, 02:29 AM
  3. v150 ERROR: Could not update to version 1.5.4. We detect that you currently have v1.5.2, a
    By rainbow_pixie_star in forum Upgrading to 1.5.x
    Replies: 15
    Last Post: 19 Apr 2016, 02:54 AM
  4. creating a backup that does not update when i update the live site
    By hereliesboots in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 20 Mar 2007, 05:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR