Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Problem upgrading from 1.5.4 to 1.5.5

    I have a live store at http://bookstore.arunachala.org which is based on version 1.5.4. I have two other bookstores which I upgraded from 1.5.1 and 1.5.4. But this one at the stage of zc_install does not recognize that my database needs upgrade. It says I have a current database and install will wipe out everything. The way I created the database as always is do a mysqldump of the old database and load it into a new one using mysql command. Normally this should come up with a zc-install upgrade database command but not this time. I have done this many times and can't see what I am doing wrong. Any suggestion would be helpful.

  2. #2
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    99% of the time it's because you used a non-empty DB_PREFIX on the "live" site, but on your "test" site you left it blank or used some other prefix, meaning all the tablenames it's looking at are a different set of data.

    That's why the instructions mention to make sure when you're setting up your temporary site that you look up the DB_PREFIX of the live site and use that same value when setting up the temporary testing/staging site.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    I do have db_prefix. I will check and fix that and report what is happening. Thanks a lot Sir

  4. #4
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    The test site and the live site both had no prefix. I added prefix to the test site's configure file and c_install started offering the database upgrade option. However it finds the superuser password incorrect even though it works fine on the live site. Stuck again. Any suggestions?

  5. #5
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Quote Originally Posted by Arunachala View Post
    I do have db_prefix. I will check and fix that and report what is happening. Thanks a lot Sir
    Quote Originally Posted by Arunachala View Post
    The test site and the live site both had no prefix. I added prefix to the test site's configure file and c_install started offering the database upgrade option. However it finds the superuser password incorrect even though it works fine on the live site. Stuck again. Any suggestions?
    This doesn't make sense. It does and it doesn't have a db_prefix value, then entering some "random" prefix into the test site resulted in an upgrade notice. To me this would indicate a need to review the database that is referenced in your test site's includes/configure.php to see what is present and how it relates to the database that is the live site. In working with both, use caution not to make changes (if any) to the wrong database, but the above doesn't make any sense...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  6. #6
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Clarification. Both live and test sites have database prefixes. I had left them both blank but zc_install didn't offer the upgrade option perhaps confusing it to be the latest version of database. After Dr. Byte's suggestion added prefix to configure file and upgrade option appeared. But it is not recognizing the valid super user admin password. The two databases are different created by mysqldump of live site. There is now way live site can be affected. Need to solve the admin password problem now for the upgrade to proceed

  7. #7
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Use this to address the password issue: http://www.zen-cart.com/content.php?44
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  8. #8
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Quote Originally Posted by mc12345678 View Post
    Use this to address the password issue: http://www.zen-cart.com/content.php?44
    Tried everything but can't go past zc_install error or can't validate admin credentials. Don't know what is causing this?

  9. #9
    Join Date
    Jan 2004
    Posts
    64,747
    Blog Entries
    6
    Plugin Contributions
    214

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Question: in the database, after you followed the FAQ article above to insert an admin user of "Admin", and the password hash was set to "351683ea4e19efe34874b501fdbf9792:9b", after you attempted to login as "Admin" with pwd of "admin", did the password in the database for that user stay the same, or did it change to something else starting with "$2y$10$" ?

    Also, what's the PHP version on the server?
    Who's the hosting company?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  10. #10
    Join Date
    Mar 2009
    Location
    New York
    Posts
    151
    Plugin Contributions
    0

    Default Re: Problem upgrading from 1.5.4 to 1.5.5

    Dear Drbyte The database associated with 1.5.4 version had a patch making it 1.5.5. That explains why the zc_install was not able to upgrade. Everything OK now. I have found a way to use the same database with updated files of 1.5.5

 

 

Similar Threads

  1. Collation problem upgrading from 1.3.8 to 1.3.9
    By artcoder in forum Upgrading from 1.3.x to 1.3.9
    Replies: 9
    Last Post: 10 Sep 2011, 05:17 PM
  2. Upgrading problem from 1.3.7 to 1.3.8
    By rtfulk in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 29 Oct 2009, 07:16 PM
  3. Replies: 3
    Last Post: 19 Jun 2008, 12:44 AM
  4. Problem upgrading from 1.3.0.2 to 1.3.6
    By Big Kahuna in forum Installing on a Linux/Unix Server
    Replies: 12
    Last Post: 6 Dec 2006, 09:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR