Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23
  1. #21
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Quote Originally Posted by GoldenNeedle View Post
    I looked at the page you put a link to, then looked at my logs for errors and this is what the file says:

    Code:
    [13-Sep-2017 08:54:31 America/Denver] Request URI: /, IP address: 199.117.220.171
    #1  trigger_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:167]
    #2  queryFactory->show_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:139]
    #3  queryFactory->set_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:266]
    #4  queryFactory->Execute() called at [/home2/goldenne/public_html/includes/functions/functions_lookups.php:29]
    #5  zen_get_countries() called at [/home2/goldenne/public_html/includes/functions/functions_lookups.php:62]
    #6  zen_get_country_name() called at [/home2/goldenne/public_html/includes/init_includes/init_header.php:71]
    #7  require(/home2/goldenne/public_html/includes/init_includes/init_header.php) called at [/home2/goldenne/public_html/includes/autoload_func.php:48]
    #8  require(/home2/goldenne/public_html/includes/autoload_func.php) called at [/home2/goldenne/public_html/includes/application_top.php:170]
    #9  require(/home2/goldenne/public_html/includes/application_top.php) called at [/home2/goldenne/public_html/index.php:26]
    
    [13-Sep-2017 08:54:31 America/Denver] PHP Fatal error:  1054:Unknown column 'status' in 'where clause' :: select countries_name, countries_iso_code_2, countries_iso_code_3
                        from znc_countries
                        where countries_id = '223' and status != 0  order by countries_name ==> (as called by) /home2/goldenne/public_html/includes/functions/functions_lookups.php on line 29 <== in /home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php on line 167
    I'm going to try to look in to these, but I'm not exactly sure where to start.
    The final "row" of data is where the problem is at. It would appear that the zc_install process (as provided by downloading the fileset from the main page of this site) was not performed. That field: status, was added in I think 1.5.2 (not released for production), but definitely in 1.5.3.

    If the zc_install database upgrade was performed on that database, then there should be some "install" logs in your logs directory. Those logs should contain information about what issues were identified and actions taken.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  2. #22
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    You're right mc12345678. I think after I did the first upgrade to the database, I had "restored" the database to a different time. Therefore causing the problem. So I just uploaded the zc_install folder again, and did the database upgrade, and it's all good! You have been such a wonderful help to me. You must have the patience of a saint. I'm thinking if I have any more problems, your response to me should be, "Just step away from the computer and no matter what, never touch the keyboard again!!" :)

  3. #23
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Quote Originally Posted by GoldenNeedle View Post
    You're right mc12345678. I think after I did the first upgrade to the database, I had "restored" the database to a different time. Therefore causing the problem. So I just uploaded the zc_install folder again, and did the database upgrade, and it's all good! You have been such a wonderful help to me. You must have the patience of a saint. I'm thinking if I have any more problems, your response to me should be, "Just step away from the computer and no matter what, never touch the keyboard again!!" :)
    :) Unfortunately if that were the normal response, there would be a lot of (or perhaps few?!) ZC operators sitting on their hands. :)

    Ideally you establish an independent copy of your site where you can (privately) make all the mistakes in the world but not impact your business. Then once the associated "non-user" errors are worked out, to bring your live site up to what you want in a single, successful operation because you have already learned from the previous mistakes. :) But, backup, backup, backup and don't be afraid to make a mistake because it can be restored from that BACKUP. :)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 6
    Last Post: 4 Dec 2013, 08:02 PM
  2. Can't log in to admin.
    By Kona Henna in forum General Questions
    Replies: 2
    Last Post: 1 Dec 2009, 02:32 AM
  3. Replies: 3
    Last Post: 4 Jun 2009, 06:40 PM
  4. Can't log in - can't add to cart - can't log in to admin?
    By ehdesign in forum General Questions
    Replies: 6
    Last Post: 5 Mar 2009, 09:29 AM
  5. Replies: 16
    Last Post: 31 Jan 2008, 06:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR