Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
  1. #11
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    I got it!! It works now. Before doing the zen cart 1.5.5e upgrade again, I went in to cpanel, then PHP config (which is under "Programming"), my php was actually set at 5.6. So I chose 5.4 instead, then saved it. I then copied all the zen cart 1.5.5e files to my site, then went to www.mywebsite.com/zc_install/index.php and chose to do the upgrade. Of course, once again, it wouldn't accept my admin credentials, so I deleted the "zc_install" folder from my site (using cpanel), deleted the "index.html" file and the "index.txt" file. I did the admin passord reset using myphp from cpanel and the code:
    DELETE FROM admin WHERE admin_name = 'Admin';
    INSERT INTO admin (admin_name, admin_email, admin_pass, admin_profile)
    VALUES ('Admin', 'admin@localhost', '351683ea4e19efe34874b501fdbf9792:9b', 1);

    This sets the user name to: Admin and password to: admin . Then I went to my admin login page on my site and was actually able to log in! I reset my admin password, and logged out. When I was in the admin section of my website, there was a warning that I should update my php to 5.5 or newer. So I went in to Cpanel, then under Programming, to PHP Config and chose 5.6 again.


    Then I uploaded the folder "zc_install" and files "index.html" and "index.txt" to my website again. I went to the install page again, "www.mywebsite.com/zc_install" and selected upgrade. Everything went fine and I was able to use my new password no problem.

    I then deleted the folders: zc_install, /docs, /extras and the following files: README.md, index.html, index.txt, and install.txt. I deleted these using Cpanel's File Manager. I had tried deleting them with ftp transfer software, but that didn't work on some of them.

    I hope this can help someone else that may have had the problems I did...like not being able use my admin credentials, and previously, a blank homepage (because I didn't get rid of the index.html at first.)

  2. #12
    Join Date
    Jul 2012
    Posts
    11,622
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Congrats!

    There is one thing that somewhat stands out that I would have suggested to do differently would have been to not attempt to login to the admin of the upgraded files before the database had also been upgraded. While it worked ok in this instance, it has been known to also cause problems with future attempts to do the upgrade/provide "matching" credentials.

    You were, however, able to work through that issue by the above process which likely will help someone if they come across this in their search/navigation.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  3. #13
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    Now a new problem...
    I have an account set up as a customer, and I can't log in as a customer.

  4. #14
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    Also, it looks like part of the customer login page is missing. It doesn't have a section to create a new account, only a place to provide billing information, then, no button to submit it.

  5. #15
    Join Date
    Jul 2012
    Posts
    11,622
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Quote Originally Posted by GoldenNeedle View Post
    Also, it looks like part of the customer login page is missing. It doesn't have a section to create a new account, only a place to provide billing information, then, no button to submit it.
    Sounds like suffering from a blank page or partial blank page: http://www.zen-cart.com/content.php?124-blank-page
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  6. #16
    Join Date
    Jul 2012
    Posts
    11,622
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Quote Originally Posted by GoldenNeedle View Post
    Now a new problem...
    I have an account set up as a customer, and I can't log in as a customer.
    ZC 1.5.5 offers the ability to reset the customer's password, suggest attempting that. Did you previously have some sort of admin logs in as customer plugins? If so which? It is possible that the password generated may without that additional code may not match the password generated/converted under the new system.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  7. #17
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    I'll try resetting the password in admin. I don't have any special plugin to log in as a customer, just created a customer account a long time ago with a different email address I had, so I could test the site as a customer. Also, there's a warning on the log in page that says, "WARNING: An Error occurred, please refresh the page and try again."

  8. #18
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    By the way...I really appreciate the help!!

  9. #19
    Join Date
    Jul 2012
    Posts
    11,622
    Plugin Contributions
    13

    Default Re: Can't Log in to Admin

    Quote Originally Posted by GoldenNeedle View Post
    I'll try resetting the password in admin. I don't have any special plugin to log in as a customer, just created a customer account a long time ago with a different email address I had, so I could test the site as a customer. Also, there's a warning on the log in page that says, "WARNING: An Error occurred, please refresh the page and try again."
    Similar actions as blank/partial blank, but here's the associated FAQ: https://www.zen-cart.com/content.php...-and-try-again

    No problem, everyone has had to have a start at some point. In an upgrade, it's kind of a restart, but... :)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  10. #20
    Join Date
    Sep 2017
    Location
    Colorado
    Posts
    12
    Plugin Contributions
    0

    Default Re: Can't Log in to Admin

    I looked at the page you put a link to, then looked at my logs for errors and this is what the file says:

    Code:
    [13-Sep-2017 08:54:31 America/Denver] Request URI: /, IP address: 199.117.220.171
    #1  trigger_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:167]
    #2  queryFactory->show_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:139]
    #3  queryFactory->set_error() called at [/home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php:266]
    #4  queryFactory->Execute() called at [/home2/goldenne/public_html/includes/functions/functions_lookups.php:29]
    #5  zen_get_countries() called at [/home2/goldenne/public_html/includes/functions/functions_lookups.php:62]
    #6  zen_get_country_name() called at [/home2/goldenne/public_html/includes/init_includes/init_header.php:71]
    #7  require(/home2/goldenne/public_html/includes/init_includes/init_header.php) called at [/home2/goldenne/public_html/includes/autoload_func.php:48]
    #8  require(/home2/goldenne/public_html/includes/autoload_func.php) called at [/home2/goldenne/public_html/includes/application_top.php:170]
    #9  require(/home2/goldenne/public_html/includes/application_top.php) called at [/home2/goldenne/public_html/index.php:26]
    
    [13-Sep-2017 08:54:31 America/Denver] PHP Fatal error:  1054:Unknown column 'status' in 'where clause' :: select countries_name, countries_iso_code_2, countries_iso_code_3
                        from znc_countries
                        where countries_id = '223' and status != 0  order by countries_name ==> (as called by) /home2/goldenne/public_html/includes/functions/functions_lookups.php on line 29 <== in /home2/goldenne/public_html/includes/classes/db/mysql/query_factory.php on line 167
    I'm going to try to look in to these, but I'm not exactly sure where to start.

 

 
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Replies: 6
    Last Post: 4 Dec 2013, 08:02 PM
  2. Can't log in to admin.
    By Kona Henna in forum General Questions
    Replies: 2
    Last Post: 1 Dec 2009, 02:32 AM
  3. Replies: 3
    Last Post: 4 Jun 2009, 06:40 PM
  4. Can't log in - can't add to cart - can't log in to admin?
    By ehdesign in forum General Questions
    Replies: 6
    Last Post: 5 Mar 2009, 09:29 AM
  5. Replies: 16
    Last Post: 31 Jan 2008, 06:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR