We have a new ZenCart site angliapipetools.co.uk on which we are currently testing the plugin UK Postcode Shipping module by Zenned with the SagePay Form payments module running in test mode

ZenCart version 1.5.5 running on Apache server under PHP ver. 5.6.31 and MySQL ver.5.5.5
Hosted by UK2.net

I have read all the information I could find about Tax / VAT problems before posting here.

The Problem
When buying a product the net price of the product plus the shipping charge are passed through to the checkout but no VAT is added.
This did happen when we first installed the UK Postcode Shipping module but was fixed by changing the Tax Basis to store instead of shipping in the shipping module.
We also had the checkout working OK previously with SagePay and the built in Table Rate shipping module and we have not changed any VAT/Tax settings since then.

Since installing the UK Postcode shipping module we have been putting in rates for each of the 4 zones and now the module works out the correct shipping charge according to weight and postcode but now there is no VAT being added in checkout.

I have tried all combinations of settings for Tax Basis between shipping, billing and store but it made no difference.

In Admin I checked all the Locations/Taxes zones, tax classes, tax rates and the settings in My Store Basis of Product Tax and Basis of Shipping Tax and the store Status is set to 0=Normal Store
Admin-->Configuration-->Stock "Allow Checkout" =True

The only other thing that I know about which might have a bearing is that UK2.net changed the PHP on their server to PHP ver7 this week and we are running 5.6 This caused some things not to work so they have changed our settings to use 5.6 again (we will have to address this later as the temporary ability to use an earlier than Ver.7 will be removed on the 15th October)

I have tried disabling the UK Postcode shipping module and enabling the Table Rate module again to try and isolate the problem to the UK Postcode shipping module but it did exactly the same with that one as well.

I have read as many posts and FAQs on the subject including about setting up zones and tax classes but I can not find anything wrong with our settings.
In case there is a problem with zones / locations / taxes these are the settings (which worked with Table Rates module previously)
My Store
Country United Kingdom
Zone UK Mainland
Basis of Product Tax Store
Basis of Shipping Tax Store
Display Prices with Tax False (add tax at the end)
Display Prices with Tax Admin False (add tax at the end)
Tax Rates
Priority 0 Tax Class "Taxable Goods" Zone "UK VAT" Tax Rate "20%" Description "Standard VAT Rate"
Zone Definitions
Zone Name : "UK VAT"
Description : "United Kingdom VAT Zone"
Definitions : details "UK Mainland"
"UK Highlands"
"Northern Ireland"
Status = Green

After reviewing all this to try and get the VAT working I don't think we will need the 3 zones we have set up as we are only using the "UK Mainland" one and the UK Postcode shipping module handles the different shipping charges according to customer's postcode area.
Although it did work before and ought to work now I am happy to start again with just one zone and tax class of taxable goods if that will fix the problem.