Page 48 of 48 FirstFirst ... 38464748
Results 471 to 478 of 478
  1. #471
    Join Date
    Jul 2020
    Location
    USA
    Posts
    68
    Plugin Contributions
    0

    Default Re: Some large images not resizing

    Quote Originally Posted by rlexyd View Post
    Hey Fuzztrip, I like the social media share green button on your site :)
    Did someone customize that for you or is it from some plugin on Zen Cart?
    Thanks.
    You can get it here: https://www.addthis.com

  2. #472
    Join Date
    Nov 2006
    Location
    Sydney, Australia
    Posts
    453
    Plugin Contributions
    1

    Default Re: Some large images not resizing

    Thanks, appreciate that.

  3. #473
    Join Date
    Jul 2020
    Location
    USA
    Posts
    68
    Plugin Contributions
    0

    Default Re: Some large images not resizing

    Quote Originally Posted by Fuzztrip View Post
    157c
    fuzztrip.com

    Using Chrome/Microsoft Edge/IE:

    If you go to https://fuzztrip.com/lp-c-1/vesta-od...ear-p-139.html and click on the extra image it opens and resizes according to the settings I have in config-images- IH large images maximum width 750, IH large images maximum height 550, although it aligns left in Chrome. This image was already in place before installing IH5. The same is true with other images added before IH5 installation.

    But if you go to https://fuzztrip.com/box-set-c-9/sul...nyl-p-241.html the images do not resize, but display at full size. These images were uploaded after IH5 installation.

    Using Firefox:

    The same images render as above, the first link resized to the proper dimensions, the second does not resize. But they also have the added issue of loading into a tiny box with scrollbars that has to be resized to view.

    I have uninstalled and reinstalled IH5, each file one by one, but no luck. I have also deleted and re-created the product listing https://fuzztrip.com/box-set-c-9/sul...nyl-p-241.html in a different category but no change.

    Thanks for any help!
    I never was able to figure this out, and the problem remains. I have learned that this is only happening to jpeg files. Most of my older images are in png and they are resizing the way they should. I have been slowly transferring over to jpeg to reduce file size and they seem to be the only images not resizing.

    When I look at them in admin/tools/image handler, they are all the same size and there is a medium image that does not exist with any of the png images

    Name:  Screenshot 2021-09-03 114806.jpg
Views: 40
Size:  47.8 KB

    The above page is here https://fuzztrip.com/box-set-c-9/sul...54e77ff8099e25

  4. #474
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,637
    Plugin Contributions
    78

    Default Re: Some large images not resizing

    Quote Originally Posted by Fuzztrip View Post
    I never was able to figure this out, and the problem remains. I have learned that this is only happening to jpeg files. Most of my older images are in png and they are resizing the way they should. I have been slowly transferring over to jpeg to reduce file size and they seem to be the only images not resizing.

    When I look at them in admin/tools/image handler, they are all the same size and there is a medium image that does not exist with any of the png images

    Name:  Screenshot 2021-09-03 114806.jpg
Views: 40
Size:  47.8 KB

    The above page is here https://fuzztrip.com/box-set-c-9/sul...54e77ff8099e25
    I'm unable to reproduce your issue on a test site running zc157c with the built-in responsive_classic template.

    You can try a couple of things to gather some additional information. First, navigate to the product page that's not displaying correctly and:

    1. Ensure that debug-logging is enabled on the storefront. Go to Configuration :: Logging and set Report All Errors (Storefront) to IgnoreDups and Backtrace on notices to true.

    2. Edit /includes/classes/bmz_image_handler_class.php, changing the definition for IH_DEBUG_STOREFRONT from 'false' to 'true' (yes, those single-quotes are necessary). That'll create a file /logs/ih_debug-yyyyddmm-hhmmss.log for each and every storefront pageload.

    3. Refresh the product-information page, then undo the edit made in the previous step.

    4. Check the /logs directory. Are there any myDEBUG*.log files generated on/around the time of the refresh? If so, post the contents.

    5. Zip-up (it might be a large file) the ih_debug*.log file generated and post that back, too.

    Edit: Are you sure that IH is enabled? Check Configuration :: Images :: IH Resize Images, it should be set to yes.

  5. #475
    Join Date
    Jul 2012
    Posts
    16,043
    Plugin Contributions
    17

    Default Re: Some large images not resizing

    Quote Originally Posted by Fuzztrip View Post
    157c
    fuzztrip.com

    Using Chrome/Microsoft Edge/IE:

    If you go to https://fuzztrip.com/lp-c-1/vesta-od...ear-p-139.html and click on the extra image it opens and resizes according to the settings I have in config-images- IH large images maximum width 750, IH large images maximum height 550, although it aligns left in Chrome. This image was already in place before installing IH5. The same is true with other images added before IH5 installation.

    But if you go to https://fuzztrip.com/box-set-c-9/sul...nyl-p-241.html the images do not resize, but display at full size. These images were uploaded after IH5 installation.

    Using Firefox:

    The same images render as above, the first link resized to the proper dimensions, the second does not resize. But they also have the added issue of loading into a tiny box with scrollbars that has to be resized to view.

    I have uninstalled and reinstalled IH5, each file one by one, but no luck. I have also deleted and re-created the product listing https://fuzztrip.com/box-set-c-9/sul...nyl-p-241.html in a different category but no change.

    Thanks for any help!
    Quote Originally Posted by lat9 View Post
    I'm unable to reproduce your issue on a test site running zc157c with the built-in responsive_classic template.

    You can try a couple of things to gather some additional information. First, navigate to the product page that's not displaying correctly and:

    1. Ensure that debug-logging is enabled on the storefront. Go to Configuration :: Logging and set Report All Errors (Storefront) to IgnoreDups and Backtrace on notices to true.

    2. Edit /includes/classes/bmz_image_handler_class.php, changing the definition for IH_DEBUG_STOREFRONT from 'false' to 'true' (yes, those single-quotes are necessary). That'll create a file /logs/ih_debug-yyyyddmm-hhmmss.log for each and every storefront pageload.

    3. Refresh the product-information page, then undo the edit made in the previous step.

    4. Check the /logs directory. Are there any myDEBUG*.log files generated on/around the time of the refresh? If so, post the contents.

    5. Zip-up (it might be a large file) the ih_debug*.log file generated and post that back, too.

    Edit: Are you sure that IH is enabled? Check Configuration :: Images :: IH Resize Images, it should be set to yes.
    While I can't speak to all aspects of the above post, the firefox issue is reproducible as posted elsewhere in the forum. The following post may correct the above described issue at least from the popped up window original sizing issue:
    https://www.zen-cart.com/showthread....33#post1375133
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  6. #476
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,637
    Plugin Contributions
    78

    Default Re: Some large images not resizing

    Thanks for that, @mc12345678!

  7. #477
    Join Date
    Jul 2020
    Location
    USA
    Posts
    68
    Plugin Contributions
    0

    Default Re: Some large images not resizing

    Quote Originally Posted by lat9 View Post
    I'm unable to reproduce your issue on a test site running zc157c with the built-in responsive_classic template.

    You can try a couple of things to gather some additional information. First, navigate to the product page that's not displaying correctly and:

    1. Ensure that debug-logging is enabled on the storefront. Go to Configuration :: Logging and set Report All Errors (Storefront) to IgnoreDups and Backtrace on notices to true.

    2. Edit /includes/classes/bmz_image_handler_class.php, changing the definition for IH_DEBUG_STOREFRONT from 'false' to 'true' (yes, those single-quotes are necessary). That'll create a file /logs/ih_debug-yyyyddmm-hhmmss.log for each and every storefront pageload.

    3. Refresh the product-information page, then undo the edit made in the previous step.

    4. Check the /logs directory. Are there any myDEBUG*.log files generated on/around the time of the refresh? If so, post the contents.

    5. Zip-up (it might be a large file) the ih_debug*.log file generated and post that back, too.

    Edit: Are you sure that IH is enabled? Check Configuration :: Images :: IH Resize Images, it should be set to yes.

    Thank you for all the assistance, it turns out the image files are corrupt. They are jpegs but image editors are trying to open them as gifs. I took new ones and uploaded them and it works as it should.

  8. #478
    Join Date
    Jul 2020
    Location
    USA
    Posts
    68
    Plugin Contributions
    0

    Default Re: Some large images not resizing

    Quote Originally Posted by mc12345678 View Post
    While I can't speak to all aspects of the above post, the firefox issue is reproducible as posted elsewhere in the forum. The following post may correct the above described issue at least from the popped up window original sizing issue:
    https://www.zen-cart.com/showthread....33#post1375133
    Thank you!

 

 
Page 48 of 48 FirstFirst ... 38464748

Similar Threads

  1. v150 Image Handler 4 (for v1.5.x) Support Thread
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 1681
    Last Post: 5 Feb 2021, 12:59 PM
  2. Attribute image replaces main product image on select [Support Thread]
    By exoticcorpse in forum All Other Contributions/Addons
    Replies: 158
    Last Post: 24 Aug 2020, 05:07 PM
  3. v139h Image Handler 3 Support Thread (for ZC v1.3.9)
    By DivaVocals in forum All Other Contributions/Addons
    Replies: 1095
    Last Post: 2 Oct 2017, 12:42 PM
  4. v138a Image Handler 2 (for ZC v1.3.8 ONLY) Support
    By timkroeger in forum All Other Contributions/Addons
    Replies: 7098
    Last Post: 12 Oct 2014, 03:48 AM
  5. Image Handler Support Please
    By nadinesky in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 30 Sep 2013, 03:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR