Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2004
    Location
    Newport, Wales
    Posts
    244
    Plugin Contributions
    0

    Default Upgrading 1.5.5 to 1.5.5 new files old database

    Hi
    I am about to embark on upgrading from 1.5.1 to 1.5.5.

    I have created a test environment where I have uploaded all the new 1.5.5 cart files (the idea is to use the new files rather than the existing ones and then add any plugins I require afterwards.) and made a clone of the old database.

    So new set of files but old database.

    The problem I have is trying to upgrade the old database as part of the zc_install process.

    I read the instructions about upgrading the Db which seems to require an old version of the config files to activate this route. (Maybe wrong) So I copied my old config files over to the new file set which brought up the Old config files need updating screen but clicking update doesn't take me anywhere.

    Any idea where I am going wrong?

  2. #2
    Join Date
    Jan 2004
    Posts
    64,748
    Blog Entries
    6
    Plugin Contributions
    74

    Default Re: Upgrading 1.5.5 to 1.5.5 new files old database

    http://www.zen-cart.com/entry.php?3-...d-of-upgrading

    The old config files are for the old site only.

    The new config files created when you ran zc_install to create the new temporary/test site, are the ones you want to use for that temporary/test site.

    You said you imported the old database. Good.
    Next step is to point your browser back to zc_install again, and follow the prompts: it will recognize the old database, and ask you to confirm that you wish to upgrade it.


    If it doesn't recognize the need to upgrade the database, then you've got your DB_PREFIX wrong. In the upgrade instructions it tells you to lookup your DB_PREFIX from the old configure.php files and be sure to use the same DB_PREFIX when setting up the new site. If you didn't do that, simply edit both of your new configure.php files and put the correct DB_PREFIX in them, and then go back to the zc_install step to upgrade the database.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Aug 2004
    Location
    Newport, Wales
    Posts
    244
    Plugin Contributions
    0

    Default Re: Upgrading 1.5.5 to 1.5.5 new files old database

    Thanks Doc

    Figured it was going to be something like that.

    Much appreciated.

 

 

Similar Threads

  1. Replies: 1
    Last Post: 9 Jan 2015, 05:57 AM
  2. Error importing old database to the new database
    By wmorris in forum Upgrading to 1.5.x
    Replies: 1
    Last Post: 3 Jan 2012, 08:27 AM
  3. Database - add new customers from old database
    By ljdream00 in forum General Questions
    Replies: 0
    Last Post: 6 Apr 2011, 05:43 AM
  4. Replies: 4
    Last Post: 15 Oct 2010, 07:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR