Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Oct 2007
    Location
    New Zealand
    Posts
    22
    Plugin Contributions
    1

    Default my site suddenly stopped working - need help please

    Hi, I really do hope someone can help. My zencart has been running for 9 years and just yesterday it stopped working. The site is hosted in godaddy. When I load the site, all I see is this "Hello. Thank you for loading Zen Cart™." page. Name:  error.jpg
Views: 49
Size:  78.7 KB

    I contacted godaddy, they checked the php and upgraded it from 5.0 to 5.6. This did not fix anything.

    Is there a way to repair an install or troubleshoot to try to identify the error?

    The website is: mlfencing.com , I made a temporary "under maintenance" page. The real site with the error is: http://www.mlfencing.com/index_bk.php

    Now where do I start to troubleshoot? My sql database seem to be ok and i can access it from phpmyadmin.

    Hope anyone can help! much appreciated in advance!!!!!

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: my zencart site suddenly stopped working - need help please

    The issue at hand is that your oldy-moldy version of Zen Cart (1.3.8a) which is coming up on its 10th birthday (released on December 11, 2007) is not compatible with any version of PHP later than 5.3.

    Specifically, the PHP function magic_quotes_runtime is no longer included in any PHP distribution, see this PHP documentation for more details. Most webhosts provide a cPanel tool to control the PHP version, but I've not seen a host that provides this service for PHP versions prior to 5.4.0.

    The site is going to need an Zen Cart upgrade (to 1.5.5e, currently) to get back in business.

  3. #3
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    6,343
    Plugin Contributions
    8

    Default Re: my zencart site suddenly stopped working - need help please

    First of all, any Zen Cart from 9 years ago might not work with PHP 5.6. That was before 1.5.# which means your site was probably not compatible with PHP5.6. MAYBE PHP 5.3 but probably 5.2.

    Since you can access the database, what does the project_version table have in the project_version_minor column?

  4. #4
    Join Date
    Oct 2007
    Location
    New Zealand
    Posts
    22
    Plugin Contributions
    1

    Default Re: my zencart site suddenly stopped working - need help please

    Hi all, first of all thanks for your replies!! It took me many hours, the first issue was that GoDaddy somehow changed their server path without warning (e.g. /home/content/XXX/XXXX/html/) this caused problem with the configuration files. The "Hello, thank you for loading Zencart" box is now gone, but all I see is a blank page on the front end of the website. I can access the admin area now.

    Second issue was that GoDaddy support upgraded the php to 5.6, and now I can't seem to revert back to the older php, only back to pho5.4. The blank issue seems like a compatibility with the older v1.3.8 zencart with newer php versions.... bump...

    Now, would you recommend that I upgrade to a newer zencart? v1.3.9 perhaps? can it be done safely? or can I upgrade to v1.5 ??

    Hope to get some help on this, much appreciate your support again!!!

  5. #5
    Join Date
    Jul 2012
    Posts
    11,632
    Plugin Contributions
    13

    Default Re: my zencart site suddenly stopped working - need help please

    You can upgrade directly to 1.5.5. The publicly recommended reading to this is: http://www.zen-cart.com/entry.php?3-...d-of-upgrading

    Backup everything before beginning. Then back up that and tuck it away in case something goes wrong.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  6. #6
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: my zencart site suddenly stopped working - need help please

    Quote Originally Posted by mc12345678 View Post
    You can upgrade directly to 1.5.5. The publicly recommended reading to this is: http://www.zen-cart.com/entry.php?3-...d-of-upgrading

    Backup everything before beginning. Then back up that and tuck it away in case something goes wrong.
    I humbly disagree with the highlighted statement, unless the site was very uncustomized at the Zen Cart 1.3.8a level (i.e. no plugins installed).

    The admin-side has gone through two very major changes (1.3.9->1.5.0 and 1.5.4->1.5.5) so any upgrade from 1.3.8a to 1.5.5e is going to require some real inspection.

  7. #7
    Join Date
    Jul 2012
    Posts
    11,632
    Plugin Contributions
    13

    Default Re: my zencart site suddenly stopped working - need help please

    Quote Originally Posted by lat9 View Post
    I humbly disagree with the highlighted statement, unless the site was very uncustomized at the Zen Cart 1.3.8a level (i.e. no plugins installed).

    The admin-side has gone through two very major changes (1.3.9->1.5.0 and 1.5.4->1.5.5) so any upgrade from 1.3.8a to 1.5.5e is going to require some real inspection.
    The level of customization has little to nothing to do with maintaining the data that has been collected which is the heart of the store and the ability to restore operation at some level. Beyond that, to restore the look (which in a way is effectively lost considering the level of php necessary to regain operation although there are those that have low versions of PHP available on their "personal computer" so that it would be possible to see what the site looked like before this issue) will certainly require more than just an installation/reinstallation.

    I would say though the question really is how important is the operation of the site? The longer the outage (more steps taken to get from where it was to where it is) to "get it just right" the less operation it does and the more that outage costs. To restore operation first and then revisit the look, well less to lose.

    It's out already. It can be built and in operation in the time it takes to upload the files of a vanilla install. Anything that was modified before can then either be added back in (if considered necessary) preferably with a development version of the site to test the changes before applying to the live site. Customers can be notified of the temporary look as the store is undergoing some much needed updates with normal operation returning soon or some other message. But at least it would be in operation.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  8. #8
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: my zencart site suddenly stopped working - need help please

    Depends on the customizations; if the site's got some required additions (like payment and/or shipping and/or order-total methods) then simply upgrading the database to the latest level and using the default Zen Cart code isn't going to get the site "back in business".

  9. #9
    Join Date
    Oct 2007
    Location
    New Zealand
    Posts
    22
    Plugin Contributions
    1

    Default Re: my zencart site suddenly stopped working - need help please

    Ok, now I thought I have successfully upgraded to v1.5.5e, but when I tested the 'checkout' page, it throws a blank page. The same with 'log-in', what could have caused this? i am at the end of my wit, spent all day trying to figure out a way to fix this.

    The issue can be seen here when you click on log-in or try to checkout with an item in the cart: http://mlfencing.com/zencart139/

    Hope you can help!! big thanks!!

  10. #10
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: my zencart site suddenly stopped working - need help please

    Quote Originally Posted by cmku View Post
    Ok, now I thought I have successfully upgraded to v1.5.5e, but when I tested the 'checkout' page, it throws a blank page. The same with 'log-in', what could have caused this? i am at the end of my wit, spent all day trying to figure out a way to fix this.

    The issue can be seen here when you click on log-in or try to checkout with an item in the cart: http://mlfencing.com/zencart139/

    Hope you can help!! big thanks!!
    See this Zen Cart FAQ regarding blank pages (also known as whitescreens): https://www.zen-cart.com/content.php...art-of-a-page)

    Essentially, you need to look in your store's /logs directory to find the most recent myDEBUG-*.log file. That file will identify the cause of the whitescreen.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. v139h HELP! USPS API suddenly stopped working after 7 years!
    By millersgrainhouse in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 6 May 2014, 03:40 PM
  2. Replies: 26
    Last Post: 17 Mar 2013, 03:41 PM
  3. HELP! Suddenly our sales tax has stopped working, all gross prices are now the same!
    By nathanscrivener in forum Currencies & Sales Taxes, VAT, GST, etc.
    Replies: 1
    Last Post: 9 Nov 2010, 08:23 AM
  4. suddenly all of the subpages of my site stopped working....
    By kaylala in forum General Questions
    Replies: 3
    Last Post: 2 Jun 2010, 01:08 AM
  5. Old site suddenly stopped working
    By Leowald in forum General Questions
    Replies: 2
    Last Post: 8 Jan 2007, 03:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR