Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34
  1. #1
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Blank site after installing using Plesk control panel

    http://joburgonline.com

    Changed hosts and moving the site.

    ZC154
    PHP5.6.1

    My first install of ZC was in 2005, and have only ever done our site. With my new host, I have been battling for 2 days.

    The install tutorial mentions to use directory:

    Basically, in your FTP area look for a "www" or "public_html" or "htdocs" or "httpdocs" or "wwwroot" folder.
    Done:

    I found settings in Plesk

    Document root directory - point to /httpdocs in /Websites & Domains/Hosting settings

    FTP

    all files to /httpdocs - all present

    MySQL

    Created DB via control panel

    Manually associated the SQL DB to "MY_DOMAIN_NAME"; and pointed to the localhost:3306 via ZC setup with related values and passwords.

    checked DB table with PHPMyAdmin - all tables present as populated by ZC

    Install

    All steps followed.

    I still have a blank website

  2. #2
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    Another setting that I made was to point to index.php as the default in the control panel is index.html

  3. #3
    Join Date
    Dec 2009
    Location
    Amersfoort, The Netherlands
    Posts
    2,284
    Plugin Contributions
    20

    Default Re: Blank site after installing using Plesk control panel

    A white page usually creates a debug file. Did you check the logs folder?

  4. #4
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    Quote Originally Posted by Design75 View Post
    A white page usually creates a debug file. Did you check the logs folder?
    Here's the first:

    [Sat Nov 18 22:43:08 2017] [error] [client 45.30.255.204] Directory index forbidden by Options directive: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/
    [Sat Nov 18 22:48:04 2017] [error] [client 66.249.79.131] Directory index forbidden by Options directive: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/
    [Sat Nov 18 22:49:17 2017] [error] [client 207.46.13.28] Directory index forbidden by Options directive: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/
    [Sat Nov 18 22:50:27 2017] [error] [client 157.55.39.239] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache
    [Sat Nov 18 23:05:48 2017] [error] [client 84.201.133.25] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/robots.txt
    [Sat Nov 18 23:05:52 2017] [error] [client 84.201.133.25] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/ems2312_02.jpg
    [Sat Nov 18 23:12:38 2017] [error] [client 98.124.251.176] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/filenames.php
    [Sat Nov 18 23:14:10 2017] [error] [client 90.64.50.229] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/ibp9120.jpg, referer: https://www.google.sk/
    [Sat Nov 18 23:14:47 2017] [error] [client 98.124.251.176] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/filenames.php
    [Sat Nov 18 23:20:46 2017] [error] [client 219.93.43.34] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/96ex988.jpg, referer: https://www.google.com/
    [Sat Nov 18 23:31:40 2017] [error] [client 207.46.13.190] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache
    [Sat Nov 18 23:38:25 2017] [error] [client 50.109.136.137] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/robots.txt
    [Sat Nov 18 23:50:04 2017] [error] [client 58.182.40.18] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/inn2150.jpg, referer: https://www.google.com.sg/
    [Sat Nov 18 23:53:42 2017] [error] [client 73.158.238.160] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/fta2600.jpg, referer: https://www.google.com/
    [Sun Nov 19 00:10:10 2017] [error] [client 157.55.39.239] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/banners/tourist.jpg
    [Sun Nov 19 00:26:57 2017] [error] [client 66.249.79.131] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/templates/winchester_responsive, referer: http://joburgonline.com/index.php?ma...ath=43_288_558
    [Sun Nov 19 00:26:57 2017] [error] [client 66.249.79.133] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/templates/winchester_responsive, referer: http://joburgonline.com/index.php?ma...ath=43_288_558
    [Sun Nov 19 00:31:33 2017] [error] [client 207.46.13.190] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache
    [Sun Nov 19 00:39:23 2017] [error] [client 66.249.79.131] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/templates/winchester_responsive, referer: http://joburgonline.com/index.php?ma...oducts_id=4462
    [Sun Nov 19 00:53:34 2017] [error] [client 207.46.13.190] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache
    [Sun Nov 19 00:57:11 2017] [error] [client 66.249.79.129] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/includes/templates/winchester_responsive, referer: http://www.joburgonline.com/
    [Sun Nov 19 00:58:05 2017] [error] [client 216.244.66.245] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/robots.txt
    [Sun Nov 19 00:59:22 2017] [error] [client 220.181.108.179] client denied by server configuration: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/images/restaurant, referer: http://image.##########.com/i?ct=503...###imagedetail
    [Sun Nov 19 01:08:23 2017] [error] [client 77.75.78.163] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/robots.txt
    [Sun Nov 19 01:10:36 2017] [error] [client 91.200.12.196] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/wp-content, referer: http://joburgonline.com/wp-content/p...vslider/db.php
    [Sun Nov 19 01:13:59 2017] [error] [client 207.46.13.190] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache
    [Sun Nov 19 01:33:59 2017] [error] [client 207.46.13.28] File does not exist: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/bmz_cache

  5. #5
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    2nd - debug from httpdocs/logs/

    [19-Nov-2017 07:20:50 UTC] PHP Warning: date_default_timezone_get(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/zc_install/includes/application_top.php on line 59

  6. #6
    Join Date
    Jul 2012
    Posts
    11,627
    Plugin Contributions
    13

    Default Re: Blank site after installing using Plesk control panel

    This might help with the more recent timezone issue, but there may still be a bigger issue.

    https://www.zen-cart.com/showthread....HP-5-3-5-4-5-5

    Specifically look at the second post in that thread as it should relate more to your configuration as of ZC 1.5.2 and above.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  7. #7
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    Quote Originally Posted by mc12345678 View Post
    This might help with the more recent timezone issue, but there may still be a bigger issue.

    https://www.zen-cart.com/showthread....HP-5-3-5-4-5-5

    Specifically look at the second post in that thread as it should relate more to your configuration as of ZC 1.5.2 and above.

    I am having another go at the a fresh install, and will try that. If I get stuck, I'll let you know.

    Thanks

  8. #8
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    Quote Originally Posted by mc12345678 View Post
    This might help with the more recent timezone issue, but there may still be a bigger issue.

    https://www.zen-cart.com/showthread....HP-5-3-5-4-5-5

    Specifically look at the second post in that thread as it should relate more to your configuration as of ZC 1.5.2 and above.
    Here we have a small issue. My timezone is Africa/Johannesburg, but my host is in North America - could be Canada?

  9. #9
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    957
    Plugin Contributions
    1

    Default Re: Blank site after installing using Plesk control panel

    this really looks like a permissions issue:

    Directory index forbidden by Options directive: /var/www/vhosts/joburlnx.ehost-services221.com/httpdocs/

    if the user running apache can not view the files inside of this directory, ZC can not run.

    not sure how re-installing would change that. especially if doing the same process from the same automated installer.

    generally your hosting company can help with permissions issues.

    best.
    feel free to donate money to carl or to the Zen-Cart Team

  10. #10
    Join Date
    Jul 2005
    Location
    Hoedspruit
    Posts
    516
    Plugin Contributions
    2

    Default Re: Blank site after installing using Plesk control panel

    SO - fresh install done, edited the file to include my local time zone, with the store country set as South Africa, and Zone set as None, both in the Zen installation procedure ie manual install

    We still have this issue: http://joburgonline.com


    Quote Originally Posted by Parafanaylya View Post
    Here we have a small issue. My timezone is Africa/Johannesburg, but my host is in North America - could be Canada?
    Quote Originally Posted by mc12345678 View Post
    This might help with the more recent timezone issue, but there may still be a bigger issue.

    https://www.zen-cart.com/showthread....HP-5-3-5-4-5-5

    Specifically look at the second post in that thread as it should relate more to your configuration as of ZC 1.5.2 and above.

 

 
Page 1 of 4 123 ... LastLast

Similar Threads

  1. admin panel blank after installing addon
    By loaner in forum All Other Contributions/Addons
    Replies: 1
    Last Post: 19 Aug 2011, 09:08 PM
  2. Accessing Old Control Panel After Moving Site
    By sirluck in forum General Questions
    Replies: 2
    Last Post: 14 Apr 2009, 11:41 PM
  3. Replies: 2
    Last Post: 2 Feb 2008, 07:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR