Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2015
    Posts
    107
    Plugin Contributions
    0

    Default Unsupported operand

    I get this error on the checkout_new_address.php. I am not sure what is causing this.

    [27-Nov-2017 01:31:21 America/New_York] PHP Fatal error: Unsupported operand types in /home/inverter/public_html/includes/modules/checkout_new_address.php on line 140


    The last change I made before it was working correctly was post
    https://www.zen-cart.com/showthread....i-get-an-error

    Just FYI error occurs when I need to add an address and save it.
    Last edited by chadlly2003; 27 Nov 2017 at 07:23 PM.

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,978
    Plugin Contributions
    63

    Default Re: Unsupported operand

    Here's what I've got for the Zen Cart 1.5.4 version of the file; line 140 is highlighted.

    Code:
        if ($error == false) {
          $sql_data_array = array(array('fieldName'=>'customers_id', 'value'=>$_SESSION['customer_id'], 'type'=>'integer'),
                                  array('fieldName'=>'entry_firstname', 'value'=>$firstname, 'type'=>'string'),
                                  array('fieldName'=>'entry_lastname','value'=>$lastname, 'type'=>'string'),
                                  array('fieldName'=>'entry_street_address','value'=>$street_address, 'type'=>'string'),
                                  array('fieldName'=>'entry_postcode', 'value'=>$postcode, 'type'=>'string'),
                                  array('fieldName'=>'entry_city', 'value'=>$city, 'type'=>'string'),
                                  array('fieldName'=>'entry_country_id', 'value'=>$country, 'type'=>'integer')
          );
    Does that match with yours? What version of PHP (for completeness, I don't envision that the PHP version makes a difference)?

  3. #3
    Join Date
    Jan 2015
    Posts
    107
    Plugin Contributions
    0

    Default Re: Unsupported operand

    That seems to work. For some reason github had the wrong code in it for version 1.5.4.

  4. #4
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,978
    Plugin Contributions
    63

    Default Re: Unsupported operand

    That's because the GitHub repository has the ZC 1.5.5/1.5.6 implementations, most likely using the [] construct for arrays, not necessarily supported by your PHP version.

 

 

Similar Threads

  1. v139h Express Checkout Unsupported operand in functions_taxes.php
    By Mad Maxx in forum PayPal Express Checkout support
    Replies: 2
    Last Post: 10 Apr 2014, 10:49 PM
  2. EasyBiz Template [unsupported]
    By blingthemes in forum Addon Templates
    Replies: 1
    Last Post: 22 Jun 2011, 12:06 AM
  3. Email Fatal Error: Unsupported operand types
    By webskipper in forum Templates, Stylesheets, Page Layout
    Replies: 4
    Last Post: 20 Apr 2008, 04:59 AM
  4. operand types
    By frostyy in forum General Questions
    Replies: 9
    Last Post: 13 Jul 2006, 05:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR