Results 1 to 6 of 6
  1. #1

    Default Products not displaying

    So recently, we have noticed that 4 of our subcategories are not displaying any of their products. We get the page header, and that's it. I know my products are THERE; normally, if there isn't anything, you get the "There are no products in this category" text. That isn't showing, plus in our Admin, the subcategories in question ARE showing all the product listings, AND everything is enabled. I've checked for error logs, except none are being generated. The only place I've seen anything, is in the Dev Console brought up on the actual pages. I know nothing about CSS coding, so I have no idea what I'm actually looking at or it's particular relevance, except to say that there is a massive chunk of code missing from the blank pages, as opposed to the working one.

    If anyone would like to take a look, the pages I'm referencing are:

    (Working) https://www.athensartandframe.com/in...x&cPath=97_103

    (Nonworking) https://www.athensartandframe.com/in...ex&cPath=97_99

    and the section is <body id="indexbody"> -> <div class="onerow-fluid"> -> <div class="co1720"> -> <div class="centerColumn">, and then everything beneath that, until you get to <span style="border-radius: etc...> is missing.

    If anyone has any kind of idea as to what is going on here, I would greatly appreciate it.

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: Products not displaying

    You've got a PHP error of some sort that's resulting in a "partial whitescreen". Look in your store's /logs directory for files named myDEBUG-{something}.log and post back the contents of the most recent one ... surrounded by "CODE" tags (the big # in the menu-bar when you're writing your post).

  3. #3

    Default Re: Products not displaying

    That was the first thing I looked for, actually. The only logs I have are for the Product Sorter plugin, which SHOULD'NT be interfering with this, or if it were, I would imagine it would be a more global issue. Regardless, here's what I've got.

    [02-Dec-2017 10:53:27 America/New_York] PHP Warning: scandir(DIR_FS_ADMINincludes/installers/zx_product_sorter): failed to open dir: No such file or directory in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 38

    [02-Dec-2017 10:53:27 America/New_York] PHP Warning: scandir(): (errno 2): No such file or directory in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 38

    [02-Dec-2017 10:53:27 America/New_York] PHP Warning: sort() expects parameter 1 to be array, boolean given in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 43

    [02-Dec-2017 10:54:42 America/New_York] PHP Warning: scandir(DIR_FS_ADMINincludes/installers/zx_product_sorter): failed to open dir: No such file or directory in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 38

    [02-Dec-2017 10:54:42 America/New_York] PHP Warning: scandir(): (errno 2): No such file or directory in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 38

    [02-Dec-2017 10:54:42 America/New_York] PHP Warning: sort() expects parameter 1 to be array, boolean given in /home/athensar/public_html/includes/init_includes/init_zx_product_sorter.php on line 43

    [02-Dec-2017 15:54:43 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'stats_template_redirect' not found or invalid function name in /home/athensar/public_html/wp/wp-includes/class-wp-hook.php on line 298

  4. #4

    Default Re: Products not displaying

    *Update*

    I HAVE uninstalled Product Sorter compleatly, to see if that would do anything, but it did not.

  5. #5
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    6,980
    Plugin Contributions
    63

    Default Re: Products not displaying

    The Product Sorter plugin is an admin-only installation; from the logs you posted, it looks like you might have installed those files on the storefront instead.

  6. #6
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    962
    Plugin Contributions
    1

    Default Re: Products not displaying

    Quote Originally Posted by Lordzoabar View Post

    [02-Dec-2017 15:54:43 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'stats_template_redirect' not found or invalid function name in /home/athensar/public_html/wp/wp-includes/class-wp-hook.php on line 298
    this seems like a wordpress error.... not sure if it is related....

    bottom line, there is a php error that is causing the page to fail. either zen will log it (which would be expected), or it will be in another error log....

    hard to troubleshoot without the error log....

    in the source for the 2 pages, the working page has the footer, the non-working does not.... which indicates an error that the server should be logging...

    best.
    feel free to donate money to carl or to the Zen-Cart Team

 

 

Similar Threads

  1. Products Not Displaying in IE
    By jvk22 in forum Setting Up Categories, Products, Attributes
    Replies: 1
    Last Post: 25 Mar 2011, 11:01 AM
  2. HELP!! All Products Not Displaying The Products.
    By limelites in forum General Questions
    Replies: 13
    Last Post: 28 Jul 2009, 03:25 PM
  3. Products not displaying
    By rgoins in forum Setting Up Categories, Products, Attributes
    Replies: 1
    Last Post: 11 Mar 2009, 05:37 PM
  4. Products not displaying
    By exarkun in forum Setting Up Categories, Products, Attributes
    Replies: 14
    Last Post: 6 Dec 2007, 11:40 AM
  5. Not Displaying Products
    By stuartforrest in forum General Questions
    Replies: 10
    Last Post: 4 Jan 2007, 06:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR