Results 1 to 9 of 9
  1. #1
    Join Date
    Mar 2012
    Posts
    307
    Plugin Contributions
    0

    Default can't log into Admin because ssl not installed. want to put site to maintenance mode

    I am going to (soon) rebuild my website on a different server, new version of zencart, etc. So I didn't renew my SSL. Now, I want to put my site in Maintenance Mode, but the browsers on my MAC (safari, chrome, and firefox) won't let me access my admin. It says "Safari can't connect to the page www.1234.com because Safari can't establish a secure connection to the server"... So,,,,, after I type in the admin URL, I then (after failed connection) take out the "s" after HTTP, and it connects to the sign-in page.. but when I enter my username and password,,,,, browser goes back to the "can't connect to server because of Safari can't establish a secure connection to the server".... It's like I'm in a bad SY-FI movie caught in some sort of a time loop... What now? Any help would be appreciated. Thanks

  2. #2
    Join Date
    Dec 2016
    Location
    Washington
    Posts
    51
    Plugin Contributions
    0

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    Just a guess, but maybe change the admin/includes/config.php and the includes/ config.php to not be defined as HTTPS.
    Last edited by answer=42; 30 Nov 2017 at 01:13 AM. Reason: typeO

  3. #3
    Join Date
    Mar 2012
    Posts
    307
    Plugin Contributions
    0

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    That's exactly what I was thinking, but I couldn't remember how (or where, I should say) to do it. I've done it before, but no more recent than 2 years ago. I'll give it a shot. Thank you

  4. #4
    Join Date
    Dec 2016
    Location
    Washington
    Posts
    51
    Plugin Contributions
    0

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    BEFORE: define('HTTP_SERVER', 'https://www.YOUR_SHOP.com');
    AFTER: define('HTTP_SERVER', 'http://www.YOUR_SHOP.com');

  5. #5
    Join Date
    Jul 2007
    Posts
    158
    Plugin Contributions
    1

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    "Now, I want to put my site in Maintenance Mode,"
    Try logging into the database and change the setting for maintenance mode

  6. #6
    Join Date
    Jul 2012
    Posts
    11,632
    Plugin Contributions
    13

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    There is likely more to it than just changing the one define.

    Basically need to reverse the guidance provided in this FAQ: https://www.zen-cart.com/content.php...alled-zen-cart

    In particular would be the two defines related to say: ENABLE_SSL. The store side includes/configure.php would also need to be modified. For both the admin and catalog side, verify that the file permissions are 644 before saving the change(s).
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  7. #7
    Join Date
    Dec 2016
    Location
    Washington
    Posts
    51
    Plugin Contributions
    0

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    Quote Originally Posted by mc12345678 View Post
    There is likely more to it than just changing the one define.

    Basically need to reverse the guidance provided in this FAQ: https://www.zen-cart.com/content.php...alled-zen-cart

    In particular would be the two defines related to say: ENABLE_SSL. The store side includes/configure.php would also need to be modified. For both the admin and catalog side, verify that the file permissions are 644 before saving the change(s).
    I was close for a guess, I'm still going to partially pat myself on the back :)

  8. #8
    Join Date
    Jul 2012
    Posts
    11,632
    Plugin Contributions
    13

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    Quote Originally Posted by answer=42 View Post
    I was close for a guess, I'm still going to partially pat myself on the back :)
    The portion of your guidance wasn't wrong. :) so pat on the back was deserved. :)
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  9. #9
    Join Date
    Dec 2016
    Location
    Washington
    Posts
    51
    Plugin Contributions
    0

    Default Re: can't log into Admin because ssl not installed. want to put site to maintenance m

    Thank you Mc #'s, it feels good to be able to help (even just a little) as many peoples' wisdom has helped me.

 

 

Similar Threads

  1. v150 Can't log into admin using SSL in a subdomain in got an error when entering the URL
    By icecold in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 25 Jul 2012, 04:03 PM
  2. Site Backup Restored - Can't Log Into Admin
    By designsbytrina in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 25 Jun 2011, 11:23 PM
  3. Can't log into cloned site's admin page
    By Tamuren in forum General Questions
    Replies: 7
    Last Post: 9 May 2011, 04:45 PM
  4. Live site flip/flops into maintenance mode
    By cliffvt in forum Upgrading from 1.3.x to 1.3.9
    Replies: 12
    Last Post: 30 Dec 2010, 03:24 PM
  5. Added SSL, Can't log into Admin
    By scosio in forum General Questions
    Replies: 1
    Last Post: 30 Jun 2010, 10:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR