Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36
  1. #1
    Join Date
    Aug 2013
    Posts
    30
    Plugin Contributions
    0

    Default Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Hello,

    I have ZC version 1.3.8a with a number of addons, including SEO urls, Tag Cloud, User Tracking, and a couple of others. I installed ZC without using the hosting installer, and I have not upgraded the version of ZenCart since it was installed, a number of years ago. The PHP version of my server is 5.2.17, and I am concerned about upgrading the PHP version, and that it might cause the site to not load at all. Presently, we are not using the cart purchase functions, it is being used as a display gallery.

    If I was to upgrade the PHP version from 5.2.17 to 5.4 or 5.5, which are both supported by my server, would it cause the add-ons shown above, or the site itself, to stop working entirely? This has been my main concern with upgrading the PHP version (and the ZC version), is that either the site would stop loading entirely, or that the add-ons would stop working.

    Since I am not using the site for people to make purchases, but I do collect user data, and users can presently still register, I would like to know what such a PHP upgrade might do to this site. Any help would be appreciated. Thank you.

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,643
    Plugin Contributions
    73

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    For a Zen Cart 1.3.8a site, any PHP upgrade to a version past 5.4 is going to cause your site to go down due to PHP language changes over the past 10-11 years.

  3. #3
    Join Date
    Jul 2012
    Posts
    15,104
    Plugin Contributions
    17

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    It is possible even with ZC 1.5.5f to install that version while php 5.2.17 is being used to at least get the ZC software operational and then to upgrade the php version.

    As to some of the plugins, not sure about SEO URLS or tag cloud, or the other plugins (not listed), but this would be a good point to identify their real need as part of the rebuild.

    The recommended method to do this type of upgrade is provided here: http://www.zen-cart.com/entry.php?3-...d-of-upgrading
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  4. #4
    Join Date
    Aug 2013
    Posts
    30
    Plugin Contributions
    0

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Thank you very much! I just updated the php version, and it still works.

    I have a related question, though. Is there an add-on or a website that would tell me all of the add-ons that this site has? I want to upgrade, but I no longer remember what all of the add-ons I installed on the site were, and I don't want to forget any.

    So, for a wordpress site, you can visit whatwpthemeisthat.com and it will tell you all of the add-ons that a
    site has on it. Is there something similar for zencart?

    To my knowledge, from the tools and configure menu, I have the following add-ons. I would like to know if they will all work with the latest version of zc after I have upgraded, or are there any known issues:
    Snapshot
    User Tracking
    Search Log Admin (not sure if this is an addon)
    Snapshot
    SEO Urls
    Google Base Feeder
    Sitemap XML
    Captcha
    Manufacturers All
    Auctions (this didn't work before with the older version, so if it doesn't work, that's no problem)
    Cross Sell
    Thank you so much for your help!

  5. #5
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,181
    Plugin Contributions
    96

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Quote Originally Posted by starrysky View Post
    Is there an add-on or a website that would tell me all of the add-ons that this site has?
    You can get some ideas using the Mod List contribution.
    https://www.zen-cart.com/downloads.php?do=file&id=2039
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  6. #6
    Join Date
    Aug 2013
    Posts
    30
    Plugin Contributions
    0

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    After upgrading the php version, as mentioned above in the prior thread, the site had seemed to be working. However, now, instead of loading anything on the site, it says the following error message:

    Deprecated: Function set_magic_quotes_runtime() is deprecated in /includes/application_top.php on line 18

    I tried to replace this file with the newer application_top file, but then the page came up simply blank (although there was no longer an error message; it was just a white page with the favicon at the top.) Is there a simple way to resolve this problem, without having to go through the whole upgrade?

    This site has a lot of addons and quite a few modified files, and we were hoping not to have to upgrade it at this time, as it may take at least a week or more to do properly0.

    Any help in fixing this issue would be greatly appreciated. Thank you!

  7. #7
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    7,501
    Plugin Contributions
    8

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Quote Originally Posted by starrysky View Post
    I tried to replace this file with the newer application_top file, but then the page came up simply blank (although there was no longer an error message; it was just a white page with the favicon at the top.) Is there a simple way to resolve this problem, without having to go through the whole upgrade?
    THings change over the years so, your adding the newer file was sorta like putting a cummins diesel in a volkswagen.

    In the original fie, you should find something like
    Code:
    # set_magic_quotes_runtime(0);
    You can replace it with
    Code:
    ini_set(&quot;magic_quotes_runtime&quot;,0);
    Adjust accordingly. It may be something other than a 0 before the closing parentheses.

    Once you get the site working again, follow the upgrade instructions given above. You may find that most of your mods not only don't work, but aren't needed with the newer version.

    @swguy 1.3.8a?
    Did you read the posting tips?!?
    Responsive Color Changes for 155-156c demo here.
    Zen Cart PCI Compatible Hosting

  8. #8
    Join Date
    Aug 2013
    Posts
    30
    Plugin Contributions
    0

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Hi, thank you so much for your help! However, when I changed line 18 as instructed, the following error comes up when the page is loaded:

    Parse error: syntax error, unexpected ';', expecting :: (T_PAAMAYIM_NEKUDOTAYIM).... on the same line in the same file as referenced above.


    I am not sure what to change in order to fix this error. Does it have to do with the 0 value being changed? What are the acceptable values to change that value to? Or, is this something else? Thanks!

  9. #9
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,643
    Plugin Contributions
    73

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Try this instead, replacing &quot; with a single-quote (')


    ini_set('magic_quotes_runtime',0);

  10. #10
    Join Date
    Aug 2013
    Posts
    30
    Plugin Contributions
    0

    Default Re: Concerned About Upgrading Server PHP with ZC version 1.3.8a

    Thank you very much. However, now when I load the page, in firefox it is a blank white page, with the favicon in the address bar. On google chrome, it comes up as an "HTTP Error 500". I am not sure what needs to be changed at this point, if it is in the same file, or a different file?

 

 
Page 1 of 4 123 ... LastLast

Similar Threads

  1. Replies: 4
    Last Post: 7 May 2016, 05:46 PM
  2. Replies: 1
    Last Post: 31 Aug 2012, 06:35 PM
  3. v139h Upgrading PHP version from 4.4.9?
    By PudzPud in forum General Questions
    Replies: 4
    Last Post: 22 Mar 2012, 06:32 PM
  4. Upgrading PHP Version
    By kdipaolo in forum General Questions
    Replies: 2
    Last Post: 2 Mar 2012, 05:15 PM
  5. live and upgrading version on same server
    By icikite in forum Upgrading to 1.5.x
    Replies: 2
    Last Post: 4 Jan 2012, 03:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR