Results 1 to 10 of 16

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Posts
    211
    Plugin Contributions
    0

    help question ZC upgrade fails from 1.3.9 to 1.50 using v1.5.5f install

    Howdy,
    Years ago I volunteered to help make this store for a family member and after a long absence am back at trying to upgrade. I wish this was done sometime ago but it is what it is. Recently the SSL certificate needed updated by host and that broke the shipping module of old store, plus a few other PayPal checkout quirks. Seeing how outdated the cart was and the newer server upgrades to PHP and Mysql made me think its time to move on and not try to keep the old store going. Although store did work ok until that cert. install and the many years is a testament of how good 1.3.9h was. Store is down for maintenance for now, unfortunately.

    We have been going deep for over 2 weeks and researched the forum and other sources but appear to be at a dead end.
    Did a copy of DB and followed Dr. Bytes "How do I Upgrade My Zen Cart" for test site. Been many years so I need to re remember where able.

    So we repeatedly get to the point of My_store/ZC_install with 1.55f and after it tries to Upgrade DB it gives up before reaching a 1.50 upgrade.
    My DB experience is lacking and am trying to wrap my mind around possible fixes but does anyone recognizes what direction I may start towards at at this point?

    Also should I try to uninstall any Plugins SQL from the DB before upgrading?
    I know some plugins like Image Handler will need a newer version anyway and other may just need cleaned out for good. I did use a My_template override system as well. Tried to keep store simple but found remnents of older stuff back from the 1.2.x days

    Below is the Logs we usually find in the new store after a DB upgrade attempt with 1.5.5f;

    Code:
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Telephone - Customer Service', 'STORE_TELEPHONE_CUSTSERVICE', '', 'Enter a telephone number for customers to reach your Customer Service department. This number may be sent as part of payment transaction details.', 1, 7, now());  1364: Field 'configuration_id' doesn't have a default value  
    
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('login mode https', 'SSLPWSTATUSCHECK', '', 'System setting. Do not edit.', 6, 99, now());  1364: Field 'configuration_id' doesn't have a default value  
    
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    ALTER TABLE admin_activity_log CHANGE COLUMN log_id log_id bigint(15) NOT NULL auto_increment;  1075: Incorrect table definition; there can be only one auto column and it must be defined as a key  
    
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    ALTER TABLE admin_activity_log DROP INDEX page_accessed;  1091: Can't DROP 'page_accessed'; check that column/key exists  
    
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    ALTER TABLE admin_activity_log DROP INDEX access_date;  1091: Can't DROP 'access_date'; check that column/key exists  
    
    ---------------
    Apr 12 2018 18:11 -- upgradeException
    FROM project_version;  1364: Field 'project_version_id' doesn't have a default value

    And of course this log, all others Passed;

    Code:
    ---------------
    Apr 12 2018 18:10 -- checkPhpVersion
    FAILED
    (
        [version] => 7.1.0
        [versionTest] => ge

    And from a third Log is the below Fails, all other Passed;


    Code:
    ---------------
    Apr 12 2018 18:09 -- checkIniGet
    FAILED
    (
        [inigetName] => output_buffering
        [expectedValue] => 1
    )
    
    
    ---------------
    Apr 12 2018 18:10 -- checkIniGet
    FAILED
    (
        [inigetName] => output_buffering
        [expectedValue] => 1
    )
    And from a forth Log is the below errors;


    Code:
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Telephone - Customer Service', 'STORE_TELEPHONE_CUSTSERVICE', '', 'Enter a telephone number for customers to reach your Customer Service department. This number may be sent as part of payment transaction details.', 1, 7, now());
    ---------------
    
    
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('login mode https', 'SSLPWSTATUSCHECK', '', 'System setting. Do not edit.', 6, 99, now());
    ---------------
    
    
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    ALTER TABLE admin_activity_log CHANGE COLUMN log_id log_id bigint(15) NOT NULL auto_increment;
    ---------------
    
    
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    ALTER TABLE admin_activity_log DROP INDEX page_accessed;
    ---------------
    
    
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    ALTER TABLE admin_activity_log DROP INDEX access_date;
    ---------------
    
    
    [12-Apr-2018 18:11:00 America/Detroit] MySQL error 1364 encountered during zc_install:
    Field 'upgrade_exception_id' doesn't have a default value
    FROM project_version;
    ---------------

    Can someone please help?
    Thank you,



    My world;
    PHP version 5.4.45
    Mysql version 5.6.38
    Linux server

    Plugins are likely1.3.9 or before (or found remnants of older plugins)
    Supertracker
    Google Sitemap or Sitemapxml
    Syscheck 1.3.8
    ImageHandler 3
    ckeditor
    fckeditor
    htmlarea
    google analytics
    Justwade
    Zen 1.5.5f
    Zen 1.3.9h, Zen 1.27 + (did that, done with that)

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    11,953
    Plugin Contributions
    85

    Default Re: ZC upgrade fails from 1.3.9 to 1.50 using Zencart 1.5.5f install

    It sounds like you know your way around phpMyAdmin. Use that tool to view your to-be-upgraded database and provide screenshots of the Structure of the following database tables (if your DB_PREFIX is other than '', the table names will be prefixed by that value):

    admin_activity_log
    configuration
    project_version
    upgrade_exceptions

  3. #3
    Join Date
    Oct 2005
    Posts
    211
    Plugin Contributions
    0

    Default Re: ZC upgrade fails from 1.3.9 to 1.50 using Zencart 1.5.5f install

    Thank you for the kind reply. Attached is the screenshots. I am just not seeing what may be obvious.

    Click image for larger version. 

Name:	Zencart admin_activity_log.jpg 
Views:	139 
Size:	56.7 KB 
ID:	17792

    Click image for larger version. 

Name:	Zencart DB configuration structure.jpg 
Views:	112 
Size:	62.3 KB 
ID:	17793

    Click image for larger version. 

Name:	Zencart DB project_version structure.jpg 
Views:	113 
Size:	60.2 KB 
ID:	17794

    Click image for larger version. 

Name:	Zencart DB upgrade_exceptions structure.jpg 
Views:	98 
Size:	40.2 KB 
ID:	17795
    Justwade
    Zen 1.5.5f
    Zen 1.3.9h, Zen 1.27 + (did that, done with that)

  4. #4
    Join Date
    Jul 2012
    Posts
    16,651
    Plugin Contributions
    17

    Default Re: ZC upgrade fails from 1.3.9 to 1.50 using Zencart 1.5.5f install

    Are those images from the existing down-for-maintenance live site's database or the new database that has received a "copy" of the live database?

    How was this copy/backup made/with what settings?

    For the applicable tables the EXTRA column is missing the setting of AUTO_INCREMENT for say log_id, etc...
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  5. #5
    Join Date
    Jul 2012
    Posts
    16,651
    Plugin Contributions
    17

    Default Re: ZC upgrade fails from 1.3.9 to 1.50 using Zencart 1.5.5f install

    Quote Originally Posted by mc12345678 View Post
    Are those images from the existing down-for-maintenance live site's database or the new database that has received a "copy" of the live database?

    How was this copy/backup made/with what settings?

    For the applicable tables the EXTRA column is missing the setting of AUTO_INCREMENT for say log_id, etc...
    Perhaps step "2" of this FAQ would also help assuming that the original database is/was ok: https://www.zen-cart.com/content.php...atabase-backup
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  6. #6
    Join Date
    Oct 2005
    Posts
    211
    Plugin Contributions
    0

    Default Re: ZC upgrade fails from 1.3.9 to 1.50 using Zencart 1.5.5f install

    Are those images from the existing down-for-maintenance live site's database or the new database that has received a "copy" of the live database?

    How was this copy/backup made/with what settings?

    For the applicable tables the EXTRA column is missing the setting of AUTO_INCREMENT for say log_id, etc...


    Quote Originally Posted by mc12345678 View Post
    Perhaps step "2" of this FAQ would also help assuming that the original database is/was ok: https://www.zen-cart.com/content.php...atabase-backup
    Yes, this is a copy of the down for maintenance live site's database.

    Well after many trials and slow transfers with the standard above, I tried on this one Database_copy-2 a new to me way of copying a live DB. I went into PhpMyAdmin / Operations and chose "Copy table to database.table" and clicked off "Add Drop Table". Was fast, allowed many more tests. Not sure how that compares to the standard......

    But that said, perhaps to my dismay. The original live DB and perhaps some older ones all do not have AUTO_INCREMENT in the Extra column as you have found on these images. I looked at an old demo store and they have it. Not sure where else these AUTO_INCREMENT should all be but they are not in the columns in question.

    Can this be fixed?
    Justwade
    Zen 1.5.5f
    Zen 1.3.9h, Zen 1.27 + (did that, done with that)

 

 

Similar Threads

  1. cannot upgrade from 1.3.9h to 1.5.4 install page blank
    By soaringeagle in forum Upgrading to 1.5.x
    Replies: 32
    Last Post: 8 Nov 2015, 08:04 AM
  2. Replies: 2
    Last Post: 26 Sep 2012, 08:55 PM
  3. Fresh install of 1.5 using database from 1.3.8
    By plsony in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 22 Jun 2012, 06:59 PM
  4. upgrade from v1.3.9b to v1.3.9d Eazy install?
    By hello in forum Upgrading from 1.3.x to 1.3.9
    Replies: 10
    Last Post: 11 Aug 2010, 03:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR