Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2008
    Posts
    44
    Plugin Contributions
    0

    Default New payflowpro reference transaction error

    Hello,

    Using 1.5.5f+ WITH PHP 7.1. with payflow pro and paypal express.

    Problem is, I recently upgraded from ZC 1.5.4 to 1.5.5f and while everything is working great. I am not longer able to process reference transactions using the web interface for payflow pro at manager.paypal.com.

    PayPal tech support said that, so far, the only thing they can see that has changed is that while my old store was using paypal manager credentials to communicate with paypal, the new store is now using API credentials. So, they believe that the API cred's are not passing information needed (that the old manager cred's transmitted) to do reference transactions.

    And, for some reason, the new 'Transaction ID's' are not searchable using manager.paypal.com's search interface; I am forced with searching transactions by customers last name.

    So, in summary. I can still create reference transaction for old orders prior to the update, but wil all new orders, I can't.

    Any help appreciated!!!

    Click image for larger version. 

Name:	a1.jpg 
Views:	84 
Size:	47.3 KB 
ID:	17826
    Click image for larger version. 

Name:	b.jpg 
Views:	110 
Size:	60.2 KB 
ID:	17827

  2. #2
    Join Date
    Dec 2008
    Posts
    44
    Plugin Contributions
    0

    Default Re: New payflowpro reference transaction error

    I got a response from PayPal. Perhaps someone can help shed some light on how to fix this.
    -------------

    "Reviewing your account, it shows that the transactions are being processed through PayPal API's rather than Payflow API (which is what you were using)

    When payments process through PayPal API's, there is just a dummy record displayed within your Payflow Account, but you won't be able to run reference transactions against these because they will not have the transactional data behind them to do that."
    ------------

    Any ideas anyone???

  3. #3
    Join Date
    Dec 2008
    Posts
    44
    Plugin Contributions
    0

    Default Re: New payflowpro reference transaction error

    And, each transaction Zen Cart sends over contains this once arriving at PayPal:

    "Dummy User for WPP Foreign Constraint"

  4. #4
    Join Date
    Jun 2009
    Location
    Sparta, TN
    Posts
    82
    Plugin Contributions
    0

    Default Re: New payflowpro reference transaction error

    During your upgrade, did you remember to uninstall your payment modules and reinstall after your update?
    This always gets me.
    If not, you should be able to do this now.

  5. #5
    Join Date
    Dec 2008
    Posts
    44
    Plugin Contributions
    0

    Default Re: New payflowpro reference transaction error

    Thanks VDecals,

    I am not sure. Someone else did the upgrade.

    I will check though.

    Can anyone at all confirm that they can do reference transactions on manager.paypal.com using paypal payments pro and express checkouts versions 1.5.5?

    If anyone can at least attest that it is in fact working 'on their cart', that would at least confirm that 'something' is fixable on my end. Otherwise, I am left thinking that the module simple does not communicate with PayPal in a fashion that will allow reference transactions going forward.

    Thanks!

 

 

Similar Threads

  1. v139h Reference Transaction API thorugh PayPal?
    By markarupert in forum PayPal Website Payments Pro support
    Replies: 1
    Last Post: 8 May 2012, 07:17 PM
  2. PayFlowPro Error (12)
    By hzrdc2 in forum Addon Payment Modules
    Replies: 2
    Last Post: 9 Mar 2010, 05:12 PM
  3. Reference new page in url address
    By g_force in forum General Questions
    Replies: 9
    Last Post: 21 Oct 2009, 10:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR