Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2016
    Location
    Athens
    Posts
    8
    Plugin Contributions
    0

    Default Possible problem with Php 5.3.28 during upgrade proccess

    Hello,

    I have:
    • Zen Cart 1.3.9h
    • MySQL 5.5.31
    • Php 5.3.28


    I want to upgrade to
    • Zen Cart 1.5.5
    • MariaDB 10.1
    • Php 7.1


    So, I thought that I could follow these steps:
    1. Upgrade Zen Cart from 1.3.9h to 1.5.5 (keeping current server settings)
    2. Upgrade server to MariaDB 10.1 and Php 7.1


    But I saw in (https://www.zen-cart.com/content.php...o-run-zen-cart) that "Zen Cart v1.5.4 is designed for PHP 5.5 and PHP 5.6 (and is compatible with PHP 5.3.7* and PHP 5.4 if posted bugfixes are researched and applied)"

    So, my question is, how can I upgrade from 1.5.3 --> 1.5.4 and finally 1.5.5, since 1.5.4 supports PHP 5.3.7* but I have installed 5.3.28?

    Thank you and Regards
    Elias

  2. #2
    Join Date
    Jul 2012
    Posts
    13,098
    Plugin Contributions
    16

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by evathias View Post
    Hello,

    I have:
    • Zen Cart 1.3.9h
    • MySQL 5.5.31
    • Php 5.3.28


    I want to upgrade to
    • Zen Cart 1.5.5
    • MariaDB 10.1
    • Php 7.1


    So, I thought that I could follow these steps:
    1. Upgrade Zen Cart from 1.3.9h to 1.5.5 (keeping current server settings)
    2. Upgrade server to MariaDB 10.1 and Php 7.1


    But I saw in (https://www.zen-cart.com/content.php...o-run-zen-cart) that "Zen Cart v1.5.4 is designed for PHP 5.5 and PHP 5.6 (and is compatible with PHP 5.3.7* and PHP 5.4 if posted bugfixes are researched and applied)"

    So, my question is, how can I upgrade from 1.5.3 --> 1.5.4 and finally 1.5.5, since 1.5.4 supports PHP 5.3.7* but I have installed 5.3.28?

    Thank you and Regards
    Elias
    First off, php 5.3.28 is higher than 5.3.7 and therefore still fits within the "band".

    But, more importantly, you don't need to do this upgrade from version to version to version. Especially in light of what you are wanting to do.

    You want ZC 1.5.5... why deal with the in betweens? It could be something that may become necessary (rarely) but it is a lot of time spent not focussing on the real business.

    Unfortunately even going that route, there are some changes that have been made in ZC 1.5.5f that will not allow verifying some things about the store before upgrading the php version. It's unfortunate that it is that way, but the recent goal and push is to cease supporting the older versions of things when something new comes out rather than continue to use what is acceptable in both the new and old.

    Anyways, hopefully you have taken a lap through this FAQ: http://www.zen-cart.com/entry.php?3-...d-of-upgrading
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  3. #3
    Join Date
    Sep 2016
    Location
    Athens
    Posts
    8
    Plugin Contributions
    0

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by mc12345678 View Post
    First off, php 5.3.28 is higher than 5.3.7 and therefore still fits within the "band".

    But, more importantly, you don't need to do this upgrade from version to version to version. Especially in light of what you are wanting to do.

    You want ZC 1.5.5... why deal with the in betweens? It could be something that may become necessary (rarely) but it is a lot of time spent not focussing on the real business.

    Unfortunately even going that route, there are some changes that have been made in ZC 1.5.5f that will not allow verifying some things about the store before upgrading the php version. It's unfortunate that it is that way, but the recent goal and push is to cease supporting the older versions of things when something new comes out rather than continue to use what is acceptable in both the new and old.

    Anyways, hopefully you have taken a lap through this FAQ: http://www.zen-cart.com/entry.php?3-...d-of-upgrading
    Hello, thank you for the quick response.

    1. I did not know that there was such a fast way, meaning that I install a new shop and then transfer the database.
    2. Can you please explain what do you mean by "... there are some changes that have been made in ZC 1.5.5f that will not allow verifying some things about the store before upgrading the php version ..."? I won't be able to setup an 1.5.5f new shop? I won't be able to migrate the database?

    Please advice
    Kind Regards
    Elias

  4. #4
    Join Date
    Jul 2012
    Posts
    13,098
    Plugin Contributions
    16

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by evathias View Post
    Hello, thank you for the quick response.

    1. I did not know that there was such a fast way, meaning that I install a new shop and then transfer the database.
    2. Can you please explain what do you mean by "... there are some changes that have been made in ZC 1.5.5f that will not allow verifying some things about the store before upgrading the php version ..."? I won't be able to setup an 1.5.5f new shop? I won't be able to migrate the database?

    Please advice
    Kind Regards
    Elias
    The goal of the process is to keep your existing store operational while making it possible to install AND test the new version. Now, yes, one should do a better job at upgrading along the way to keep the difficulties at a minimum. In this case though there are a few features that without making change to the code, just won't work until the php version is upgraded above what your current store supports. It means that in order to see how certain "features" work either you have to at least temporarily prevent your current store from supporting operation or one should have blind faith that those features will work after the php upgrade. Of course one can modify either the old or the new to work in the alternate environment, but just saying that one shouldn't have to do that knowing the cause of that problem.

    So, perhaps you're still wondering what impact it will have? The database can be transferred regardless the php version. The store can be setup, but for example the payment module which didn't exist in time until recently the payment method square or payeezy as written won't operate in a php environment below 5.6 because it uses the short hand for an array ([] instead of array()) that was only made available at and after php 5.6.

    Do the upgrade, test what you can, review the logs folder when something in testing doesn't seem to go as expected, ask questions. Make backups!!! Database particularly.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    6,881
    Plugin Contributions
    8

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by evathias View Post
    Hello, thank you for the quick response.

    1. I did not know that there was such a fast way, meaning that I install a new shop and then transfer the database.
    2. Can you please explain what do you mean by "... there are some changes that have been made in ZC 1.5.5f that will not allow verifying some things about the store before upgrading the php version ..."? I won't be able to setup an 1.5.5f new shop? I won't be able to migrate the database?
    If you have cpanel as your controller, check with your host to see if you are running suPHP or some other version that allows specifying PHP by directory. If they provide it, you could set the root to 5.3 and yoursiteDOTcom/test to 5.6 while upgrading. When done, move the new site to the root and set the whole site back to 7.0 when done.

  6. #6
    Join Date
    Sep 2016
    Location
    Athens
    Posts
    8
    Plugin Contributions
    0

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by dbltoe View Post
    If you have cpanel as your controller, check with your host to see if you are running suPHP or some other version that allows specifying PHP by directory. If they provide it, you could set the root to 5.3 and yoursiteDOTcom/test to 5.6 while upgrading. When done, move the new site to the root and set the whole site back to 7.0 when done.
    Thank you for your help. I have directadmin, and I will have this option after the upgrade of my server to the new software versions.
    Kind Regards

  7. #7
    Join Date
    Sep 2016
    Location
    Athens
    Posts
    8
    Plugin Contributions
    0

    Default Re: Possible problem with Php 5.3.28 during upgrade proccess

    Quote Originally Posted by mc12345678 View Post
    The goal of the process is to keep your existing store operational while making it possible to install AND test the new version. Now, yes, one should do a better job at upgrading along the way to keep the difficulties at a minimum. In this case though there are a few features that without making change to the code, just won't work until the php version is upgraded above what your current store supports. It means that in order to see how certain "features" work either you have to at least temporarily prevent your current store from supporting operation or one should have blind faith that those features will work after the php upgrade. Of course one can modify either the old or the new to work in the alternate environment, but just saying that one shouldn't have to do that knowing the cause of that problem.

    So, perhaps you're still wondering what impact it will have? The database can be transferred regardless the php version. The store can be setup, but for example the payment module which didn't exist in time until recently the payment method square or payeezy as written won't operate in a php environment below 5.6 because it uses the short hand for an array ([] instead of array()) that was only made available at and after php 5.6.

    Do the upgrade, test what you can, review the logs folder when something in testing doesn't seem to go as expected, ask questions. Make backups!!! Database particularly.
    Thank you.

    I started by installing ZC 1.5.5f. It runs smoothly in my old server, and very fast!

    I know install (in the new shop) greek language. And then I have to import the database.
    Ιs this the right order or should I do it differently?

    If the shop runs smoothly with the products, then I will upgrade my server keeping both shops. And if the new shop runs ok, I will delete the old shop and keep the new. Is this ok?

    Moreover, after finishing the transition (hope to succeed) I will make a full greek translation for 1.5.5f and upload it.

    Kind Regards
    Elias

 

 

Similar Threads

  1. Odd problem with configure.php when trying to upgrade
    By canemasters in forum Upgrading to 1.5.x
    Replies: 4
    Last Post: 19 Mar 2012, 07:16 PM
  2. Problem with custom tpl_whats_new.php sidebox after upgrade
    By JLA in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 23 May 2010, 12:04 PM
  3. PHP Upgrade Problem with Shared SSL
    By grncreek in forum General Questions
    Replies: 2
    Last Post: 20 Nov 2008, 01:41 AM
  4. Problem during upgrade (after renaming tables to remove zen_ prefix)
    By rainthebat in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 11 Dec 2007, 05:23 PM
  5. currency problem with GV during checkout
    By s_mack in forum Bug Reports
    Replies: 5
    Last Post: 20 Nov 2006, 11:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR