Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2018
    Location
    South Africa
    Posts
    7
    Plugin Contributions
    0

    Idea or Suggestion Upgrade to PHP Version 7.2 - How to do it?

    I am using the following Versions:

    Zen Cart Version 1.3.8a
    PHP Version 5.6.38

    My Provider is discontinuing the above PHP-Version and my Website will
    only work in future whe I do upgrade it to PHP Version 7.2


    I don't understand anything about how to do this....
    may you point me into the right direction?
    Please in a way that I am understanding....

    Any support would be soooo appreciated.

  2. #2
    Join Date
    Aug 2007
    Location
    Gijón, Asturias, Spain
    Posts
    1,817
    Plugin Contributions
    26

    Default Re: Upgrade to PHP Version 7.2 - How to do it?

    First, check your hosting cannot allow PHP7.1. If not, find someone who will.
    Current ZC (v1.5.5) will work on 7.1, but not 7.2.

    You have a lot of work to do to update to the current version (congratulations on your obsolete ZC not getting hacked, you have been fortunate).

    Trying to add in 100+ edits from the development version 156 to get the current version to work with 7.2 is more pain you should avoid for the moment. Wait until ZC 156 is released.
    Steve
    github.com/torvista: Apsona (php7), BackupMySQL Admin/Auto, CEON URI Mapping (php7), Product Listing Sorter, Redsys payment module, Spanish Language Pack and more...

  3. #3
    Join Date
    Jul 2012
    Posts
    12,981
    Plugin Contributions
    16

    Default Re: Upgrade to PHP Version 7.2 - How to do it?

    The general how to is an instruction on how to use current up-to-date software, incorporate changes that have been made to reflect the desired output and an update of the database to the then current expected structure. This is accomplished through an upgrade by rebuild as provided here: http://www.zen-cart.com/entry.php?3-...d-of-upgrading

    And would be highly recommended over trying to "patch" individual sections/code while still claiming to be on an older version...

    As pointed out by torvista, should see what is possible to support php 7.1 as ZC 1.5.5f supports that as the highest version where the not yet released 1.5.6 will support php 7.2. So, if 7.1 can still be used in that site, great, do the full upgrade to ZC 1.5.5f.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

 

 

Similar Threads

  1. Replies: 3
    Last Post: 20 Dec 2015, 10:29 AM
  2. Replies: 4
    Last Post: 4 Sep 2012, 05:56 PM
  3. Upgrading ZC needs php version upgrade?
    By jaishem in forum General Questions
    Replies: 6
    Last Post: 15 Mar 2011, 01:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR