Results 1 to 7 of 7
  1. #1
    Join Date
    May 2016
    Location
    Ohio
    Posts
    243
    Plugin Contributions
    0

    Default Please select a payment method for your order.

    People are not able to check out... I choose cc and it says Please select a payment method for your order.
    (You are presently using: v1.5.4)

    I had to upgrade my site from shared hosting (Dreamhost) to a VPS for memory issues, and now under admin payment options I see this:Name:  payment.jpg
Views: 69
Size:  24.5 KB
    Last edited by jmberman; 5 Dec 2018 at 06:20 PM.

  2. #2
    Join Date
    May 2016
    Location
    Ohio
    Posts
    243
    Plugin Contributions
    0

    Default Re: Please select a payment method for your order.

    I had to upgrade my site from shared hosting (Dreamhost) to a VPS for memory issues, and now under admin payment options I see this:

    People are not able to check out... I choose cc and it says Please select a payment method for your order.
    (You are presently using: v1.5.4)

    The zen cart payment module now shows no options after the change to VPS.

  3. #3
    Join Date
    May 2016
    Location
    Ohio
    Posts
    243
    Plugin Contributions
    0

    Default Re: Please select a payment method for your order.

    All other modules seem to load except payment, so when people try to check out it keeps saying choose payment method, i need to figure this out asap please help.

  4. #4
    Join Date
    May 2016
    Location
    Ohio
    Posts
    243
    Plugin Contributions
    0

    Default Re: Please select a payment method for your order.

    Whew, I was able to resolve the issue.

    i was thinking switching from PHP 5.6 to 7 along with the VPS switch broke it due to an incompatibility, so I just switched it back to 5.6 and it's now working.
    Last edited by jmberman; 5 Dec 2018 at 06:48 PM.

  5. #5
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    9,032
    Plugin Contributions
    72

    Default Re: Please select a payment method for your order.

    Yes, Zen Cart 1.5.4 is not compatible with PHP versions greater than 5.6.

  6. #6
    Join Date
    May 2016
    Location
    Ohio
    Posts
    243
    Plugin Contributions
    0

    Default Re: Please select a payment method for your order.

    Quote Originally Posted by lat9 View Post
    Yes, Zen Cart 1.5.4 is not compatible with PHP versions greater than 5.6.
    Thank You for the confirmation.

  7. #7
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,401
    Plugin Contributions
    2

    Default Re: Please select a payment method for your order.

    the image you loaded should have created a log file. i would look to see if you can find the log file as errors should always get logged, and the ZC logging overrides function is quite good.

    it would have pointed you tot the same conclusion that @lat9 made.

    best.
    no good deed goes unpunished. help out with the green....

 

 

Similar Threads

  1. Error: Please select a payment method for your order
    By marypotter in forum Addon Payment Modules
    Replies: 3
    Last Post: 25 Jan 2012, 08:34 PM
  2. Please select a payment method for your order
    By jensen_tw in forum PayPal Express Checkout support
    Replies: 20
    Last Post: 30 Aug 2011, 05:45 AM
  3. Please select a payment method for your order
    By ellivir in forum PayPal Express Checkout support
    Replies: 6
    Last Post: 18 Nov 2010, 09:21 PM
  4. Please select a payment method for your order
    By stagebrace in forum Bug Reports
    Replies: 1
    Last Post: 3 Jun 2010, 10:50 AM
  5. * Please select a payment method for your order.
    By scott_see in forum Built-in Shipping and Payment Modules
    Replies: 2
    Last Post: 22 Jan 2010, 01:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR