Results 1 to 8 of 8
  1. #1
    Join Date
    Apr 2017
    Location
    United States
    Posts
    5
    Plugin Contributions
    0

    Default "unknown response 400" please help?!

    [Note: remember to include site URL, ZC version, list of plugins, PHP version, etc ... read the Posting Tips shown above for information to include in your post here. And, remove this comment before actually posting!]

    Hello all. I am new to zen cart and have searched for a remedy to my issue but have been unable to find anything. I apologize if this ia a duplicate post.

    https://www.made-right-here.com

    ZC version: 1.5.5 installed by FTP
    THe only plugins I am running are taxcloud, shipstation, UPS tracking, and the Winchester BLack template
    PHP version 5.6.37
    MySQL version: 5.6.41-84.1(as it is listed in the server info under admin>tools.)
    I do not know for certain when the problem started, Only that I noticed it last night when I was doing some shopping cart test runs to make sure everything was running smoothly.

    Problem:
    anytime there is a login, logout, or change in the shopping cart contents I get the following message:

    Made-right-here.com says:
    An unknown response 400: :text/html; charset=utf-8: : was received while processing an ajax call. The action you requested could not be completed.

    In my browser, the message shows as a pop up with an "OK" button. WHen I click the button, the action continues and is apparently completed. THis happens when loggin in as a shopper, or when browsing without being logged in if I add something to the cart login. I have had no such messages in the admin area. I have not tested actual transactions yet to see if this affects them. THere do not appear to be any related debug logs. I will include a screenshot of the message. Please let me know if there are other questions or needed information.
    Name:  Drawing1.png
Views: 90
Size:  73.9 KB

  2. #2
    Join Date
    Apr 2017
    Location
    United States
    Posts
    5
    Plugin Contributions
    0

    Default Re: "unknown response 400" please help?!

    on further inspection, it does appear to be an issue with the Winchester Black template I have installed. I tried it with the responsive classic template and did not get the same message. Can anyone suggest a patch or fix? I really like the style of the winchester black template.

  3. #3
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,344
    Plugin Contributions
    2

    Default Re: "unknown response 400" please help?!

    you need to replace your:

    includes/templates/winchester_responsive/jscript/jscript_framework.php

    file with this one:

    https://github.com/zencart/zencart/b..._framework.php

    actually see:

    https://www.zen-cart.com/showthread....jax-Call-Error

    best.
    Last edited by carlwhat; 7 Dec 2018 at 05:22 PM.
    helpful? while i do it for fun, u can say thanks with the green. bitcoin also welcome...

  4. #4
    Join Date
    Jul 2012
    Posts
    13,112
    Plugin Contributions
    16

    Default Re: "unknown response 400" please help?!

    Quote Originally Posted by jnorwood521 View Post
    on further inspection, it does appear to be an issue with the Winchester Black template I have installed. I tried it with the responsive classic template and did not get the same message. Can anyone suggest a patch or fix? I really like the style of the winchester black template.
    There are actions identified in this thread that are needed to support operation of that (and similar templates) to operate under ZC 1.5.5: https://www.zen-cart.com/showthread....rk-with-v1-5-5

    Welcome to Zen Cart, sorry you're having difficulty. Hopefully that and any other assistance requested/received helps you get through the issues.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  5. #5
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,344
    Plugin Contributions
    2

    Default Re: "unknown response 400" please help?!

    Quote Originally Posted by mc12345678 View Post
    There are actions identified in this thread that are needed to support operation of that (and similar templates) to operate under ZC 1.5.5: https://www.zen-cart.com/showthread....rk-with-v1-5-5

    Welcome to Zen Cart, sorry you're having difficulty. Hopefully that and any other assistance requested/received helps you get through the issues.
    why doesn't anyone update those templates?
    helpful? while i do it for fun, u can say thanks with the green. bitcoin also welcome...

  6. #6
    Join Date
    Jul 2012
    Posts
    13,112
    Plugin Contributions
    16

    Default Re: "unknown response 400" please help?!

    Quote Originally Posted by carlwhat View Post
    why doesn't anyone update those templates?
    There's a couple of reasons that come to mind as to why some have not: respect to the original author; she's still alive and doing some level of work. Whomever does the update in some regards will be asked to continue to support it which may deter some from stepping up. There's already posted solutions and people are still able to identify where they are. Currently the solution is not really one specific file or a specific change, but instead a process (something that could be coded into the installation script to ensure the content applicable to the currently installed version is used.) Those that know how to perform the actions don't see a need to update the files based on one or more of the above. Those that haven't provided an updated fileset before are worried about doing it right. Any number of other reasons/excuses..

    With that question, the same could be asked in return? Since anybody truly could offer up a revised fileset with instructions, then the question could be posed to the inquirer.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...
    Upgraded to Zen Cart V1.5.3 from V1.5.1 from V1.5.0 from V1.3.9h

  7. #7
    Join Date
    Apr 2017
    Location
    United States
    Posts
    5
    Plugin Contributions
    0

    Default Re: "unknown response 400" please help?!

    That did the trick. THank you so much!!!!!!!!

  8. #8
    Join Date
    Nov 2005
    Location
    los angeles
    Posts
    1,344
    Plugin Contributions
    2

    Default Re: "unknown response 400" please help?!

    Quote Originally Posted by mc12345678 View Post
    There's a couple of reasons that come to mind as to why some have not: respect to the original author; she's still alive and doing some level of work...

    With that question, the same could be asked in return? Since anybody truly could offer up a revised fileset with instructions, then the question could be posed to the inquirer.
    w/o rehashing things already stated on these boards; due to her marketing tactics i have no respect for the original author, and would prefer to not support her or anything associated with her....

    best.
    helpful? while i do it for fun, u can say thanks with the green. bitcoin also welcome...

 

 

Similar Threads

  1. v139h "Contact Us" page missing "Submit" button - please help!
    By lucky-nz in forum Templates, Stylesheets, Page Layout
    Replies: 18
    Last Post: 20 Feb 2013, 10:24 PM
  2. Please help, no "my account" or "order history"
    By jaypg1 in forum General Questions
    Replies: 15
    Last Post: 18 Oct 2009, 07:05 PM
  3. fedex setting "always free" weights to "0" on upgrade..help please
    By wootoot1234 in forum Built-in Shipping and Payment Modules
    Replies: 9
    Last Post: 14 Jan 2009, 01:11 AM
  4. Replies: 0
    Last Post: 15 May 2008, 01:51 PM
  5. Attributes - "More Info" / "Buy Now" Help please.
    By justme2000 in forum Setting Up Categories, Products, Attributes
    Replies: 3
    Last Post: 29 Dec 2007, 04:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR