Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    182
    Plugin Contributions
    2

    database error Database Issues when Upgrading - Pease Help!

    Ok so I had my live store running and set up the separate demo and test sites, and things seemed to be going well then I went to upload my database back up to the new file and all of a sudden the live site stopped working. What am I doing wrong?! Is it because the new database is a copy of the live site database? Should I rename the backup copy before uploading it to the blank database?!

  2. #2
    Join Date
    Sep 2008
    Posts
    210
    Plugin Contributions
    21

    Default Re: Database Issues when Upgrading - Pease Help!

    You need to check your error logs.
    Our Site: http://zucando.com
    Marketing Plugins: Marketing Modules
    Free Response Templates: Responsive Templates

  3. #3
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    182
    Plugin Contributions
    2

    Default Re: Database Issues when Upgrading - Pease Help!

    No longer have them. I uploaded the back-ups which did not work.

  4. #4
    Join Date
    Jul 2012
    Posts
    16,361
    Plugin Contributions
    17

    Default Re: Database Issues when Upgrading - Pease Help!

    Couple of things. From what version are you upgrading?

    How was the database backup loaded to the new database? Did you use something like mysql backup that does the restoration from your admin?

    Is the DB_PREFIX between the two sites the same?
    Are the database's referenced by the two filesets different?

    When you say that the live site stopped working, can you elaborate? Error messages received? Maintenance mode? Blank screen?

    Which backups were loaded? Database? Files?

    To be able to understand what was done wrong need to have detail of what was done, but really just want to get these two locations back to where they were so that sales can continue while further development is done on the new files.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  5. #5
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    182
    Plugin Contributions
    2

    Default Re: Database Issues when Upgrading - Pease Help!

    I am attempting to upgrade from 1.5.5f to 1.5.6, to up load the db back up I have to import it into the new db via phpmyadmin. The prefix for both sites were the same. The live site went blank although, I was not working on it at all. I don't have a picture of how the site looked before, but this is how it looks now without all of the sideboxes and enhancements: http://atmospherebooks.com I used Filezilla to upload the back up files, after I reloaded all of the files I used the restore feature of my cpanel to upload the db download, but it still did not work so I deleted it and tried again.

  6. #6
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    8,482
    Plugin Contributions
    9

    Default Re: Database Issues when Upgrading - Pease Help!

    You have managed to get a glitch in the code that creates the Useful Links option in the Information Menu.

    All is rocking along until the browser tries to draw that UL. The code MIGHT be in the database. Not familiar with that menu system.

  7. #7
    Join Date
    Dec 2009
    Location
    Amersfoort, The Netherlands
    Posts
    2,845
    Plugin Contributions
    25

    Default Re: Database Issues when Upgrading - Pease Help!

    My guess is that the useful links are ez-pages. In Zen Cart 1.5.6 they became multi-lingual, and your template is still using the old ez-page query

  8. #8
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    182
    Plugin Contributions
    2

    Default Re: Database Issues when Upgrading - Pease Help!

    Well, in my frustration I deleted all of the work I was doing on the demo site. I am waiting for my hosting company to restore backups from 12/14/18 when I was blissfully unaware of the 1.5.6 upgrade. In the mean while I will download zipped copy of my last good back up files and use those to try more file comparisons using WinMerge. I expected there would be problems with my template, but I did not think working in a new site would affect the present live site.

  9. #9
    Join Date
    Jul 2012
    Posts
    16,361
    Plugin Contributions
    17

    Default Re: Database Issues when Upgrading - Pease Help!

    If everything really is kept separate, there is no way that the work in one would have an effect on the other. It's almost like maybe a backup copy of the new database got loaded to the old or there was a file reference that didn't get updated and some "wire" got crossed. I say that because even if the "recent" backup of the old site were loaded to the wrong place, it would operate fine in the old fileset and cause a notification in the new fileset.

    Still can't tell exactly how file backups had anything to do with the issue because again, if the two sites were being maintained independent than there should be nothing to restore on the old site and the new site would just likely go back to non-merged files.
    ZC Installation/Maintenance Support <- Site
    Contribution for contributions welcome...

  10. #10
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    182
    Plugin Contributions
    2

    Default Re: Database Issues when Upgrading - Pease Help!

    I wonder if I did it wrong. I was fighting with the new file system, I got to step 2 and made the new database, but when I imported the db back up files it did not add the prefix so I deleted and did the import again. This looked right so I went to the zc_install step and my password would not work so I started working on that part. Somewhere, I messed everything up.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Layout Help Pease
    By mckay in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 10 Jun 2011, 01:47 PM
  2. Configure file issues when upgrading
    By cactusrunning in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 9 Nov 2010, 10:14 PM
  3. odd error when upgrading database
    By prestontmitch in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 1 Mar 2007, 04:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR