Page 13 of 13 FirstFirst ... 3111213
Results 121 to 128 of 128
  1. #121
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    I reached out on the IH5 support thread trying to understand why IH5 is not working properly. The answer I got back was to check with the template author.

    This is the problem ->https://wlcartistry.com/index.php?ma...roducts_id=374

    There is a single image loaded via IH5. The thumbnails and additional IH files are created correctly. But I am still getting broken image links. What in the template would cause this? Are you hardcoding the image to be the Med and Large image files from the ZC core? How can I fix this?

    The following is the warning log. It appears the template is looking for the missing _LRG file without letting IH handle the process.....?

    Code:
    29-Nov-2021 06:45:04 America/Chicago] Request URI: /index.php?main_page=product_info&cPath=76_103&products_id=374, IP address: 107.77.221.228
    #1  getimagesize() called at [/home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php:19]
    #2  require(/home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php) called at [/home/includes/templates/fluorspar/templates/tpl_product_info_display.php:51]
    #3  require(/home/includes/templates/fluorspar/templates/tpl_product_info_display.php) called at [/home/includes/modules/pages/product_info/main_template_vars.php:153]
    #4  require(/home/includes/modules/pages/product_info/main_template_vars.php) called at [/home/includes/templates/fluorspar/common/tpl_main_page.php:315]
    #5  require(/home/includes/templates/fluorspar/common/tpl_main_page.php) called at [/home/index.php:94]
    --> PHP Warning: getimagesize(images/large/CE3100080000_Front_LRG.jpg): failed to open stream: No such file or directory in /home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php on line 19.
    Thanks
    Chris

  2. #122
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,816
    Plugin Contributions
    80

    Default Re: Template Fluorspar

    Quote Originally Posted by g2ktcf View Post
    I reached out on the IH5 support thread trying to understand why IH5 is not working properly. The answer I got back was to check with the template author.

    This is the problem ->https://wlcartistry.com/index.php?ma...roducts_id=374

    There is a single image loaded via IH5. The thumbnails and additional IH files are created correctly. But I am still getting broken image links. What in the template would cause this? Are you hardcoding the image to be the Med and Large image files from the ZC core? How can I fix this?

    The following is the warning log. It appears the template is looking for the missing _LRG file without letting IH handle the process.....?

    Code:
    29-Nov-2021 06:45:04 America/Chicago] Request URI: /index.php?main_page=product_info&cPath=76_103&products_id=374, IP address: 107.77.221.228
    #1  getimagesize() called at [/home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php:19]
    #2  require(/home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php) called at [/home/includes/templates/fluorspar/templates/tpl_product_info_display.php:51]
    #3  require(/home/includes/templates/fluorspar/templates/tpl_product_info_display.php) called at [/home/includes/modules/pages/product_info/main_template_vars.php:153]
    #4  require(/home/includes/modules/pages/product_info/main_template_vars.php) called at [/home/includes/templates/fluorspar/common/tpl_main_page.php:315]
    #5  require(/home/includes/templates/fluorspar/common/tpl_main_page.php) called at [/home/index.php:94]
    --> PHP Warning: getimagesize(images/large/CE3100080000_Front_LRG.jpg): failed to open stream: No such file or directory in /home/includes/templates/fluorspar/templates/tpl_modules_main_product_image.php on line 19.
    Thanks
    Chris
    FWIW, it's that this template's version of tpl_modules_main_product_image.php is (for whatever reason) bypassing the use of the Zen Cart zen_image function to render those images. That function, if used, is what enables Image Handler to perform its image manipulations.

  3. #123
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    Quote Originally Posted by lat9 View Post
    FWIW, it's that this template's version of tpl_modules_main_product_image.php is (for whatever reason) bypassing the use of the Zen Cart zen_image function to render those images. That function, if used, is what enables Image Handler to perform its image manipulations.
    I am looking at that file now. This file simply echos the html reference to the files...how would I change this to make it work with IH? I have no problems editing this file as needed.

    Code:
    <?php require(DIR_WS_MODULES . zen_get_module_directory(FILENAME_MAIN_PRODUCT_IMAGE)); ?>
    
    <figure id="productMainImage" class="product-main-image" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject">
    
    <?php
    $largewidth = "1000";
    $largeheight = "1000";
    list($largewidth, $largeheight, $type, $attr) = getimagesize($products_image_large);
    
    $smallwidth = "200";
    $smallheight = "200";
    list($smallwidth, $smallheight, $type, $attr) = getimagesize($products_image_medium);
    
     echo '<a href="'.$products_image_large.'" itemprop="contentUrl" data-size="'.$largewidth.'x'.$largeheight.'" data-index="0">'. "\n";
     echo '<img src="'.$products_image_medium.'" alt="'.$products_name.'" title="'.$products_name.'" width="'.$smallwidth.'" height="'.$smallheight.'" itemprop="thumbnail" class="img-responsive" /></a>'. "\n";
    
    ?>
    </figure>

  4. #124
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    I have spent some time looking at this file vs the default template file. It appears that this is just an older version of the file.

  5. #125
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    10,816
    Plugin Contributions
    80

    Default Re: Template Fluorspar

    Quote Originally Posted by g2ktcf View Post
    I have spent some time looking at this file vs the default template file. It appears that this is just an older version of the file.
    Not so much older as very much changed from the template_default rendering. You're going to also have issues with additional images; this template provides a module override (/includes/modules/fluorspar/additional_images.php) as well, which doesn't include any of the zc156+ notifications that Image Handler uses to provide its dropin distribution.

  6. #126
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    Quote Originally Posted by g2ktcf View Post
    I have spent some time looking at this file vs the default template file. It appears that this is just an older version of the file.
    well, replacing the Fluorspar template version with the default fixed all the log warnings. But now my main product image is tiny...smaller than the image in the grid view

  7. #127
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    Quote Originally Posted by lat9 View Post
    Not so much older as very much changed from the template_default rendering. You're going to also have issues with additional images; this template provides a module override (/includes/modules/fluorspar/additional_images.php) as well, which doesn't include any of the zc156+ notifications that Image Handler uses to provide its dropin distribution.
    I removed that over ride as well. Not much has changed though.

  8. #128
    Join Date
    Feb 2011
    Location
    Near Houston, TX
    Posts
    449
    Plugin Contributions
    0

    Default Re: Template Fluorspar

    Quote Originally Posted by g2ktcf View Post
    I removed that over ride as well. Not much has changed though.

    Okay, I figured out that the main image size was being driven by configuration image values. They were previously 150 and 120 and I noticed those values in the developer console of Chrome. I increased these to 400 x 400 and now my page appears to be operating properly.

    Code:
    Product Info - Image Width	        400	
    Product Info - Image Height	400
    So I had to replace tpl_modules_main_product_image.php with the default template version and REMOVE the override includes/modules/fluorspar/additional_images.php

 

 
Page 13 of 13 FirstFirst ... 3111213

Similar Threads

  1. theme277 from template monster and replacing with new template
    By DarkAngel in forum General Questions
    Replies: 0
    Last Post: 8 Nov 2012, 07:17 AM
  2. Can't seem to get template on the admin/tools/template selection
    By avmejias in forum Templates, Stylesheets, Page Layout
    Replies: 6
    Last Post: 19 Aug 2012, 07:39 AM
  3. Replies: 8
    Last Post: 29 Apr 2011, 07:53 PM
  4. Template selection page not viewable after uploading custom template
    By mek113 in forum Templates, Stylesheets, Page Layout
    Replies: 6
    Last Post: 28 Apr 2011, 05:16 PM
  5. open_basedir restriction in effect - trying to use tm001 template monster template
    By prantiC in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 10 Aug 2007, 10:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR