Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    7,503
    Plugin Contributions
    8

    Default Re: Upgrading from 155 to 156: Support for ".htaccess" files is not enabled.

    That worked which leads me to believe we have more of a problem.

    With it set to https, the folks without an SSL will get an error and with it left to http, the folks WITH SSL will get an error. It won't work with just // as some links will.

    Do you gather the same from the results?
    Did you read the posting tips?!?
    Responsive Color Changes for 155-156c demo here.
    Zen Cart PCI Compatible Hosting

  2. #12
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,187
    Plugin Contributions
    96

    Default Re: Upgrading from 155 to 156: Support for ".htaccess" files is not enabled.

    Don't worry - this issue will be fixed before the release. Thank you for your help in testing.

    Please proceed - let's see what else you can find!
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  3. #13
    Join Date
    Feb 2006
    Location
    Tampa Bay, Florida
    Posts
    7,187
    Plugin Contributions
    96

    Default Re: Upgrading from 155 to 156: Support for ".htaccess" files is not enabled.

    If you have time, it would be a big help for you to pull the file out of

    https://github.com/zencart/zencart/pull/3249

    and try this test again. Should work for both http:// and https:// environments.
    That Software Guy. My Store: Zen Cart Modifications
    Available for hire - See my ad in Services
    Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.

  4. #14
    Join Date
    Jan 2004
    Posts
    65,402
    Blog Entries
    7
    Plugin Contributions
    232

    Default Re: Upgrading from 155 to 156: Support for ".htaccess" files is not enabled.

    Quote Originally Posted by dbltoe View Post
    Revisiting due to .htaccess error loading trial 1.5.7

    When I try the "filenames.php" test, I get status "301 Moved Permanently", which redirects to a page "403.shtml", which itself returns status "404 Not Found"

    Maybe some of this info will help
    Code:
    ===[[email protected] 1102428]# curl -ILs http://test.netzencommerce.com/includes/filenames.php
    HTTP/1.1 301 Moved Permanently
    Date: Mon, 13 Apr 2020 20:35:51 GMT
    Server: Apache
    Location: https://test.netzencommerce.com/403.shtml
    Content-Type: text/html; charset=iso-8859-1
    
    
    HTTP/1.1 404 Not Found
    Date: Mon, 13 Apr 2020 20:35:51 GMT
    Server: Apache
    Content-Type: text/html; charset=iso-8859-1
    ===
    You'll notice that zc_install is indeed following the server's redirect.
    So, why not fix the server's broken redirect instead of having the server return a 404-not-found?
    Zen Cart shouldn't have to magically figure out why your server is giving an incorrect response.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donate to: DrByte directly or to the Zen Cart team as a whole

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

 

 
Page 2 of 2 FirstFirst 12

Similar Threads

  1. v155 zc_install keeps telling me the files are not writable
    By bscho in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 11 Jul 2016, 09:42 PM
  2. Nginx equivalents for htaccess files
    By Dayo in forum Code Collaboration
    Replies: 6
    Last Post: 8 May 2016, 06:59 PM
  3. v155 zc_install: ini setting session.use_trans_sid is enabled
    By lat9 in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 4 May 2016, 10:11 PM
  4. Replies: 3
    Last Post: 25 Nov 2010, 02:10 PM
  5. Are there .htaccess files for Apache 1.3 available for ZC 1.3.x?
    By neekfenwick in forum General Questions
    Replies: 2
    Last Post: 3 Nov 2010, 04:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR