Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2012
    Posts
    76
    Plugin Contributions
    0

    Default New products listing month shows abnormal characters

    ZC 1.5.0, php 5.6

    I have a Finnish language pack installed and Finnish is only language in the shop. We have two months June and July which have a letter ń in them and now I noticed it shows up funny question mark in new products for June in the front page.

    Name:  language_error.png
Views: 73
Size:  743 Bytes

    I checked the Finnish language packs locale and checked supported locale from server and settings do match. Also all the other language related pages shows all the umlauts correctly, only this month name shows wrong.

    Many years ago the shop had latin-swedish encoding and few years ago it was transferred to utf-8 encoding.

    Where should I start to find the error?

    Any help would be greatly appreciated with this small but annoying error.

  2. #2
    Join Date
    Sep 2009
    Location
    Stuart, FL
    Posts
    8,524
    Plugin Contributions
    68

    Default Re: New products listing month shows abnormal characters

    Refer to this (https://vinosdefrutastropicales.com/blog/?p=309) blog-posting for possible solutions.

  3. #3
    Join Date
    Aug 2007
    Location
    Gijˇn, Asturias, Spain
    Posts
    1,957
    Plugin Contributions
    29

    Default Re: New products listing month shows abnormal characters

    The days and months are php-generated. This thread adds more information.
    https://github.com/zencart/zencart/issues/973

    and I always like to refer back to this for those with insomnia:
    https://www.zen-cart.com/showthread....e-on-my-server
    Steve
    github.com/torvista: Apsona (php7), BackupMySQL Admin/Auto, CEON URI Mapping (php7), Product Listing Sorter, Redsys payment module, Spanish Language Pack and more...

  4. #4
    Join Date
    Mar 2012
    Posts
    76
    Plugin Contributions
    0

    Default Re: New products listing month shows abnormal characters

    Thank you lat9 and torvista, I really am getting some imsomnia but the error was actually quite simple:

    finnish.php was "shortened" by unknown translator and was only containing part of info setlocale needs, it was wrongly formatted as

    Code:
    (LC_TIME, 'fi_FI')
    when it should have been:
    Code:
    // look in your $PATH_LOCALE/locale directory for available locales..
      @setlocale(LC_TIME, 'fi_FI.utf8');
    Now php locale time works correctly.

    If someone wants to know their server supported locales below is a script you can upload to server and check it out. Just change the fi to your country code:

    Code:
    <?php
    echo "<hr><br>The available 'locale' strings for 'fi' on this server are:<br>";
    echo '<pre>';
    system('locale -a | grep -i fi');
    echo '</pre>';
    ?>

 

 

Similar Threads

  1. Inserting a New Title instead of "New Products for (insert month)
    By rarinstructors in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 28 Feb 2011, 09:34 PM
  2. Replies: 2
    Last Post: 16 Nov 2009, 07:35 AM
  3. Replies: 4
    Last Post: 20 Jun 2009, 04:06 PM
  4. how do I change "New Products for 'month' and 'monthly specials for 'month'
    By Fatum in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 20 Mar 2008, 07:08 PM
  5. Upcoming in 2 months shows in current month new products why and how can I remove
    By nwironsales in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 16 Oct 2006, 06:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR